Remove All Ads from XDA

Invalid missing SIM card

4 posts
Thanks Meter: 0
By vaidod, Junior Member on 27th January 2009, 07:35 AM
Thread Deleted Email Thread
I am a complete newbie. Own 8125 CIngular. Worked fine, I switched to T-mobile, unlocked it with lockiwiz 3a (thanks, machinagod). It worked great until I for some reasons had to pull the battery out. It quit recognizing sim in ther - any sim - old Att or new TM. IT is G3 phone, had 2.25 IPL/SPL. I flashed to TM 2.26 (per all the guides here), gsm 02.25.11, Everything loads up great except for the phone part - It's still "missing or invalid sim" What do I do? Please, help Thanks a lot in advance
3rd February 2009, 06:39 PM |#2  
Senior Member
Flag Rising Sun
Thanks Meter: 0
did you try following the unlock procedure again?
4th February 2009, 11:29 PM |#3  
Flag Ljubljana
Thanks Meter: 1
try to move sim a little bit.. maybe it's displaced?
That what happened to me.
Good luck!
5th February 2009, 12:25 AM |#4  
Junior Member
Thanks Meter: 0
To echo the post above mine, I had that same problem at one point, and just taking the SIM card out and putting it back in solved the problem.
8th February 2009, 05:22 PM |#5  
Senior Member
Thanks Meter: 38
I faced a similar problem when I went to another country and used a local sim of that country. I kept putting the phone in 'airplane mode' for 5 minutes and when got that 'airline mode' off, it worked. Cumbursome but it worked.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes