Remove All Ads from XDA

New and improved Apps to SD(more stable, more powerful, etc) Tutorial

1,094 posts
Thanks Meter: 9
By, Senior Member on 6th May 2009, 11:05 PM
Post Reply Email Thread
31st May 2009, 09:19 PM |#991  
borodin1's Avatar
Senior Member
Flag Minneapolis MN
Thanks Meter: 45
Originally Posted by sjbayer3

okay, I copied both the AND the extracted files to my SD card and it says AppstoSD2.apk No such file or directory.

furthermore, when I unzip it its not an apk but a few files and a few folders:
META-INF (folder)
res (folder)

Please help

Don't unzip it... just rename it toAppstoSD2.apk
31st May 2009, 09:48 PM |#992  
driguez's Avatar
Senior Member
Flag O-Town
Thanks Meter: 28
God, i been dying to A2SD but i read nothing but small issues which i dont want to deal with... Hopefully this will become even better and more stable. Till then ill stick with my 20mb free.
1st June 2009, 03:14 AM |#993  
Senior Member
Thanks Meter: 0
these are the best folders to move for optimal space and speed
This is the old school way but the exact order to do it in maybe scripts can be modded.

cp -a /system/app system/sd/app
mv /system/sd/app /system/sd/appsys

<<<hero only>>> cp -a /system/app_s /system/sd

cp -a /data/app /system/sd
cp -a /data/app-private /system/sd
cp -a /data/dalvik-cache /system/sd

reboot in recovery
mount system

rm -rf /system/app
<<hero>> rm -rf /system/app_s

ln -s /system/sd/appsys /system/app
ln -s /system/sd/app_s /system/app_s

mount data

rm -rf /data/app
rm -rf /data/app-private
rm -rf /data/dalvik-cache

ln -s /system/sd/app /data/app
ln -s /system/sd/app-private /data/app-private
ln -s /system/sd/dalvik-cache /data/dalvik-cache
1st June 2009, 03:34 AM |#994  
Thanks Meter: 3
Any known issues with moving dalvik cache to sd? I have app and app-private on sd now. Thanks!
1st June 2009, 03:53 AM |#995  
cronin4392's Avatar
Senior Member
Thanks Meter: 0
seems like i bricked my phone with this, better explanation here:

any help would be appreciated.
1st June 2009, 03:58 AM |#996  
Junior Member
Thanks Meter: 0
after a wipe to the dudes build.. i install mybackup pro so i can upload apps2sd app onto my phone

when i move apps2sd all of my apps from the market including mybackup pro are erased off my phone and if i restart my phone it'll stay in a loop

is this an issue with my sd card ? thanks in advance
1st June 2009, 04:18 AM |#997  
Senior Member
Thanks Meter: 315
There's definitely seems to be some performance issues with unionfs.

I can get my g1 to lock up if I'm running unionfs with apps/app-private/dalvik-cache on the sd card by doing the following:

1. Play IMEEM in the background
2. Go to this website

If I do the same thing with everything in internal flash or using symlink a2sd method, I don't get the same lockup.

I'm sticking with symlinks for now.

I also see more menu lagging with unionfs. Meaning if I press "menu", it takes a split second to come up, while using symlinks its faster.
1st June 2009, 05:31 AM |#998  
beagz's Avatar
Senior Member
Flag Greenacres, FL
Thanks Meter: 23
I always thought the stuttering was just something I was doing.

AUFS seems to be reported as better. Any chance of switching to that other than using cyanogen's build?
1st June 2009, 05:35 AM |#999  
Senior Member
Thanks Meter: 315
Originally Posted by beagz

I always thought the stuttering was just something I was doing.

AUFS seems to be reported as better. Any chance of switching to that other than using cyanogen's build?

tried the aufs boot img from cynaogen and get the same problems.
1st June 2009, 06:07 AM |#1000  
Senior Member
San Antonio, Tx
Thanks Meter: 1
i ran the appstosd2 app and partitioned my card and my internal memory says like 775mb. The first page is a bit confusing though im not sure which step to pick up the process on after running the app. anybody want to throw me a bone? thanks
1st June 2009, 11:16 AM |#1001  
Senior Member
Flag Hong Kong
Thanks Meter: 4
i've done the first part, but when i run apps2sd 2 app, it tells me 'oops, looks like you need to go through the tutorial to set up apps to sd.'
is this because i already partitioned my sd card??

please help

Quote: (I started from a fresh wipe and flash of jf1.51 adp.
A newly formatted fat32, non partitioned sd.
Put the init.rc and on the sd (the files NOT the zip)

Then go to the terminal emulator and typed:
cp /sdcard/init.rc /data/
cp /sdcard/ /data/

Then reboot

Next I ran the apps2sd 2 app. It will ask you how much to you want to partition. I did 3000mb the first successful time and the dreaded low mem notice would not leave the status bar. I have read not to make it more then 1500mb. Have a good connection, dont force close it. It will reboot.

Next, after the reboot, I ran the apps2sd 2 app again and pressed "copy apps to sd" (let it do its thing)

Next I went back to the emulator and typed:
mkdir /system/sd/app-private
mkdir /system/sd/dalvik-cache

Go back to the apps2sd 2 app and hit move dalvik-cache.
Reboot for good measure and your done.) Quote
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes