FORUMS
Remove All Ads from XDA

[ROM] Ravenge - Optimised Rogers Modification - aka 'ramjet' (r7 updated: 24-June-09)

75 posts
Thanks Meter: 0
 
By ravenge, Member on 9th June 2009, 09:43 AM
Post Reply Email Thread
UPDATES

Updated with r7

ravenge-ramjet-r7-signed-update-AU.zip
md5sum: f90b7db7768f6d431af079e97775e288


This patch includes some signifant changes to the guts of the build like the kernel and a2sd. If you experience problems, a wipe may be necessary.

+more useful apps
/data/app
astrid
locale
twitterride

+boot.img/kernel change to Cyanogen's 2.6.27.25 (anticipatory iosched, enabled multicast and max cpufreq at 528MHz)
This should fix a LOT of problems people were having, including the "coma" bug where the phone would run out of memory and wouldn't wake from standby.

a2sd now uses bind mounts (instead of aufs) allowing better stability and compatibility etc.

+replaced default google maps with newer one
+IM app. (let me know if I missed some files)
/system/app/IM.apk
/system/app/TmoImPlugin.apk
+replaced libhtc_ril.so with the one from ion. This should give '3G' and allow HQ youtube over 3G.
+boot.mp3 update
+localisation settings language default to en_AU for locale and dialer \customize\MNS\default.xml
+modified update-script (now closer to cyanogens) and
cleaned out xbin



Updated with r6

linky: ravenge-ramjet-r6-signed-update-AU.zip
md5sum:
a6c7e0eeb0145e5ca18e06e755a10d11

APPS
/system/app
+fix amazon.mp3
+google voice search (yay)
+spareparts
+updated Quick office to 1.0.1
+HTC Sync (W00t) seems to work too, which is a bonus
+IM (hopefully - someone please check)

/data/app
+FBook.apk
+updated Forecast Widget by Koxx - http://forum.xda-developers.com/showthread.php?t=511351
+added the google maps update 3.1.1 & mymaps 1.1.6 (to /data/app) uninstall it if you dont want it
+smspopup 0.9.96
+linda file manager 1.2.10
+NetCounter 0.8

Cosmetic
+new boot animation screen bkg (was bored lol)

Audio Mod
included Meltus' V5.3+bluetooth fix (if you prefer a different one, go see his thread)

default wallpaper switched

Free space:
with pre-installed apps
/data: 91904K total, 34336K used, 57568K available (block size 4096)

Without pre-installed apps
/data: 91904K total, 29760K used, 62144K available (block size 4096)


================================================== ======

Updated with r5a

ravenge-ramjet-r5a-signed-update-AU.zip
md5sum: 9d294c49d853ac0db67a9571d115898e

r5a: simply fixes a n00b mistake where I didn't upload the rom that included the new lines in the update-script.

r5:
+altered mount auto in a2sd to use busybox to avoid boot loop, allowing potential compatibility for other card types.
(though i'm still fairly certain that e2fsk and tune2fs are meant to convert the partition to ext3 file system anyway)
+Updated Meltus V4 (quality) loud mod. Sounds better than the V3 though not quite as loud.
+moved some apps to /data/app to clear up some system space and make it possible to update/remove them as normal if required. (this required an update to the update-script)

================================================== ======

Updated with r4
Since I don't have a lot of room left in my initial post at the moment (needs tidying) here is my changelog for r4

the major focus being Default APNs!

(thanks to shellite for having more foresight than me and getting his original files backed up!)

Changelog:
ravenge-rogers-r4-signed-update-AU.zip 09-06-2009
Code:
apns-conf fixed for AU and included more carriers (needs testing)
	optus internet -works
	optus mms -works
	IDEAS -untested
	IDEAS MMS -untested
	Three -untested
	Three MMS -untested
	Vodafone Internet -untested
	Vodafone MMS -untested
	Telstra 3G EDGE GPRS -untested
	Telstra GPRS -untested
	Telstra 3G Databundle -untested
	Telstra 3G Pay by time -untested
	Vodafone NZ -untested
	Vodafone NZ MMS -untested
voicemail-conf added for Optus AU. If anyone has more carriers to add, let me know 

updated build.prop
I could use some help confirming/fixing any of the APNs I used, as I'm with OPTUS I don't have the opportunity to work with the other carriers. I'd love to hear from you.
Attached Files
File Type: zip Updated APNs for AU.zip - [Click for QR Code] (2.6 KB, 24 views)
 
 
9th June 2009, 09:43 AM |#2  
ravenge's Avatar
OP Member
Flag Adelaide
Thanks Meter: 0
 
More
Exclamation [ROM] Ravenge - Optimised Rogers Modification - aka 'ramjet' (r7 updated: 24-June-09)
Hey all,

Firstly I'll introduce myself as I'm relatively new around here. My name is Geoff (aka ravenge) and I'm a 22yo, IT Systems Support Manager in South Australia. Things that take up most of my time lately are Work, LANning and tinkering with my G1 that I've had since a few weeks after Optus released them in AU.

Since purchasing my phone, I've thoroughly enjoyed gaining root, and playing with the works of JF, TD, Haykuro and Cyanogen (to name a few). In a nutshell I've tried dozens of excellent ROMs thanks to these guys.

After much experimentation, I decided to move away from the shiny hero as I found it to be rather unreliable and relatively slow. I loved the HTC apps of Hr's Sapphire ports and I loved the speed of ION, then came Rogers, a fully finished, fully packaged rom made by HTC for Rogers in Canada. This meant that the HTC apps were stock and didn't need any porting, and more importantly the rom was designed for the G1 so it ran fantastically on my handset!

I loved the rom but, stock, I found it a little lacking in the features dept. Many people have repacked their own flavours of Rogers, but none fitted my desire for a 'complete' rom.

Since I rebuild my phone consistantly, I wanted a rom that has all the core applications that I use. firstly Apps2SD with ext3 had to be standard. I wanted superuser, terminal, mtt browser, and all the other goodies you've seen floating around the forums. I also wanted to change some options to AU standards so that i wouldn't need to do it later. An example was the Date format from MM-dd-yyyy to dd-MM-yyyy.

After much bug testing, and a LOT of help from awesome xda users such as Haykuro, Cyanogen, MarcusMaximus. I'm happy to have finally reached a stable build.

Starting with the original Rogers rom graciously provided by Haykuro here

History:
This Build is based on the Rogers rom provided by haykuro. I take no ownership for the original files, or any of the
modifications made (except where labelled otherwise).This Build would not be possible without the awesome works of: Haykuro,
JesusFreke, Cyanogen, TheDudeOfLife, and all the developers of the apps included. <3 your work!

To make it significantly easier to differentiate between my rom and other rogers repacks, I am nicknaming mine 'ramjet'.

r7 FEATURES LIST:
Quote:

Optimisations from Cyanogen's 3.4.4 build:
Cyanogen's 2.6.27.25 kernel (anticipatory iosched, enabled multicast and max cpufreq at 528MHz)
boot.img
a2sd scripts - automatic A2SD using bind mounts
various other file system tools and libraries

AUTO Apps to SD - Standard:
As mentioned above, we're now using bind mounts. This means more stability and flexibility for filesystems. Apps to SD will automatically run for you with next to no setup required (apart from needing a partitioned SD card). If you don't have the partition, it will operate as per any build without a2sd (more or less)

Applications:
-All rogers specific apps removed
/system/app
+amazon mp3
+superuser
+Terminal Emulator
+Browser with multitouch (will possibly replace with HTC browser)
+bugreport.apk
+Google Voice Search
+Latest Google Maps
+spareparts
+updated Quick office to 1.0.1
+HTC Sync
+IM

pre-installed to /data/app
+Backup for root users
+apps2sd
+wifitether 1.51
+Fbook.apk
+Forecast Widget by Koxx
+mymaps 1.1.6
+smspopup 0.9.96
+linda file manager 1.2.10
+NetCounter 0.8
+Locale 0.611 beta
+Astrid 2.8.6
+TwitterRide 1.3.1

Cosmetics:
added images (my own)
in app/launcher.apk
transparent handle for app drawer (just because I prefer it)
in framework/framework-res.apk
battery depletion images with % included (cause I didn't like the battery icon going GREEN GREEN GREEN GREEN RED-FLAT)
NOTE this works off of modifications on the original images. As such, there are only levels at 0% 10% 20% 40% 60% 80% and 100%.

boot animation / audio copied from hero, cause its fancier and modified to include some build details and a picture of roger ramjet (note, Roger Ramjet the cartoon character is copyright of someone else, NOT ME)

3G:
A HTC lib was causing some problems for HQ youtube over 3G. Replacing with the lib from ION seems to fix it.

Audio Mod:
Max Volume mod by Meltus (V5.3+Bluetooth fix)

Dalvicvm:
dalvicvm from ION - cause it's shown speed improvements

Localisations:
Changed date format default to dd-MM-yyyy
Changed build.prop ro.product.locale.region=AU
Added Haykuro's APN List, modified by me to include the AU Carrier 'YES OPTUS' and many other AU carriers (that still need testing) http://forum.xda-developers.com/show....php?p=3891703
Added Optus voicemail config.
Changed default languages to en-AU for dialer and ime.


WHAT YOU NEED!

TODO:
  • APNS/Voicemail - Read up HERE
  • Homescreen customisation, such as TD's 5 home screens mod, when I can get my hands on the 'how to' doc.
  • Investigate ODEX for /system/app

FAQ:
  • Apps 2 SD: a lot of people have asked "Do I have to use apps to sd?" - you do not.
  • "if i had apps to sd before?" - thanks to cyanogen's handywork, it will automatically find what you have and set it up for you.
  • "can you port something from hero?" - probably not, the launchers / framework are different causing problems in most circumstances
  • "Do I need to wipe?" Probably. You may or may not need to wipe depending on where you've come from. You might be able to get away with just deleting cache (note cache may also be stored on your sd card from apps2sd and will need to be removed manually). If you get lots of force closes, chances are you need a wipe!
  • Has anyone made any themes? OPhone-V1.0 - ported by barakinflorida

P.S. I added a splash screen for those who know what it is.

If you have any problems, I'll do my best to support them. If you don't like my rom, use someone elses. If you have any useful suggestions, I'd love to hear them!

Regards,
ravenge


CREDITS:
Quote:

This build was based on Haykuro's rogers.
In the past, Haykuro has been legendary at providing awesome HTC stuff ported from here and there, and a lot of the great roms that are around today are especially thanks to him.
If you would like to support Haykuro, you can buy him some nesquik!

I also got a lot of help, and used a lot of Cyaonogen's optimized android files and kernals from his latest builds. This helped me implement Apps2SD and get the build running nice and fast. For mor information about all of his great work, take a look here
Feel free to Buy Cyanogen a beer!

The AppstoSD2.apk Application comes straight from MarcusMaximus with an updated icon by me.
If you like this App please support Marcus by donating (aka purchasing it) in the Paid market.
MarcusMaximus and his Apps2SD thread is [http://tinyurl.com/n2ah4z]here.[/url]

As mentioned I have used Meltus's audio mod. The one I used is quite loud so you may prefer to check out Meltus' thread here and apply your own. Donate to Meltus here

I also believe that a lot of credit to certain parts of the android development should go to JesusFreke.
Go visit his Blog here and honour his work by donating here

The apks I included were from various sources and in general were extracted from other peoples builds, for example TheDude's 1.2b or Cyanogen or Haykuro's work. If I have forgotton to credit someone somewhere (which is pretty likely - SORRY!) Please PM me so I can give credit where it's due!

Previous versions:
r3 AU
r4 AU
r5a AU
r6 AU
Attached Thumbnails
Click image for larger version

Name:	dialler1.jpg
Views:	1083
Size:	21.2 KB
ID:	199378   Click image for larger version

Name:	dialler2.png
Views:	1013
Size:	18.1 KB
ID:	199379   Click image for larger version

Name:	lock.jpg
Views:	1042
Size:	19.6 KB
ID:	199380   Click image for larger version

Name:	newmap.jpg
Views:	928
Size:	20.5 KB
ID:	199381   Click image for larger version

Name:	voicesearch.jpg
Views:	865
Size:	21.4 KB
ID:	199382   Click image for larger version

Name:	weather.jpg
Views:	1161
Size:	19.6 KB
ID:	199383  
Attached Files
File Type: zip ramjet splash.zip - [Click for QR Code] (21.9 KB, 141 views)
File Type: zip rogers-buildinfo.zip - [Click for QR Code] (3.7 KB, 48 views)
9th June 2009, 09:50 AM |#3  
Senior Member
Thanks Meter: 17
 
More
I'll try this out, sounds good! Its good to see an Australian build pop up, now I won't have to deal with switching date formats every time xP
9th June 2009, 10:03 AM |#4  
Senior Member
Thanks Meter: 10
 
More
in case you didn't know.. it's Rogers without the D.. they're a mobile carrier in Canada.
9th June 2009, 10:05 AM |#5  
robpet2's Avatar
Senior Member
Flag Virginia
Thanks Meter: 77
 
More
sounds good.. but does this only work with ext3?? i have ext2
9th June 2009, 10:05 AM |#6  
ravenge's Avatar
OP Member
Flag Adelaide
Thanks Meter: 0
 
More
Quote:
Originally Posted by yingjai

in case you didn't know.. it's Rogers without the D.. they're a mobile carrier in Canada.

haha thanks, correcting now
9th June 2009, 10:08 AM |#7  
ravenge's Avatar
OP Member
Flag Adelaide
Thanks Meter: 0
 
More
Quote:
Originally Posted by robpet2

sounds good.. but does this only work with ext3?? i have ext2

Theoretically, cyanogen's script converts the filesystem to ext3 to make it compatible, I'm yet to try it though. (adding it to my TODO list)

Edit: Apologies for the double post. didn't realise I couldn't delete unwanted posts.
9th June 2009, 11:16 AM |#8  
Member
Flag Ottawa
Thanks Meter: 3
 
More
holy moly the HTC start-up sound went through my ear drums~ I am still at the HTC screen but I guess it's gonna take a little longer than ususal due to the extensive inclusion of this and that I think I'm gonna love this thanks Ravenge~ I did a wipe and it works now... hey hold on... omg... My Apps2SD is working too!!... my ext2 was corrupted though I just kept on using the same sd regardless the reduced capacity... (Too busy these days) now it mounts back nicely...

wow... wow... this is insane... btw u have all the goodies working flawlessly.
9th June 2009, 11:48 AM |#9  
jmon777's Avatar
Senior Member
Thanks Meter: 1
 
More
man i told my slef i was not going to try rogers but...ok you talked me into to it.
9th June 2009, 12:59 PM |#10  
Member
Thanks Meter: 10
 
Donate to Me
More
Use busybox to mount -t auto
Quote:
Originally Posted by ravenge

NOTE: Originally this is supposed to support ext2 however, leaving mount -t auto caused a boot loop in my build. I imagine something is missing.
If anyone could provide some insight, this would be awesome. For the time being ONLY ext3 is supported.

The stock 'mount' binary doesn't support an auto mount. If you do a logcat, you'll see it's failing to mount the second partition and therefore can't access the dalvik cache, which is required for a full boot.

The fix is easy, just use 'busybox mount' instead of the regular 'mount'. You can even do this from an adb shell from inside the boot loop and you'll see the system finishes booting and comes online
9th June 2009, 01:38 PM |#11  
ravenge's Avatar
OP Member
Flag Adelaide
Thanks Meter: 0
 
More
Quote:
Originally Posted by Kinslayer81

The fix is easy, just use 'busybox mount' instead of the regular 'mount'. You can even do this from an adb shell from inside the boot loop and you'll see the system finishes booting and comes online

Great tip, I'll give that a shot for future releases.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes