Remove All Ads from XDA
Honor View 10

Push-mail fails..?

50 posts
Thanks Meter: 0
By Archatos, Member on 13th August 2009, 07:58 PM
Post Reply Email Thread

A couple of days ago, I allready posted this thread but somehow nobody's responding.


Since last week I'm the owner of an HTC Hero. One of the features I like(d) most is the support for Push-mail. But since a few days it seems to be broken and I can't get it fixed.

I'm having Zarafa with Z-Push (open source Exchange-implementation) which worked fine first couple of days, but all of a sudden it stopped working. This is my config:
Zarafa mailserver on Debian Linux with Apache and (self-signed) SSL certificate. This is the configuration which worked until 2 days ago and nothing changed on that config.

This is what I tried:
- Turn phone off and on: Does not work
- Manually sync: Works; Push sometimes keeps working for up to one hour and then stops also.
- Disable downloading on arrival and start polling every [x] minutes/hours: Works
- Disable SSL (pushmail over http in stead of https): Does not work
- Remove and re-add account: Does not work
- Start using WiFi in stead of 3G: Does not work

I checked the serverlogs of of my mailserver but I can't find anything strange.

In another forum I found somebody who uses Exchange 2003 which stopped syncing after several days without any reason.

I'd like to keep using Push-mail because (AFAIK) it isn't exhausting the battery as much as polling every [x] minutes.

Does anybody have a clue on how to solve this or at least how to troubleshoot this?

I hope I'll have more luck in Q&A.
13th August 2009, 10:25 PM |#2  
Senior Member
Flag Sunny Yorkshire
Thanks Meter: 2
Its probably because nobody has used the same set up as yourself, I for one have not heard of half the stuff in your post so wouldn't be able to answer.

You don't give much info as to whats wrong, it just "stops working". Do you get errors? is it trying to connect? Timing out?

Installed anything after installing this?

Is the exchange actually working to push email? I mean on the server side not the phone?

Network? Tried Turning the phone off and back on? Tried a hard reset and start again?

Sometimes I do a hard reset if something doesnt work and install things 1 by 1 after to see what causes the issue, its usually something thats conflicting.
18th August 2009, 06:45 PM |#3  
OP Member
Thanks Meter: 0

Thnx for your reply. I've been gone for several days, so that's why I didn't respond earlier.

I've been using Zarafa for quite some time, also with another phone (SE Xperia X1) and Push-mail works perfectly there. And it's been working fine for several days on the Hero too, but all of a sudden it stopped. I can make it work for up to an hour (at very most) by setting the download frequency to 'on arrival' which also proofs the server-side should be OK.

I'm not getting any errormessages, not on the phone nor on the server.

I've tried all things you mentioned, except a hard-reset. I'll try that later today as I want to make a backup first.

The funny thing is that I saw somebody else at this forum having the same symptoms, only with a real MS Exchange-server. Sadly enough, I can't find that post anymore...
19th August 2009, 10:48 AM |#4  
OP Member
Thanks Meter: 0

A couple of days ago I removed some applications (funny gadgets, nothing special) because I didn't use them anymore. And yesterday I set the DL-frequency to 'on arrival' and until now it works flawlessly!

I don't know if there's any relation between these 2 events but somehow it's working again.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes