Hard-SPL Unlocker for Rhodium (AT&T Tilt 2) Released and Updated! New FAQ added!

42 posts
Thanks Meter: 39
By OliNex, Member on 20th August 2009, 12:19 AM
Post Reply Email Thread
*****Hard-SPL Release Time!!!!*****

NOTE: This is *NOT* a SIM UNLOCKER, nor does it security unlock for
other radios. If you need that,
This Hard-SPL unlocker will allow you to install a custom Rom cooked by the many fine chef's here on XDA.


People with a CDMA device trying to run this GSM tool will get a sync
error, because the package is not compatible.*

Please read the FAQ page if you do not understand what a Hard-SPL is
Flashing your First Rom (For Noobs) - Please Click here

*Important:* Each user gets 1 license. You may get 2-3 on request if
needed and if you have replaced your device after a warranty issue. The licenses are valid forever, and all this works as
transparently as possible, so it won't be a problem. Businesses who need
to unlock more devices than that, can purchase it.
talk to cmonex or use if you want to discuss
bulk unlocking.

You can send a request for 1-2 more devices for private user (free) at (ONLY at this link, not in PM).
Make sure your are selecting the correct help request, <----this is important!!!


* This tool is for Rhodium (Touch Pro 2).
* If you have Vista or Windows 7, WMDC update to at least version
6.1 ->

***First: Beware that your Anti-Virus protection ***may Cause a issue with the downloading process and installation of this Hard-SPL***
If it does , disable it, then proceed with the download and installation of the Hard-SPL, Again This Hard-SPL download is not a Virus...

Next insure you have at least 50% battery left and also disable your screen saver...DO NOT RUN any other programs while this operation is Running.


* Download Hard-SPL tool from the attached file below
* Extract it to an empty folder.
* Connect the device to the PC with a USB cable.*** Do not Disconnect !!!
* Sync the device with WMDC or ActiveSync.
* Make sure the cellular radio is on with a data connection, because
Internet access is required as the program checks online for
updates and the license.
* Run Rhodium-HardSPL_V2_00R3.exe on the PC. It must be launched
from a local drive, not a network location. XP requires
Administrator privileges. Vista/Windows 7 should automatically
prompt you to allow it to run in Administrator mode. Allow it to
do so. If it doesn't, right click and select "Run as

" If you get an anti-virus warning, please ignore
it. It contains no harmful code. This false positive is due to a
packer being used to compress it.

* Follow steps as prompted in the Hard-SPL program.
If this is the first run of Hard-SPL on a device after hard reset, you should
select Automatic flash mode (the first button in Welcome screen).
* It will ask you to wait while it prepares for the flashing; press OK.
* Now it should go through without any error messages, if one does
pop up, then please follow the instructions included in the error
text. If no specific instruction is shown, then ask for help in
the thread, but this should not ever occur as this means a fatal
error occurred.
* At this point the device did hopefully went to a black screen
reporting version as 1.10.C-SSPL only using "info 7" in mtty, this
is the SSPL version, which is temporary. The RUU will then
instantly launch.
* SPL will now flash. The device will automatically reboot. Job done.
* To confirm you have installed properly, go into bootloader mode
(Reset the device while holding the volume down button), and
verify the screen shows 0.85.OliNex, which is the Hard-SPL version.


* You should generally go for Automatic flash mode. The Manual flash
option is only to be used as noted below. You must only attempt
the Manual mode option if Automatic flash mode or SSPL-Manual.exe
already put device in black screen. Any other errors triggered
while running in Autoflash mode will need to be fixed as
instructed in the error message.

* If you get an error message for the Hard-SPL program that says it
cannot connect to the device, then use the cab file that the
Hard-SPL program asks you to install on device.

* Once you install the cab on the device, rerun the Hard-SPL
program. DO NOT freak out as your device appears to completely
power off. Leave the USB cable plugged into device and computer
and follow onscreen prompts.

* When the RUU says it will hard reset, don't worry. It isn't going
to do that. Also, when it says the flash will take 10 minutes,
ignore that. It will only take a minute or so.

* This is unsigned Hard-SPL. No limitations on flashing ROMs (except
of course some Radios). Also, this has overwrite protection
against HTC RUU's overwriting Hard-SPL with a stock one. This
means that if someone needs to revert to stock SPL for warranty
reasons, a stock SPL downgrade package is required and is posted
as an attachment below. Use this relocker **ONLY** if you need to
return the phone for warranty, and **ONLY** use it as the last
step after reflashing stock OS and radio. See steps at the end of
this post about how to reflash stock SPL.

* Anyone having USB problems with the device after it entered SSPL
mode, please copy SSPL-Manual-Rhodium.exe from attachment in this post, copy it to the
device and run it. then once the screen has gone black, run the
Hard-SPL package on the PC and you must select Manual flash
option. **important*:* make sure that the USB cable is plugged in
and device is synced to Windows Mobile even if doing manual method.
* Do not use this RUU for anything other than SPL flashing (i.e.
hardspl or stock spl restore). Nothing other than SPL's made by
Olinex team, using OliNex custom cert, which is not public, will
flash to make SSPL more secure. If you want to flash some other
ROM, then use the shipped RUU or Rhodium customRUU.
* For developers asking: Hard-SPL is not based on MFG SPL, as it can
only be used for development and hacking, contact cmonex in PM if
you need that one.

* Supported OS versions: both 32-bit and 64-bit XP, Vista, Windows 7
and later. Windows 2000 and lower were not tested. Also, the
program may be unstable or not work on Virtual systems, so it's
recommended to try outside Virtual OS software. Also,to verify the
version: if Hard-SPL package says V200R in first Welcome dialog
title and version 2.00 in About box, it is the latest version, not
some crappy beta/old version.

*Troubleshooting* and *Step by Step on reflashing stock SPL* are in next
post below! Please take the time to read them, they could help keep you from banging your head on the keyboard and saying "Why is this not working!!!"


First, "OliNex" is a team which means: cmonex + Olipro
Olipro -> Concept of EXE program that runs on the PC, Hard-SPL concept,
server-side license code and maintaining the licenses.
cmonex -> HSPL package on PC, SSPL loader for windows mobile and SSPL
binary. Hard-SPL binary. (SSPL loader: partially based on haret and old
pof & Olipro jumpspl code)

*Donations are always appreciated, the Hard-SPL program will provide you
with a link at the end of the process to make it easier. Any little bit
helps! Thank you and enjoy!*
The Following 4 Users Say Thank You to OliNex For This Useful Post: [ View ] Gift OliNex Ad-Free
20th August 2009, 12:20 AM |#2  
OP Member
Thanks Meter: 39
*_Troubleshooting FAQ_*

If you are having problems, make certain that you've read the information in the first post.

My antivirus software reports this is a virus. What gives?
This program contains no harmful code. It was compiled using a packer, so it may be incorrectly reported as a virus by some software. Simply disable the anti-virus software and try again.

I get the FATAL ERROR that "HardSPL is for NON Commercial purposes...." What do I do?
To fix this, please contact us at the link (our support ticket system) and use the *Rhodium Hard-SPL* category! Alternatively, you can send a donation, this is optional if for personal use.

Why doesn't this work even when I've already donated?
If you donated in Manual mode, you didn't enter an IMEI or it was mistyped. If you donate in Automatic mode, that will always work as long as the error message was about the commercial usage. To fix this, please contact us at the ticket system link and use *Rhodium HardSPL - Paying* category!

I get sync issues/a sync error text while running the program.
Check to make sure the phone is NOT in flight mode. Next, try installing on the phone. If still same error, disable your firewall temporarily (e.g. ZoneAlarm or Sygate can interfere sometimes). Check the phone screen for any error messages, that can cause a sync error too (such as incompatible model message).

The file cannot be installed on the phone.
Do not extract the CAB file on the PC, copy it to the phone without unzipping it.

I followed the instructions, but nothing happened. It didn't enter the black screen mode.
First make sure the box is unchecked at Start > Settings > Connections > USBtoPC > Enable faster data synchronization. Make sure you've used Automatic flash mode before to put the device in SSPL. If you hard reset your device, you have to repeat Automatic flash mode at least once. Please make sure you watch the device screen during the Hard SPL process to see if it asks about running files. It probably won't, but just in case, check. For example it can warn about model incompatibility.

The program gives me a connection error during the process.
DO NOT UNPLUG THE USB CABLE. If you get connection error in RUU after the device goes to the black SSPL screen, make sure device was still synced via USB to the PC at the point of it entering SSPL (the black screen). It may take some time for the program to see the device again. If it doesn't, you need to wait for it to time out or wait about five minutes, whichever is first. Then, leave the USB cable plugged in and press the reset button with your stylus and start over.

The program gives me ERROR 260 CONNECTION message. What do I do?
DO NOT TRY TO FLASH THROUGH A USB HUB. Disable your anti-virus software for the duration of the flash. If that doesn't help, reboot the PC. Then try a different USB port on the PC. If that doesn't work, try a different USB cable, if you have one (original HTC cable is the best). Make sure you don't move the cable around while it is flashing. If this does not help, download SSPL-Manual-Rhodium.exe from the first post, copy it to your device, and run it. Once the screen goes black, run Hard SPL package on the PC and select Manual Flash.

The device shuts off.
It didn't actually shut off, this is the "black screen" mode, it is ready to flash Hard-SPL at this point, do not worry about the sync getting lost, just continue with the next step on the PC.

The program says it's for a different model or mine isn't supported.
If a message on the phone screen says it's for a different model or device, please check modelID by entering SPL tricolour screen manually, and note what it says for RHODxxx, where xxx is a three-digit number.
T-Mobile, AT&T phones, RHOD100, RHOD200, RHOD210, RHOD300, or variants of these are supported by this package. RHOD400, RHOD500, and variants are CDMA versions and are *not* supported by this package.

My device says that Enterbootloader.exe failed to run due to missing component or corrupt signature.
You'll need to do a hard reset to fix this issue. Turn off the device, and hold talk/send, and end buttons while pressing the reset button once. Release the buttons when the device asks you to confirm the hard reset and press volume up to confirm. Note that a hard reset will factory reset your device and return it to its original shipped condition. You should back up your programs and data before doing this as it will all be gone after the hard reset.

My PC gives me a RAPI.dll error message.
This happens on Windows 7 with versions of Windows Mobile Device Center. To fix it, download and install the latest version of Windows Mobile Device Center.

I get an error message that says the server is down.
First of all, do not use a proxy as the program doesn't support it. Turn off all firewalls including windows built-in firewall, and check if your AV software includes firewalls. Most companies have firewalls on their networks; try this when you get home. Don't tether to the phone being unlocked. Wait 24-48 hours and try again. If it still doesn't work, contact us at

I get a corrupt data error message.
Download the Hard SPL package again from the first post of this thread, to be sure you have the latest version intact. Sometimes the download may cut off part ways. Try with a different Internet connection if that doesn't work. If you still have trouble, contact us at

The program just crashes and doesn't give me an error message.
Check to see if you have DEP (data execution prevention) enabled in windows. If you do, disable it. Turn off your anti-virus software for the duration of the flash. Sometimes Windows 7 x64 gives problems, try it from a different PC. Virtual PC software is not supported.

When trying to run the program, Windows says it cannot access the path or file.
Disable all antivirus software. Make sure you extract the EXE from the ZIP file before running it. Don't try to run it from a network folder.

The device reboots instead of going into the SSPL screen (black screen).
While this is unlikely to ever happen, if it does, contact cmonex.

My problem still isn't fixed, or I can't find my problem here
Post in the thread. There are several users who monitor this thread and can help you with your problem. To make it easier for the users to help you, please provide as much information as you possibly can. This can include things like your PC operating system, antivirus software, or anything else that might help us figure out your problem. You should also quote any error message texts you are getting.

How to reflash Stock/Shipped SPL - STEP BY STEP - FOR WARRANTY REASONS ONLY!

1. Flash the Stock ROM. If the stock radio isn't included, flash that as well. This must be completed first.
2. Download the Relocker attachment, extract the zip and run the EXE on your PC.
3. If you wish to replace RUU_Signed.NBH that got extracted, feel free to do so, but not necessary. This Hard-SPL will only allow overwrite with a SPL signed by our custom cert. The included one is the 0.79.0000 stock SPL. You also have the option for 0.84.0000 and 0.87.0000.
4. Flash the SPL.
5. Verify if it flashed by checking version in tricolour screen, it should say 0.79.0000 (or 0.84.0000 or 0.87.0000), *not 0.85.OliNex*.[/QUOTE]
The Following 2 Users Say Thank You to OliNex For This Useful Post: [ View ] Gift OliNex Ad-Free
20th August 2009, 12:22 AM |#3  
DaveShaw's Avatar
Senior Moderator Emeritus + Wiki Bureaucrat
Flag Huddersfield
Thanks Meter: 506
Thanks guys.

Thread stuck.

20th August 2009, 12:52 AM |#4  
Senior Member
Thanks Meter: 12
First one public flashed! THanks guys u rock!
20th August 2009, 12:54 AM |#5  
OP Member
Thanks Meter: 39
Originally Posted by FU5 KONA

First one public flashed! THanks guys u rock!

LOOL! congrats on that!
20th August 2009, 12:55 AM |#6  
Senior Member
Thanks Meter: 1
Worked a treat thanks guys. Let the flashing begin.
20th August 2009, 12:56 AM |#7  
wberesford's Avatar
Flag All over the blooming place
Thanks Meter: 4
Hey Team,

Today is my first day back on HTC devices for a little while,

I sold my Blackstone after missing the keyboard too much (went to a BB - I know flame away)

Anyway, I have been doing a massive amount of reading and am greatly appreciative of all the efforts of the teams who work hard to help us make these devices 'that much better'!!!!


donation inbound.

Touch Pro 2
20th August 2009, 12:56 AM |#8  
OP Member
Thanks Meter: 39
Originally Posted by wberesford

Hey Team,

Today is my first day back on HTC devices for a little while,

I sold my Blackstone after missing the keyboard too much (went to a BB - I know flame away)

Anyway, I have been doing a massive amount of reading and am greatly appreciative of all the efforts of the teams who work hard to help us make these devices 'that much better'!!!!


donation inbound.

Touch Pro 2

well, this *IS* a blackstone, with a keyboard. so you're going to love this phone! & donation will be much appreciated!
20th August 2009, 12:58 AM |#9  
Senior Member
Flag Tirana
Thanks Meter: 16
Thanks guys, you rock!
20th August 2009, 12:58 AM |#10  
Senior Member
Flag Nieuw-Vennep
Thanks Meter: 51
This is awesome!

The HardSPL is like the birth of the new christ for us Touch Pro 2 users ;)
20th August 2009, 01:00 AM |#11  
Thanks Meter: 7
Thanks guys! I found a slight error though.

ModelID checking: if SSPL loader says it's for a different model or device, please contact cmonex in PM for testing SPL on that too. check modelid by entering SPL tricolour screen manually and note what it says (RHOD100, or something else). note: currently SSPL accepts any RHOD***** except for the CDMA-GSM worldphone version (RHOD400, RHOD500 modelids), but if we get notified of another incompatible (CDMA) topaz version, we will instantly modify it to deny those models."

Should be Rhodium. Again, thanks.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes