FORUMS

[SOLVED] Help: Hard-SPL installation on DIAM300

326 posts
Thanks Meter: 51
 
By braunie, Senior Member on 6th September 2009, 11:02 AM
Post Reply Email Thread
Hello,

I've read many threads about this issue without success.
My device is an O2 XDA Diamond (DIAM300).
I have test it with Olinex HardSPL 1.40, 1.93. I hvae test it in tricolor-mode.
SSPL bevor HardSPL just makes an softreset.
Has anybody the same diam-model, and had success in installation HARDSPL?
9th September 2009, 11:00 AM |#2  
braunie's Avatar
OP Senior Member
Thanks Meter: 51
 
More
Is there nobody out there, who had the same problem????
9th September 2009, 12:06 PM |#3  
matrix77's Avatar
Senior Member
Thanks Meter: 0
 
More
I have that phone and I put HardSPL and security unlocked it, DIAM300:
10th September 2009, 12:37 AM |#4  
Junior Member
Thanks Meter: 0
 
More
i had some connection problems with the same DIAM300 at first, but it may have just been
down to pressing the wrong button.

I used these to get it sorted

http://forum.xda-developers.com/showthread.php?t=416211
http://forum.xda-developers.com/showthread.php?t=411707
11th September 2009, 11:28 AM |#5  
braunie's Avatar
OP Senior Member
Thanks Meter: 51
 
More
[SOLVED] Hard-SPL on DIAM300 (+newest original HTC-ROM)
In that while, nobody could help me, i've got it !

1. I download "diamond-hspl-1.23-and-1.24"
http://forum.xda-developers.com/showthread.php?t=408621

2. I download "Unsigned-Hard-SPL-Diamond-OliNex" (Signed may also work, what's the difference?)
http://forum.xda-developers.com/showthread.php?t=400950

3. I connect the diamond with the pc (activesync-connection)

4. I start "diamond-sspl.bat" from "diamond-hspl-1.23-and-1.24"-package, the diamond goes in black screen, the usb-connection shortly disconnects and connect back again

5. I start "ROMUpdateUtility.exe" from the "Unsigned-Hard-SPL-Diamond-OliNex"-package (diamond is still in black screen an connected=> usb)

6. Now the update-procedure runs throu

Newest HTC-ROM

However the update to the newest HTC-Rom for the diamond from www.htc.com does not work (Error: Fehler [244]: ung├╝ltige Modell-ID)

1. I download a modified version from here (only german):
http://www.maxstegi.de/downloads.php...etail&df_id=27
But if I start the "DiamondCustomRUU.exe" in that package, an error occures (something wrong with this exe).

2. Now I copy the "RUU_signed.nbh" from that package into the folder from the "Unsigned-Hard-SPL-Diamond-OliNex" (rename the existing one first).

3. I set my phone in tricolor-mode (softreset + volume-low-button), start the "ROMUpdateUtility.exe" from the "Unsigned-Hard-SPL-Diamond-OliNex"-folder with the HTC-ROM inside and it works!!!

Hope I can help someone with that ... it is possible that that instruction is not complete, cause i wrote it out of my mind
3rd October 2016, 02:19 PM |#6  
Junior Member
Thanks Meter: 0
 
More
htc diam300 spl 2.03.0000
Hello.
My spl is like in topic.
When I try to write hardspl, the phone is hang on 0% and on PC is error [262] - update error
Is solution for so high spl?
Emilkawa
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes