Remove All Ads from XDA

[HOWTO] If you flashed the original RUU_Hero_HTC_WWE_2.73.* and got the new hboot

443 posts
Thanks Meter: 122
By Jesterz, Retired Moderator on 13th September 2009, 02:27 PM
Post Reply Email Thread
You will have noticed you can't 'fastboot boot' the recovery image again for rooting or using the new recovery image.


You can use flashrec to flash the patched recovery, from where you can do all the usual stuff (and even put the old hboot back on if you want!)

flashrec is using an exploit that isn't patched yet in the current kernel used by HTC, however if/when HTC patches this, flashrec will stop working.
So for now it's ok but a next version might have patched this, so keep this in mind !

Thanks for the original headsup by Magnus and Modaco, adapted from here

Quick Howto:

1. On your phone, goto Settings, Applications, and make sure Unknown source is checked ON.

2. On your phone, goto Settings, SD card and phone storage, and click Unmount SD card.

3. Then click Format SD card (it should automatically remount after this).

4. Plug the phone into the compuer via USB, then pull down the notification bar and click on the SD card notification. Then click mount.

5. Download this APK and recovery image and save it to your computer:
Cyanogen’s / Modaco Hero Recovery Image

Update: updated flashrec here

6. Extract the cm-hero-recovery.img out of the and put it somewhere on your computer.

7. Save both the cm-hero-recovery.img and the flashrec-20090815.apk to your computer, then copy them both to your SD card
(do NOT put them inside any folders on the SD card, just put them in the root of the SD card itself).

8. Unplug the phone from the computer once they are downloaded to the SD card.

9. Goto the Market and download Linda File Manager or any file manager program if you do not already have one.

10. Open the file manager and goto SDCard and then find the flashrec-20090815.apk file and click on it.
If asked, tell it to use Package Installer to open it. It should automatically install the apk.

11. Open the FlashRec program and click on Backup Recovery Image and wait for it to finish.

12. Once done, click on the empty text box in the FlashRec program and type:
Then click on the Flash Custom Recovery Image button and wait for it to finish.

13. Turn off the phone and turn it on into Recovery mode by holding down Home and Power to turn it on
(keep holding until the recovery screen comes up has a bunch of text on a black background).
As long as that screen comes up, you have done it correctly and can now go and load other ROM/hboot/whatever.
13th September 2009, 03:47 PM |#2  
alexmw's Avatar
Junior Member
Thanks Meter: 1
Excellent, worked perfectly! Thanks!
13th September 2009, 05:25 PM |#3  
Senior Member
Thanks Meter: 3
I flashed the new official update from HTC, but i do got a nandroid from before when my phone was rooted, do you know if restoring that will make any changes to the hboot? And will i get root again? Or is this method that you posted over, the only way so far?
13th September 2009, 11:40 PM |#4  
Radeon1337's Avatar
Senior Member
Thanks Meter: 22
I did all this with the orginal 2.73 update and booted in to the recovery mode (worked fine..) but i still dont hav root
I tried the other method from to but still no root..
15th September 2009, 03:36 PM |#5  
Junior Member
Thanks Meter: 0
I followed this excellent tutorial, then I just ran the root tutorial again. Worked flawlessly.
15th September 2009, 05:47 PM |#6  
Joost39's Avatar
Senior Member
Flag Næstved
Thanks Meter: 13
Worked fine - thx m8
15th September 2009, 08:06 PM |#7  
Thanks Meter: 0
Is it possible to make this without a sd card?
Because my phone doesn't detect my sd card. Now i have the problem that i can't do anything on my phone because i can't get into recovery mode...

Anyone who knowes a solution???

Thanks in advance.
15th September 2009, 11:15 PM |#8  
Junior Member
Thanks Meter: 0
works perfectly, many thanks !
16th September 2009, 12:25 AM |#9  
Radeon1337's Avatar
Senior Member
Thanks Meter: 22
I get this "downloading 'boot.img'... FAILED (remote: not allow)" when i type "fastboot boot cm-hero-recovery.img" any one know what is wrong ?
16th September 2009, 10:04 AM |#10  
Junior Member
Flag Vienna
Thanks Meter: 0
you have uploaded the recovery image by that apk, be sure to boot your phone holding POWER+HOME NOT power+back, then you can continue to root your phone, hope i could help you
16th September 2009, 11:42 AM |#11  
Radeon1337's Avatar
Senior Member
Thanks Meter: 22
Ok, But what to do when i boot up with power+home ?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes