Remove All Ads from XDA

Unresponsive (bricked??) HTC Touch Pro 2. Help please.

229 posts
Thanks Meter: 1
By i<3myphone, Senior Member on 17th October 2009, 08:49 PM
Post Reply Email Thread
19th October 2009, 05:19 AM |#51  
OP Senior Member
Flag Charleston, SC
Thanks Meter: 1
Originally Posted by MadBeef

Can you get a hard reset out of it?

Don't give up yet, but you may have the option of re-flashing the original ROM, then flash the stock SPL (it's on the HardSPL page) then the phone's flash should be in it's original state. Try to get it replaced under warranty

I'm just a semi-noob I'm running out of ideas, really at this stage you need olinex. It may be that the bit before SPL (bootloader?) is corrupted I believe there is a program called mtty which may be able to solve this but from what I remember you need to really know what you are doing with that.

Could always try flashing stock again via USB but watch your battery levels!!

You have been a LOAD of help. Like a life preserver!! thanks a lot!

I cannot get a hard reset out of it. It just comes up with the damned striped screen.

I just did get a new HRDSPL on there. It is the .84 version, so I am thinking that is good for warranty purposes, like you said. I have pm'ed cmonex (the 1/2 of Olinex) and I think we are in totally diff time zones. So that is slow going. She mentioned mtty. I dont get that at all. I need the "mtty for Dummies" book on that one.

I have to go to sleep. THis has exhausted my eyes. Work comes early and I cant play with the phone as much tomorrow.

ps, I take that battery out as much as I can now. I cherish every charge I can get now. (although I think the guy at the store would do it again for me....maybe 1 more time...)
19th October 2009, 05:32 AM |#52  
Senior Member
Thanks Meter: 5
No problem dude, good idea on the battery hehe
19th October 2009, 12:03 PM |#53  
Thanks Meter: 0
Originally Posted by Loco5150

People are reporting the same thing after doing slide to reboot with NRG's 10/11 Photon ROM... Go check that topic, you are not alone.

Same problem over here after slide to reboot with EnergyROM
Tried a lot of things:
- reflash same ROM -> nothing
- reflash stock ROM + stock SPL -> nothing
- Leaving battery out for a while -> nothing

I wonder if they would fix my phone under warranty and I'm still waiting for the dutch ROM update, maybe that one will be a solution :s
19th October 2009, 04:47 PM |#54  
Senior Member
Flag vilnius
Thanks Meter: 6
show the possible direction

Suppose this is the quite common problem. You are not the fist ones who bricked the phone.
I do think similar questions were already discussed on XDA if not - somewhere else.
As I used the search please have some internal and external links.
Personally I do not remeber jtag process- just read it concerning my dreambox. But please do not stop to try.

My guess is : only jtagging will help then.
If it's having a msm qc chipset, then you should be able to jtag it with qmat and segger j-link arm soon. However, you will need the jtag pinout for your htc magic.

it's done!!!
Today i discovered the JTAG pins of HTC hermes.
My device got bricked and was not able to boot anymore. Not even the bootlader came up.
Anyway i decided to do some investigation, there was nothing to loose

Thanks to Lt.Cmdr.Ivan who discovered the JTAG pins on the universal hardware.
(It made the step successful!!!)

See the attachment!
(had to make a zip because high-resolution pix )
These are the testpoints to access Hermes main system Samsung MPU and recover OS bootloader!
To get access to the GSM chipset please have a look in the second post!

see attachment (backup package form samsung site, source code included)
See the documentation in the archive for information how to build a LPT adaptor, to use this software!

The software tool has been modified to handle the /WP issue.
See attachment!
What ever happens to IPL/SPL on your device, it can be recovered quite easily now, using the JTAG method!

Added Olipro's 2.10 (Hard-SPL V7) for completeness.
This is a pure binary file, ready to flash via JTAG. Thanks again to olipro for this beautiful bunch of bits!!

Thanks again to scholbert,pof, cmonex, cr2, the_dipe and the others who gave useful hints or helped testing.
19th October 2009, 04:48 PM |#55  
Senior Member
Thanks Meter: 5
Noooo not another one

Has anyone seen a response to this from NRGZ28 himself? I think at the very least the 11/10 EnergyROM should be pulled from download sites. I'm not saying it's definitely an EnergyROM issue but to be on the safe side ... (I'm running the one before 11/10 for this exact reason)

I did find this last night just before I'd had enough:

It shows how to use MTTY and step 6b in the tutorial (3rd or 4th post in) says something interesting:

6b: type "set 14 0" without the quotes to tell bootloader to boot the OS after reset:

I wonder if this would help, but I have no clue with MTTY have never used it before, and the thread is from a Diamond forum so it's possible the commands aren't the same on the Rhodium. I don't know. It would be nice to have the theory looked at by someone who is familiary with MTTY and the Rhodium before anyone tries this. (hey if you want to risk it then I'm not stopping you but MTTY scares me and either I'm a pansy or it should scare you too hehe)

At least there is one good thing. The more people have this problem, the better chance of getting it fixed
19th October 2009, 04:51 PM |#56  
Senior Member
Flag vilnius
Thanks Meter: 6
11th August 2009, 07:39 PM
Senior Member Join Date: Jan 2006
Location: Milton Keynes
Posts: 788


Originally Posted by digitalmk
Dear Cmonex, one question, as I have found, vol up + vol down + reset btn and then press power. Is this the way for entering the emergency mode, or it is something else (like you wrote... vol down + reset ) ???? maybee I do not enter the recovery mode correctly ???
Thanks for quick reply Cmonex , but thanks all also!!!

As Cmonex wrote,

Hold Vol Down (keep it pressed) and press the reset with the stylus.
This should take you to the tri-colour bootloader screen.
If it doesn't you have bricked your expensive device, the only way to recover is to get a new bootloader loaded via JTag, good luck getting someone to do that for you.

As is always stated here time and time again, read the information carefuly and if you don't understand ask.

Since you flashed a Raphael bootloader or rom or both ???? I'd say it's well and truly an expensive paper weight sir............ on the bright side though, you've learn't an extremely valuable lesson.
19th October 2009, 08:21 PM |#57  
Senior Member
Flag vilnius
Thanks Meter: 6
what exactly bricks a device
What about bricking? (or what exactly bricks a device)
Posted by Tyler EarmanJuly 30, 2008So you’ve probably heard about being careful with flashing and such because it can brick your device. And you obviously know that bricking a device renders it unusable. But what exactly causes this brick?
Enter the world of embedded devices. Needless to say, your Tilt (herein called an embedded device) lacks a hard drive, so it needs some sort of involatile memory (id est, memory that does not get erased after power to the memory is cut) to store the OS (firmware) and other persistent data.

Embedded devices now days typically turn to a type of flash memory known as NAND flash, which tends to be a lot smaller and more economically feasible than NOR flash, albeit less resilient. More after the break.

So you may be wondering about where the name flash comes from. Well, a colleague of the creator of flash memory, Mr. Shoki Ariizumi, decided that the erasing procedure looked a lot like the flash of a camera. Flashing is obviously the process of programming a piece of flash memory.

So you may be asking what all of this has to do with bricking your device. Well I’m getting there.

Flash memory works very differently from a hard drive, obviously. For instance, NAND flash does not provide a mechanism for random access of data, it has to be accessed by page. Another example is writing to NAND flash. NAND flash has data written to it and erased from it using the Quantum Tunneling effect (didn’t think Quantum mechanics had much bearing on your everyday life now did you?) which has a tendency to be a fair bit more complicated than passing a magnetic charge to a certain position on a magnetic tray.

Obviously this process has to be controlled. Mostly it’s controlled by integrated circuits (ICs) on the board. However, there must obviously be an input to the controllers while the NAND flash is being programmed. Mostly we use USB or serial (classic flashing interfaces) to accomplish this, but utilizing these components requires that an OS is available in order to communicate with the source machine sending the input and that will send the data onto the controllers to be flashed.

On the AT&T Tilt, the communicating OS is what we know as SPL, which can either be hard or soft. HardSPL is the actual SPL that is flashed onto the NAND flash and runs from this location as well. SoftSPL is basically a version of SPL that runs in the RAM only, which is volatile, meaning if you turn the Tilt off, SoftSPL is lost.

See where I’m going with this?

If you’re flashing HardSPL to your Tilt using SoftSPL, and power is cut to your Tilt, in all likelihood you will brick your device. This is because HardSPL has been erased from the NAND flash and only part of it has been rewritten, and since a portion of the code cannot be used, and because HardSPL functions as the bootstrapper, your device will not boot up.

This process of a broken Bootstrapper is what causes the bricking effect, in that your device will no longer run. You can also no longer try to flash back because there is no OS (firmware) to communicate with a source machine to receive the programming data and push it on to the flash controllers.

There are ways around this obviously. The Tilt in particular is a rather resilient device to flashing (I’ve worked with much pickier), allowing partial interfaces such as MTTY to recover from potentially bricking flashes. However MTTY requires at least a partially usable SPL, if you don’t have this then one must further regress to using a JTAG cable, which is essentially a very low level component that will give you an interface to reflash the ROM firmware to the NAND flash almost directly. However, this requires a specialty component (JTAG cable, which can run over $100 for a buffered version) and also requires disassembling your Tilt and finding the correct positions on the mainboard to tie the cable into.

So I hope I haven’t scared you with the whole flashing jargon and all of the other technical information surrounding flashing. But typically understanding what causes things will qualm some of your fears.
19th October 2009, 10:46 PM |#58  
OP Senior Member
Flag Charleston, SC
Thanks Meter: 1



[re-reading all above posts for the 5th time]

where is the "way over my head" icon?

lol. thanks.
19th October 2009, 11:30 PM |#59  
Senior Member
Thanks Meter: 5
tell me about it it's all getting a bit heavy now

I don't think yours is "bricked" in the same way as some of the other posts. May not have to resort to JTAG. You can do a flash, it's just as though the bootloader is confused.

Can you charge it now? If so, maybe do a full charge and flash stock ROM via USB with no SD card if you haven't tried already.

Will give you time for a 6th run through of the thread even if it doesn't work
19th October 2009, 11:33 PM |#60  
Senior Member
Thanks Meter: 5
ps. this is the one you want i think

20th October 2009, 03:00 AM |#61  
Senior Member
Thanks Meter: 0
I dont think you've bricked your phone since it still "have" it's bootloader (tri colour screen).

Try this :

Enter the bootloader.
- Remove battery
- Insert it again
- Hold the Volume Down button + power button
- Press reset button with stylus

You should now see the bootloader (tri-color screen) with 'serial' text on the bottom. Connect the usb cable to your computer. the "serial" should now change to "usb". Flash with a original ROM just to be safe.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes