Remove All Ads from XDA

Telus APN settings don't work

555 posts
Thanks Meter: 10
By Macmee, Senior Member on 24th November 2009, 12:24 AM
Post Reply Email Thread
I used:
No username/password
MMS Proxy:
Tethering APN:

I can make calls and send text messages fine but these APN information don't work. I have a 500mb data plan.

Do any fellow Telus users know what I'm doing wrong :P
24th November 2009, 08:17 PM |#2  
OP Senior Member
Flag Halifax
Thanks Meter: 10
surly someone knows how to help me. I can't use this phone without data..
29th November 2009, 10:34 PM |#3  
Junior Member
Thanks Meter: 0
Those settings worked for me but I have a RETARDED data usage now.

Data Usage 77522 Kilobytes $757.03

I called customer support and from what there telling me (they can't say much) I have the wrong APN settings.

And yes, I have a 500mb data plan. I guess ill keep looking.
29th December 2009, 12:57 AM |#4  
Junior Member
Thanks Meter: 0
I am trying to get my rogers iPhone onto Telus now and I am close .. got everything but the data plan working and cant find the APN info either.

Gonna try talking to Telus and see what they say.
8th January 2010, 07:52 PM |#5  
Junior Member
Thanks Meter: 0
Those settings worked for me but only after i installed a custom profile and editing the settings manually. (only after this profile installation was i able to make it work)
1) go to and create and install a custom profile (from your phone through wifi)
you will be able to manually edit the settings on the page. (only the Apn, you can add the rest later)

2) go back to your phone settings/general/network/cellular data network and make sure you have the settings listed above.
you will notice the apn settings are not exactly they way you typed it in the website. (that's why you need to change them and also the rest of the settings need to be manually added which were not available on the site)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes