Remove All Ads from XDA

no service at all after routine flash

229 posts
Thanks Meter: 6
By superkevx, Senior Member on 12th January 2010, 06:51 AM
Post Reply Email Thread
Just flashed to a new rom yesterday and now my phone is completely incapable of getting a signal.

I've flashed plenty of roms and they've all worked fine until flashing to a 21889 rom yesterday (firestormLeo v5.5). Not a single bar of service since. Text messages don't get received and no data either.

I reflashed, hard reset after the flash, updated the radio, flashed back to an older rom that worked, and hard reset again.

Nothing works! I now have a completely unusable phone (phone-wise). It completely works otherwise (music, sync to pc, wifi etc) although it does seem to get warmer than usual. I'm assuming that's because it's trying to grab a signal or something.

Anyone have any ideas on whats going on?
12th January 2010, 08:06 AM |#2  
Thanks Meter: 0
I would try flashing the original rom/radio that came with your device including removing the spl and seeing if that fixes it.

If that doesn't fix it, then you are all prepared for warranty service.

If it does fix it, then you can reflash your favourite rom and it should still work. But sometimes flashing an official rom can fix things. I know back with my Kaiser it was advised to always flash an official rom between switching from an unofficial to another unofficial.
12th January 2010, 09:51 AM |#3  
OP Senior Member
Thanks Meter: 6
thanks for the suggestion!

just did all that and now i'm on stock rom and removed spl but it still has zero signal/service.

i bought this tmo tp2 from craigslist so i'm not sure if i'm covered by warranty. where do i go to get this fixed? or am i screwed

anyone else have any idea whats going on?
12th January 2010, 02:22 PM |#4  
Flag istanbul
Thanks Meter: 0
I had a similar problem with you(, and have been waiting for some reply since last night, though got none, but the problem disappeared on it's own.

I continuesly flashed and flashed official ROM's and Radio's, totally gave up at the end, charged the battery to 100%, removed battery and let it like that for 5 hours, did an hard reset, and well, working as well as new.

It's a T-Mobile version as well, though my problem was losing signal continuosly and asking for PIN again and again every 5-10 mins. HTC support offered me to use another SIM card today, since I asked what could I try last night, though I didn't have the need for it =)
12th January 2010, 04:53 PM |#5  
InRBigness's Avatar
Senior Member
Thanks Meter: 0
A lot of roms do not come with a radio so you may have to get one and flash it. If you put stock rom back on make sure it has a radio as well. Make sure the radio matches the rom and the ril.dll is the right one.

I have not had the problem but have read about others flashing new roms and no signal only to find out they had to write a radio as well.
12th January 2010, 10:43 PM |#6  
OP Senior Member
Thanks Meter: 6
i'm certain i have the radio flashed on it and it isnt the problem.

just took the battery out and hoping it'll somehow fix itself in a few hours.
12th January 2010, 10:48 PM |#7  
fone_fanatic's Avatar
Senior Member
Flag Central Texas
Thanks Meter: 248
Donate to Me
I would also recommend to flash the shipped stock rom. Go to htc's support/download page and download the rom they have for the t-mobile touch pro 2.

If that doesn't work, take it in for warranty with t-mobile. I purchased a used at&t tilt off craigslist and had an issue with it. Took it into at&t's device support center and they replaced it no questions asked.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes