FORUMS
Remove All Ads from XDA

[FIX](Test) Mobile Shell 3.5.3 Facebook Widget Broken in WM 6.5.3

272 posts
Thanks Meter: 8
 
By mtstmp, Senior Member on 28th January 2010, 12:46 AM
Post Reply Email Thread
DO NOT TRY THIS ON ANYTHING OTHER THAN WINDOWS MOBILE VERSION 6.5.3 OR HIGHER! IT CONSISTS OF A .DLL FILE DEVELOPED AFTER WM 6.1! YOU WILL DISABLE FEATURES!



I love using Mobile Shell 3.5.3, and I love using Windows Mobile 6.5.3, but the facebook and twitter widgets would not connect for me. I kept getting the error cannot connect. It was driving me nuts and forcing me to switch to a regular 6.5 rom. I figured out that 28002 was the last 6.5.3 build that these widgets worked on, so I pulled some packages out and added them to the new builds and viola! it worked. I've narrowed it down to the webview.dll file. This works fine for me when I cook it in, and I've tested the cab a few times. The widgets can connect now, and Internet Explorer doesn't seem to be affected. I don't use it all that often so I can't really say for sure if it makes a huge difference.

The cab is hard-coded to go to the windows directory and cannot be uninstalled. So this is kind of a one-time deal.

This is only a test and will need some feedback from others before we can call this one a sure thing.

BACKUP YOUR PHONE BEFORE YOU TRY!

I AM NOT RESPONSIBLE FOR WHAT THIS MAY DO TO YOUR PHONE!

USE AT YOUR OWN RISK!



.
Attached Files
File Type: cab Mtstmp Widget Fix.cab - [Click for QR Code] (1.08 MB, 5946 views)
 
 
29th January 2010, 05:40 PM |#2  
mtstmp's Avatar
OP Senior Member
Thanks Meter: 8
 
More
i'm guess i'm the only one with this problem?
29th January 2010, 05:54 PM |#3  
Senior Member
Flag Helena
Thanks Meter: 327
 
More
I'm using a 28205 6.5.3 build, and the Facebook widget works fine for me.
29th January 2010, 07:55 PM |#4  
Senior Member
Thanks Meter: 83
 
More
Quote:
Originally Posted by mtstmp

i'm guess i'm the only one with this problem?

No you're not. People are all over SPB developers behind in the SPB forums. So far they have just said that they are looking into it.

I'll back up my phone now and try this. Is there a manual way of uninstalling and getting back to the old settings?
29th January 2010, 08:08 PM |#5  
Senior Member
Thanks Meter: 83
 
More
So no luck. I am using build 23037 and the Facebook screen still keeps getting the "Retry" button. Internet Explorer seems to work ok.
5th February 2010, 02:54 PM |#6  
Junior Member
Thanks Meter: 0
 
More
I actually receive the same error, yet it updates my status anyway.
6th February 2010, 01:08 PM |#7  
Senior Member
Thanks Meter: 5
 
More
Thumbs up
It works! It opens my default browser and there's a message about a bug in the application, therefore I cannot log in. But when I try again to open Facebook in SPB Mobile Shell it logs in.

My ROM: Energy.KOVSKY.23519.Leo_04.Feb.2010

Thx a lot man!
8th February 2010, 07:54 AM |#8  
Senior Member
Philadelphia - HTC One (m7)
Thanks Meter: 390
 
More
Quote:
Originally Posted by JOeS

It works! It opens my default browser and there's a message about a bug in the application, therefore I cannot log in. But when I try again to open Facebook in SPB Mobile Shell it logs in.

My ROM: Energy.KOVSKY.23519.Leo_04.Feb.2010

Thx a lot man!

I too have a 23519 build this seems to have worked for me although only for google and facebook widgets the twitter does not say fail to connect any longer but it just sits on a white screen anyone else?
15th February 2010, 07:10 AM |#9  
clintonwes's Avatar
Junior Member
Flag Stanger
Thanks Meter: 0
 
More
I'm have ing the very same issue using Flame build 23529.

Twitter widget sometimes say failed to connect with a retry button, sometimes it just displays and white screen and hangs the mobile, requiring me to pull out the battery.

I'm downloading the patch now! Will let you guys know how it goes.

WOOHOO!!!

It works!!

Thanks mtstmp!
2nd March 2010, 10:19 AM |#10  
Junior Member
Thanks Meter: 0
 
More
WICKED!!! IT workedd!! you're a genius, i love the facebook feature of spb mobile shell too =D THANK YOU SO MUCHHHHHHHHH
11th March 2010, 12:34 AM |#11  
f0vela's Avatar
Junior Member
Thanks Meter: 0
 
More
Thumbs up
Amazing this solved the problem for me too
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes