Remove All Ads from XDA
Honor 9 Lite

I had something unusual happen

4 posts
Thanks Meter: 0
By phazzy, Junior Member on 16th February 2010, 06:02 PM
Post Reply Email Thread
Not sure how to fix it. Before it happened, I was rooted with a Cyanogen rom on 1.6. I also had a black and green theme on. I went to install a new rom called "OpenEclair". I downloaded it, placed it in my sdcard root folder, and tried to install it. I had an installation error and it aborted. At this point, I figured ok, I'll just reboot. It kept me at the G1 screen for over 25 minutes, so I knew something was wrong. So no matter what I did from here on out (trying to perform a backup restoration, flash a different rom, etc), I would be stuck on the G1 screen. Finally, I flashed a JesusFreke rom and it let my phone come back on, so I haven't tried anything since. However, this rom is ANDROID 1.1. It sucks. Is there any way I can get back to either where I started, or even get this OpenEclair 2.1 rom working properly? Any help would be greatly appreciated. When I try to install the OpenEclair rom (before and after downgrade) it will say
E:Can't chown/mod /system/xbin/librank
*No such file or directory)
D:Failure at line 221:
set perm 0 0 06755 SYSTEM:xbin/librank
Installation aborted.

Press Home+Back to reboot
16th February 2010, 10:02 PM |#2  
TheBogBrushZone's Avatar
Junior Member
Thanks Meter: 4
I had this also. The problem went away after I installed DangerSPL which, as stated at the top of the OpenEclair thread, is required to install this on the G1.
16th February 2010, 11:27 PM |#3  
Thanks Meter: 0
If you don't have DangerSPL, OpenEclair will fail to install as it doesn't have enough room to place its files.

However, if you do have it...

I have noticed this with some of the 2.1 ROMs. I think the reason is that, since we flash using an "updater", it wont wipe the partition before flashing. This leaves the possibility that there are old files with different permissions that prevent the new ROM from properly taking.

Boot your phone into fastboot (for the G1, hold the camera button while powering up), set it into usb mode (by the "back" button, I think), then use the fastboot tool to clear the boot and system partitions:
/fastboot wipe boot
/fastboot wipe system

This will clear the "ROM" component from the phone, and you can then go and flash whatever ROM you want. Make sure to wipe the data partition via recovery.

If, after wiping the ROM and rebooting, the phone is stuck at the carrier screen and says "Fastboot USB", that means it tried to boot the usual way and found no data in the boot partition. You need to boot into recovery and flash a ROM. Using "fastboot reboot" or the reboot command from the phone's fastboot screen will cause this. Use the phone's fastboot "power off" button ("menu" in the G1), then boot it into recovery.

Also remember that any install that fails after the "verification" phase will destroy the existing ROM, since you will be left with a partially installed ROM on top of the older one.
17th February 2010, 02:38 AM |#4  
OP Junior Member
Thanks Meter: 0
Thanks a lot guys. will try all of this when I get off of work. Much appreciation!
17th February 2010, 09:14 AM |#5  
OP Junior Member
Thanks Meter: 0
Got everything worked out. Just had to install that danger spl :]
Just flashed FastTest rom, pretty freakin' nice I must say!
19th February 2010, 01:43 AM |#6  
OP Junior Member
Thanks Meter: 0
Is there a way to backup all my apps/contacts/texts before wiping and flashing a new rom?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes