FORUMS
Remove All Ads from XDA

connecting the Wifi 802.1x on Captivate (Android in general))

69 posts
Thanks Meter: 0
 
By carporsche, Member on 22nd July 2010, 07:32 PM
Post Reply Email Thread
Hi Guys

I need some help connecting to Wifi 802.1x with PEAP security at work.
I tried the following steps:

"Open Wi-Fi Settings from Settings, Wireless & Networks
If need be, write down the SSID of the 802.1x network (Case sensitive)
Select Add Wi-Fi network
Enter the SSID, select security 802.1x Enterprise, EAP method is PEAP, Phase 2 authentication is None, CA certificate and Client certificate are N/A, Identity is your RADIUS or Domain Authentication username, Anonymous Identity can be left blank, and Wireless password is the password to match your RADIUS or Domain Authentication password."

But after i finish the above config the SSID network is just saved in my WiFi list. It does not detect the network and connect to it. (it does not show the icon to the right which says the network is broadcasting)

Please help!
 
 
22nd November 2010, 08:35 PM |#2  
Junior Member
Thanks Meter: 0
 
More
any answers???
23rd November 2010, 12:35 AM |#3  
Junior Member
Flag Chicago
Thanks Meter: 0
 
More
You could try the FullWifi app. Something in the standard wifi app seems to be defunct at least on my captivate so I'm using the FullWifi app to setup the network.

Give it a shot. Can't hurt.
23rd November 2010, 03:57 AM |#4  
I run 802.1x encrypted with AES and EAP via a Win 2k8R2 server running NPS (RADIUS) and authenticating via MSCHAPv2 to Active Directory at home. Yeah, I'm kind of a geek.

Anyhow, try this: Delete (or 'forget') your network from Android. Since you said your network is brocadasting the SSID, just chose the right network from the list. Choose the following settings:

EAP method: PEAP
Phase 2 authentication: MSCHAPV2
CA cert: Unspecified (Adding certs to Android is a PITA)
User cert: Unspecified
Identity: <userid> (NOT <domain>\<userid> or any permutation and it is cASe SeNsiTivE).
Anonymous identity: _blank_
Password: <password>

Press Connect.

If this does not work, repeat using different Phase 2 Auth.
If the RADIUS server is Linux, try None, then PAP, then MSCHAP, then MSCHAPV2.
If the server is Windows, try MSCHAPV2, then MSCHAP, then None, then PAP. Try GTC last, as it is the least used that I've seen.
If the server is OS X, then just give up dude. Macs suck so hard that I'm surprised it hasn't swallowed up your network and given everyone that you've ever known cancer.


I really hope this helps.
1st December 2010, 05:15 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Awesome fatbas202, your instructions worked for me. The default Phase 2 authentication won't work - TRY "MSCHAPV2" if you want to connect to PEAP wireless network at office/school. Thanks a million!
2nd December 2010, 03:34 PM |#6  
Quote:
Originally Posted by bking007

Awesome fatbas202, your instructions worked for me. The default Phase 2 authentication won't work - TRY "MSCHAPV2" if you want to connect to PEAP wireless network at office/school. Thanks a million!

Word.


10char
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes