Remove All Ads from XDA

[Tutorial] Root Without Unlocking (Alternative way for all ROMs Vodafone,Korean,US)

40 posts
Thanks Meter: 2
By dolomiti7, Member on 26th July 2010, 10:55 PM
Post Reply Email Thread
6th December 2010, 09:39 PM |#261  
Senior Member
Flag Rome
Thanks Meter: 11
I did everything ok but when I type:
adb shell


"Permission denied"

But devices is rooted, I tried to install Titanium backup and it gain root

but I can't install recovery Amon_RA,
plese help!

Additinal information:

Nexusone PVT SHIP S-ON
Dec 17 2009, 13:05:23

Android 2.2
haley@m4-dev #1

7th December 2010, 01:40 PM |#262  
Senior Member
Flag Rome
Thanks Meter: 11
12th December 2010, 02:26 PM |#263  
Junior Member
Thanks Meter: 0
Cant get past $ ./freenexus
everytime I type in ./freenexus, it will tell me ./freenexus not found. I ve checked that there is no "Freenexus" folder and all the other steps have worked up to that one. Anything that i could be doing wrong!?

Update. k so never mind I got passed i m on step where you have to type in rootshell but when I type that in it says premission denied. I ve checked and I did not have -dw thing I do have an r there but it still doenst allow me to root
29th December 2010, 03:35 AM |#264  
SharpIS03's Avatar
Senior Member
Flag Koshigaya
Thanks Meter: 56
Question Sharp IS03
Originally Posted by dolomiti7

- Basically this method should work on all currently known ROM versions.
- I tested it on EPF30, Korean FRF91, Vodafone FRF91, US Stock FRF91.
- As usual when doing this kind of stuff: DO THIS AT YOUR OWN RISK.
- It could even work on other Android devices as long as their system partition is at
/dev/block/mtdblock3/ with yaffs2 file system and there is still some space left on the system partition (without any changes).

The bolded part is the part I'm interested in. My phone is totally different, but I tried this method anyways. I got as far as step 14, but when I run rootshell, I get permission denied.

Anyways, my system partition is on mtdblock4 with yaffs2. How does that change things as far as running the code is concerned? Is it a big or small change?

I'm sorry if my questions don't make sense, I'm still grasping this kind of stuff as I read all these different forums.

Thanks for your time.
1st January 2011, 03:10 AM |#265  
flip3547's Avatar
Flag Clearwater
Thanks Meter: 15
I just purchased a wopad tablet, I've tried every root method I can find. Only one has worked and has only temp rooted. My system partition is at mtdblock4, I wonder how this could be adjusted in a way for it to work with this partition scheme?
7th February 2011, 07:15 AM |#266  
Junior Member
Thanks Meter: 0
Do I have to wipe data after rooting a stock N1? Will my contacts and SMS be saved?
11th November 2012, 03:19 AM |#267  
tanclo's Avatar
Senior Member
Flag Gyeongsangnam Province
Thanks Meter: 30
Thanks for this very useful and comprehensive post - I rooted Froyo using the wifi exploit method described. I was given a power button failed Korean CID Nexus One by a student who was told by Service center that the mainboard was broken. Without the ability to unlock the bootloader (power button is required to confirm fastboot oem unlock), I downgraded to Korean Android 2.3.3 using PASSIMG method: renamed PASSION-KR-FRF91 to - The ROM must be an official version for the device (same region) otherwise the PASSIMG process will fail. Nexus One official ROMS can be found here

The linux commands in this post worked FLAWLESSLY and I was rooted in no time. I used ROM Manager to install custom CWM. Installed root explorer and searched for
but I didn't see those in there. I didn't require the stock rom after a reboot anyway so I continued to download CM7 and installed using ROM Manager. All is good now!!

MUCH APPRECIATION - doing things without a windows bash script via VirtualBox is still and always will be the best method!
Post Reply Subscribe to Thread

nexus, root, tutorial

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes