Remove All Ads from XDA

Captivate's GPS is pissing me off

214 posts
Thanks Meter: 3
By saint168, Senior Member on 27th July 2010, 12:15 AM
Post Reply Email Thread
I take a walk everyday after lunch at the office and use RunKeeper to keep track of my progress. When I was using the Aria, I open the app, click the start button and never had trouble. With the Captivate, I have to stand on the street corner for 1 - 15 minutes before I get a GPS fix. This is unacceptable! I tried to follow the direction of the other posting and it's not helping much.

I feel like I made a bad decision to return the Aria and got the Captivate.
28th August 2011, 05:38 PM |#2  
oriveradel's Avatar
Senior Member
Thanks Meter: 193
after reading tons of forums and post about the gps on captivate, I found out itis the google navigation software not the actual GPS, I got rid of all my problems once I switched the software to Sygic GPS, which is not free however; pm me and will hook you up!
28th August 2011, 06:09 PM |#3  
emuneee's Avatar
Senior Member
Flag Raleigh, NC
Thanks Meter: 96
Buy a different phone. After a year with the Captivate, no matter the tweak, GPS for navigation purposes or tracking purposes is not reliable. I used to use it with My Tracks for tracking my runs as well and it was shotty at best.

It is not Google Navigation either as Google Navigation on my Galaxy Tab 10.1 is freaking flawless.

The GPS on the Captivate sucks. Period. /endThread
28th August 2011, 09:26 PM |#4  
curti.nogg's Avatar
Senior Member
Flag Gadgetzan
Thanks Meter: 50
After I got a refurb mine has worked and locks on quickly, but my previous Captivate did the same thing. It would take forever or sometimes not work at all.

Sent from my Captivate
29th August 2011, 02:51 AM |#5  
Senior Member
Thanks Meter: 21
The gps is spotty.. You can try turning on the control plane (hardware) also i noticed increase by removing case.. (hardware) other than that we have crappy chip with insufficient antenna..

sent from an alternate reality
29th August 2011, 03:08 AM |#6  
MikeyMike01's Avatar
Inactive Recognized Developer
Thanks Meter: 2,486
Donate to Me
The Captivate GPS is broken. Period. It doesn't work. Never has, never will. Anyone telling you anything else has low standards, poor testing, or is a liar.
29th August 2011, 03:17 AM |#7  
Senior Member
Thanks Meter: 57
With stock settings GPS is clearly broken.

That said changing the to the google SUPL server and occasionally running the "GPSRestore" app by samsung if I can't get a fix are pretty much the only GPS fixes I've ever needed.

I think my phone is a 1007.

But based on the majority of posts here my experience is not the norm.
29th August 2011, 04:24 AM |#8  
Thanks Meter: 4
What's the build date on your phone? I got mine recently with a Feb 2011 build date and the thing locked in seconds out of the box. I've used Co-Pilot to take me from Vancouver to Las Vegas with no issues. What bugs me about this phone is the battery life..
29th August 2011, 05:20 AM |#9  
Junior Member
Thanks Meter: 0
happens to me as well.
29th August 2011, 05:44 AM |#10  
Thanks Meter: 9
My stock captivate was great I'd get a 9 sat lock in 12 seconds nearly all the time.
I got hooked on flashing and my gps was usually crap on other roms.

Now I'm running apex 9 with a talon kernal and I'm getting a 9 sat lock in 10 to 12 again. So go figure
29th August 2011, 08:16 AM |#11  
techn's Avatar
Senior Member
Flag Houston Tx
Thanks Meter: 38
same here i think i got a bad phone so i send it back and a new one and everything works fine now.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes