Remove All Ads from XDA

way to reinstall allshare apk?

549 posts
Thanks Meter: 203
By tweezit, Inactive Recognized Developer on 7th August 2010, 05:09 AM
Post Reply Email Thread
I have the dlna.apk and the odex file was curious if there was a way to adb it back on the phone.. ( I removed it thinking I wouldn't use it )

I just don't know the commands for adb and if I try and just put them on sd card and install it says it is already installed but I know it is gone cause I removed it via titanium backup.
8th August 2010, 08:15 AM |#2  
Senior Member
Thanks Meter: 160
Donate to Me
send it to me and let me see if i can do some work on getting it back on the phone. i took mine off too like you but dont have the dlna.apk
8th August 2010, 03:01 PM |#3  
Inactive Recognized Developer
Flag New York, NY
Thanks Meter: 37,926
Donate to Me
Originally Posted by BRANDENDEUCE

send it to me and let me see if i can do some work on getting it back on the phone. i took mine off too like you but dont have the dlna.apk
Check the ADB threads and/or Root Explorer (it could probably do this too) for the commands.

As a last resort, if you really need it and can't figure it out.. just download the stock ROM in the dev forum and flash/restore it but you'll have to redo the settings so back up data with Titanium Backup.
10th September 2010, 01:11 PM |#4  
Junior Member
Thanks Meter: 0
Dlna.apk AllShare reinstall fail.
I'm using the Vibrant9 Eclair 2.1 rom which has removed Dlna.apk aka AllShare.
Any ideas how to get this reinstalled?

Some of my results.

When I try to install via the Vibrant file browser it I get the usual
"Do you want to install this application"
I click on Install and get
"Application not installed"

Tried to install via adb.

./adb install /SDK/app/Dlna/Dlna.apk
1175 KB/s (787522 bytes in 0.654s)
pkg: /data/local/tmp/Dlna.apk
execv /system/xbin/procrank returned -1
execv /system/xbin/librank returned -1
/mnt/.lfs: Function not implemented
execv /system/bin/parse_radio_log returned -1
[1] Killed pm install /data...

Tried to install while in adb shell, no errors untill reboot, got stuck on splash screen until it ended on a black screen, soft keys lit and stayed lit when I pressed them.

# install /sdcard/Dlna.apk /sdcard/system/app
# reboot
(black screen after splash loop on reboot)(adb shell active, can't gain su access though)
10th September 2010, 10:44 PM |#5  
Thanks Meter: 1
I've failed on trying to get it reinstalled too, anyone knowledgeable enough to fix this?
24th September 2010, 07:21 AM |#6  
Jayrod1980's Avatar
Senior Member
Flag Far East
Thanks Meter: 604
Bump... trying to get this working on FrankinTwiz...

Works fine on Bionix ROM, wonder whats different
24th September 2010, 05:10 PM |#7  
benwhite's Avatar
Senior Member
Flag Columbus, OH
Thanks Meter: 13
I'm having the same issue. I can't get it to work on FrankinTwiz
9th January 2011, 05:12 PM |#8  
Senior Member
Thanks Meter: 31
Any luck?
I know this is an old thread, but has anyone had any luck at getting the Allshare app reinstalled with custom roms? I've googled to no avail.
19th March 2011, 05:00 AM |#9  
slotteh's Avatar
Flag Singapore
Thanks Meter: 10
u could try creating a .zip file and placing the dlna.apk in systems\app folder and flashing it in CWM.

For example, ur .zip file would look something like this.


I havent tried it out though so not sure if it may work. Dont burn down my house if it doesnt. It just seems feasible.
19th March 2011, 05:04 AM |#10  
Binary100100's Avatar
Retired Forum Moderator
Flag Detroit, Mi
Thanks Meter: 1,671
Did you guys ever consider trying Bloater?
28th March 2011, 11:05 AM |#11  
Thanks Meter: 8
I'm trying to install it on my Nexus S, without success. Where should I put the Dlna.odex? When I installed the Dnla.apk, it says "installation succesful", even though it's not. Here's the log:

D/PackageManager(  332): Scanning package
E/PackageManager(  332): Package requires unavailable shared library touchwiz; failing!
W/PackageManager(  332): Package couldn't be installed in /data/app/
I/InstallAppProgress( 7472): Finished installing
You can find the zip here, by the way:
The Following User Says Thank You to neu242 For This Useful Post: [ View ] Gift neu242 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes