Remove All Ads from XDA
Honor 9 Lite

Unavailable SD Card issue after (any) Rom Upgrade...Please help!

2 posts
Thanks Meter: 0
By asapp, Junior Member on 26th August 2010, 06:26 AM
Post Reply Email Thread
This is my first post, and I'm usually pretty careful about following instructions. I'm currently running Skyraider's 3.0 RC2, but to my dismay, I am finding that my phone still refuses to recognize my SD Card. Under settings it says it is unavailable, and when connected to PC, it gives an option to mount to disk but doesn't mount upon selecting this.
My phone is rooted with S-Off and 2.15 radio...Did a full wipe of everything before I flashed 3.0 RC2. Shows that my kernel is now King #2, but I have had this issue with many other roms and kernel combinations. I have been unsuccessful in finding a solution when searching the forums, and the only way to regain functionality is to restore a previous backup without any roms installed.
Any help is much appreciate. Thanks!!!

P.S. I've also tried mounting the card in clockworkmod's advanced recovery settings, but this does not change a thing. Internal storage is also currently unavailable. Mount through usb in recovery does work, but this doesn't help when I cannot access my sd card after boot.
26th August 2010, 07:29 PM |#2  
Hackenstein's Avatar
Senior Member
Thanks Meter: 9
I had a similar issue a couple days ago after upgrading from stock 2.1 to SkyRaider 2.5.2.

When I'd go to set my ringtones, the option for the SD card wasn't there. As if it wasn't reading it was in the phone at all. I opened up Astro file manager to see if it could read it and it in fact did. I could see that all the ringtones were still on the card right where they should be and they would play from Astro when I clicked on them. But, the option to actually set them still wasn't there.

I'm not exactly sure what 'fixed' it, but I went in to set my notification tone and suddenly the option to select from the SD card was there. Then, I could then access the card to set ringers as well. I'm sorry I don't have anything more specific. The card just seemed to suddenly decide to let the OS know it was there. I also rebooted the phone a couple times as well as removing the card while the phone was in use and reinserting it. Not sure if any of that helped the situation or not.

I had asked about this in two separate threads and not one person responded, so I'm guessing the issue is rare.

If you don't get anywhere with it, maybe try a different SD card just to see if it shows up.

Good luck.
26th August 2010, 07:46 PM |#3  
Junior Member
Thanks Meter: 3
I've had the same issue but was able to resolve it. Mount the sd card from a laptop or PC. If you can read the card copy the contents onto the PC (I placed mine in a separate folder). Then go into tools and do an error checking. After replacing the SD card back in the phone see if everything is ok. this fixed my SD card. However, I've had the SD card lose its primary disk notation so I had to reformat and then transfer the previous save files on the SD card from my backup an that solved my other issue. Also, some times the SD card speed can cause this issue and it is perfered that you a class 4 or better. I hope this helps.
27th August 2010, 06:05 AM |#4  
OP Junior Member
Thanks Meter: 0
Well, I took your advice and pulled the sd card only to mount it separately and scan it for errors. None were found. I've also reformatted and restored all the files that were on it. Phone still does not recognize card or internal storage. My phone did, however, recognize another card I had on hand and I believe it may be a compatibility issue between my 8 Gb A-Data brand Micro SD card and 2.2 roms. FYI...It's a class 6, and the one I tried that was recognized was a 6gb sandisk (class 4). I'll look into getting a 16 or 32 gig sandisk in the near future and keep you posted. Thank you guys for your insight.
27th August 2010, 06:16 AM |#5  
Junior Member
Thanks Meter: 0
always 'safely remove hardware' (stop the device, etc.) from your windows machine before unplugging your incredible

if you don't, you end up not being able to see the SD card until you restart your phone
16th March 2011, 04:18 PM |#6  
PaulWilks's Avatar
Thanks Meter: 8
Just reformatted my SD card, checked for errors after unmounting etc... and now it seems to work ok, although one of the music players I normally use doesn't seem to recognise it!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes