FORUMS
Remove All Ads from XDA

Display anomaly: problem with color reproduction

409 posts
Thanks Meter: 15
 
By Neo-ST, Senior Member on 3rd September 2010, 07:42 PM
Post Reply Email Thread
Hi...

So i bought the new galaxy s...the best screen of mobile phones at the moment, super amoled....is everything to me except "super" right now.
The phone is merely a month old. I bought it from some guy that sells phones without the bill but with valid warranty (seal+signature) because in my country (Croatia) it wasn't officially available when I was buying it (it is now)...

Everything was fine for a week or so, when one morning I turned it on (left it for recharge during night) and noticed that something is wrong with the display. It had a certain "mist" layer (similar to when you boost brightness too much) in the home screen and menus were different too. I couldn't tell what exactly happened until I opened a few dark HD pictures.
I realized that the phone isn't displaying colors correctly, or their depth or something.

It displays them as if someone messed with color depth in driver settings and set it to 16 or even 8-bit (default is 24 or 32-bit as far as I know).
I tried fully resetting the phone (by typing in the code for factory wipe+reset) but with no luck.
Then I called the guy that sold it to me and he wasn't very polite, saying that it can't be possible and that I must have messed with phone or dropped it or something, which I haven't, I even have a special case for it to avoid scratches, etc. Nevertheless, he told me to send it to him and I did.
I also wrote him a short message explaining what the problem is, and even told him to compare the display with the other new galaxy s and to lookup some dark pictures, because the anomaly is best seen there.

The phone was for 2 weeks at him, and he kept saying that everything is alright with the display, that he compared it with other phone, etc. and that he'll keep running some tests just to make sure. I said alright, didn't want to mess with his job.
Today I received the phone. You're guessing - he didn't fix anything but I paid postal charges alright.
Since he doesn't seem to know or care about my problem I'm asking you for some favors. I need pictured proof of my anomaly, which I will then send to him again in hope he'll finally understand the problem and do something about it.

What I'm asking from you is to take screen shots of your Galaxy S with these two pictures on the screen (when they open click on them to get full size):
1. http://img824.imageshack.us/f/14213741.jpg/
2. http://img819.imageshack.us/f/35743610.jpg/

Please, just make sure that the pictures are clear to see. You might need to turn off your lights and take a night shot with macro to capture the screen properly.
After you do that, just post the screens here. I will need those pics to send him the evidence.

These are my screen shots, take a look at the pictures and you will see what I mean:

The home screen. Artifacts can be seen:


The menus screen:


The gallery screenshot, even here you can see the color anomaly:


The second pic. Please compare this to the second link I gave above:


And yes, everything is alright with my digital camera, the picture just looks that awful on the phone's screen

The second pic when screen dims after 30sec (notice how it adds purple layer):


The first pic. Please compare this to the first link I gave above:



The first pic when screen dims after 30sec:



So there it is...
If some of you wise people know how to fix this problem without sending it again to that guy or voiding the warranty, please do tell me. I assume it has something to do with color depth or something, maybe somehow that setting changed, don't know how or why, maybe some software I installed triggered it although none of it was illegal or malicious in any way...I think...

Thank you in advance for any help and I appreciate your efforts for helping!
 
 
3rd September 2010, 08:41 PM |#2  
Senior Member
Thanks Meter: 11
 
More
Have you flashed any new firmwares lately?
3rd September 2010, 08:43 PM |#3  
Neo-ST's Avatar
OP Senior Member
Thanks Meter: 15
 
More
No, I'm afraid to get the warranty void, nor do I know which firmware to flash, how to do it and how to un-do it. I also don't know if serial numbers will change or something :|
Sorry
3rd September 2010, 08:50 PM |#4  
Senior Member
Thanks Meter: 11
 
More
Don't be sorry. I was just asking because there have been reports that some of the 2.2 froyo firmwares had some similar issues, but I think that was mostly when watching films.

So you didn't do anything "new" when this happened? Installed an app, messed with phone settings etc?
3rd September 2010, 08:54 PM |#5  
Neo-ST's Avatar
OP Senior Member
Thanks Meter: 15
 
More
I received an advice to go to video player and while playing a video go to settings. There are some color controls but it didn't help.
One more thing I didn't mention before, the color anomaly is present even when phone boots up or shuts down, when those logos spin, etc. For example, when it boots, the big shiny "S" also has this anomaly instead of being smooth as it was originally...
3rd September 2010, 09:15 PM |#6  
Neo-ST's Avatar
OP Senior Member
Thanks Meter: 15
 
More
Here, I even recorded a video of the bootup, maybe you can see what I mean although my digital camera isn't intended for capturing video so it may not be the best quality :/
At 0:14 where purple color is, it isn't smooth, instead it looks like thick lines of purple...

http://www.youtube.com/watch?v=50G2uLFDo5I
4th September 2010, 12:02 AM |#7  
Senior Member
Thanks Meter: 3
 
More
Just take it to the closest Samsung Service Center for repair/replacement. Forget the dealer. If you have proper warranty papers there shouldn't be a problem.

Same thing happened to mine, bought directly from Vip, about one hour after turning it on. Returned it to the Vip center and got a new unit 2 days later.

In any case, the address of the authorized service center is somewhere on the eastern outskirts of Zagreb.
4th September 2010, 02:25 AM |#8  
Neo-ST's Avatar
OP Senior Member
Thanks Meter: 15
 
More
It's got warranty papers of that guy's company. I don't think it would be accepted by official Samsung service center because it's not the original Samsung warranty paper that is legitimate in every Samsung center. This guy owns a small cellphone service company, sells cellphones bought outside of Croatia and gives his own warranty on them. Who knows how he gets them, I just know he had Galaxy S far sooner than it appeared here officially. Thanks for the advice anyway...
4th September 2010, 11:18 AM |#9  
Neo-ST's Avatar
OP Senior Member
Thanks Meter: 15
 
More
Quote:
Originally Posted by BronzedDroid

Have you flashed any new firmwares lately?

Do you recommend to flash a new firmware? I've read guides and I can do it, I just need an advice which firmware to flash? Will it void the warranty?
4th September 2010, 02:51 PM |#10  
Neo-ST's Avatar
OP Senior Member
Thanks Meter: 15
 
More
Sorry for posting one post after another, but this is important. I found someone else with the same problem: http://forums.whirlpool.net.au/forum....cfm?t=1520586
I don't think I'm gonna try flashing the firmware, I'll wait until monday to contact the warranty guy and ask for repair of the device or the replacement. I will also send him a link to this post, so if you can take your screenshots, now would be a good moment :/
Thanx
5th September 2010, 12:00 AM |#11  
Senior Member
Thanks Meter: 3
 
More
I'd do the shots but I've got nothing to take them with. Sorry.

In any case, a replacement is necessary. It's definitely a hardware fault and it appears to affect early units. My replacement device has a later manufacture date and a newer firmware than the first, dead one.
Post Reply Subscribe to Thread

Tags
colour, display, galaxy s, i9000, screen

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes