FORUMS
Remove All Ads from XDA
Honor 9 Lite

min scaling CPU freq != cpuinfo min freq

229 posts
Thanks Meter: 10
 
By chris..., Senior Member on 25th September 2010, 04:05 AM
Post Reply Email Thread
Hello,

Is there any reason why the scaling min freq is not equal to the cpuinfo_min_freq?

By default the scaling min freq is set to 245760
However the cpu can go to 122880

I have manual set this and the phone seems to run fine, changing freq on demand as need and slowing back as it should

I tried editing the /init.qcom.post_boot.sh so it does it every time on boot up but it just overwrote the file with the default
 
 
27th September 2010, 03:22 PM |#2  
arcatarc's Avatar
Senior Member
Flag Anguillara Sabazia (ROMA)
Thanks Meter: 2,575
 
Donate to Me
More
Quote:
Originally Posted by chris...

Hello,

Is there any reason why the scaling min freq is not equal to the cpuinfo_min_freq?

By default the scaling min freq is set to 245760
However the cpu can go to 122880

I have manual set this and the phone seems to run fine, changing freq on demand as need and slowing back as it should

I tried editing the /init.qcom.post_boot.sh so it does it every time on boot up but it just overwrote the file with the default

I use overclock widget and it do the job (need root)
3rd October 2010, 04:26 PM |#3  
Account currently disabled
Thanks Meter: 1
 
More
True, overclock widget sets it perfectly, lets hope this saves more battery

To check cpu running speed use system panel ..
4th October 2010, 02:59 PM |#4  
Junior Member
Thanks Meter: 0
 
More
I think that there's a reason cause they set the kernel to that frequency. Probably 122mhz is too low for gsm csmda radio activity or probably cause after some tests they saw that there was no difference in stand by between the two power consumption levels.
4th October 2010, 03:26 PM |#5  
OP Senior Member
Flag Melbourne, Australia
Thanks Meter: 10
 
More
I got no problem when on idel setting the max cpu freq to the lowest speed possible
4th October 2010, 04:20 PM |#6  
Junior Member
Thanks Meter: 0
 
More
If there were not problems about it they would set it to 122Mhz. Maybe they solved some lags, who know what. But if it's at 245Mhz a reason exists.
Anyway.... I don't know too, I think only Sony Ericsson developers could tell something about this choice.
4th October 2010, 06:58 PM |#7  
OP Senior Member
Flag Melbourne, Australia
Thanks Meter: 10
 
More
Probably so their crappy interface and built in demo apps can work
5th October 2010, 08:19 PM |#8  
Senior Member
Flag Helsinki
Thanks Meter: 5
 
More
Have had no issues running this at boot time ( via root )

---------------------- snip ---------------
#!/system/bin/sh
echo 122880 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
---------------------- snip ---------------

i save this as "slow.sh"

then run

#sh slow.sh

now idle uses 122.88 mhz and saves alot of battery!
6th October 2010, 08:46 AM |#9  
Senior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by morning_wood

Have had no issues running this at boot time ( via root )

---------------------- snip ---------------
#!/system/bin/sh
echo 122880 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
---------------------- snip ---------------

i save this as "slow.sh"

then run

#sh slow.sh

now idle uses 122.88 mhz and saves alot of battery!

Hi Morning_wood

Could you please share the whole procedure for us newbi's .. i think saving battery life would help us all allot
6th October 2010, 10:29 PM |#10  
OP Senior Member
Flag Melbourne, Australia
Thanks Meter: 10
 
More
Quote:
Originally Posted by kimb0

Hi Morning_wood

Could you please share the whole procedure for us newbi's .. i think saving battery life would help us all allot

use the "overclock widget" app
You have separate min/max speeds while idle and while running
7th October 2010, 07:47 AM |#11  
Senior Member
Flag Helsinki
Thanks Meter: 5
 
More
Quote:
Originally Posted by kimb0

Hi Morning_wood

Could you please share the whole procedure for us newbi's .. i think saving battery life would help us all allot


1. you need root
2. create file "slow.sh" with this entry ( can use notepad or whatever )

#!/system/bin/sh
echo 122880 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

save anywhere eg: /sddcard/slow.sh

3. open a terminal *ConnectBot works fine

4.
$su
#sh /sdcard/slow.sh

5. exit your terminal



note: you need to do this everytime you reboot your phone

I use Android System Info ( System / CPU tab ) to check the cpu usage
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes