Remove All Ads from XDA

Dell Streak won't start

4 posts
Thanks Meter: 0
By leonardm, Junior Member on 1st October 2010, 07:40 AM
Post Reply Email Thread
Yesterday, before going to sleep I checked my mail and layed my phone next to me. This morning I grab my phone but it doesn't respond. I just charged it for an hour but still no response... Any suggestions
1st October 2010, 07:54 AM |#2  
Junior Member
Thanks Meter: 0
Remove & install battery, then boot up again?
1st October 2010, 08:08 AM |#3  
OP Junior Member
Thanks Meter: 0
I allready did that twice without result but after reading your reply I tried again. Now I replaced the SIM and SD card too and now it's working again! Thanks.
1st October 2010, 06:20 PM |#4  
Senior Member
Flag Valle de San Isidro
Thanks Meter: 13
Don't want to bring you down but It sort of happened the same for me, I went to sleep with 85% batt, plugged the charger went to bet, next moring tried to tur on, nothing, charger was still on, tried pulling te batt out, turn on no luck. Still haven't been able to figure it out but I know my streak won't charge the battery so I'm charging the batt outside the streak ordered a second batt so no way to test cable/battery ATM, so far can't say if it's the battery but it don't look like the battery is the problem. forgot to mention, a couple of times I saw the empty battery icon, so i used a BB Bold battery to jump start the phone (just making sure the streak was ok heh), only thing I can think off is that there was a power surge of some sort and took the charging IC with it. The cable works fine for sync and x-fer files but charging is a NO go. it goes as far as telling where the power source is coming (USB/AC) but thats about it. no charge.

so before reaching my conclution i say make sure the metal contacts are touching the battery, make sure the battery has charge if you are an avid electronics guy I say check voltage on the battery and see how is that doing. I've read a lot lately to see what can be my problem and there is one tiny hope that the battery might have triggered it's security gimmick and it won't take charge the "smart" way and that is why I have to use a Li-ION "desk" charger. But I don't know that much of batteries.

I hope it guides you towards what might be happening. Not a solution but you're not alone.


LOL, I realized you fixed the problem. nice one!
2nd October 2010, 07:37 PM |#5  
da_jojo's Avatar
Senior Member
Flag Utrecht
Thanks Meter: 5
when you have a lot of applications running which consume a lot of battery you will notice the streak is going to tell you the charger is invalid. infact there is more powerdrainage then charging capacity. this shouldnt happen with the dell adapter which delivers 1 ampere at 5v instead of the pc which gives 500mA.
if this happens to you one time that the device wont turn on or do anything anymore unplug it from AC and detach the usb cable . then attach the usb cable to the pc and stick the other side in the device and wait for it to show desktop, should be no longer then 30 secs for it to show. (you need the dell sync software and drivers being installed)
8th May 2011, 12:31 AM |#6  
bleech's Avatar
Junior Member
Flag Coffs Harbour
Thanks Meter: 1
Unhappy Dell Streak 7 won't power on or off
Had my 7 for a few days now, the screen was intermittently not responding so I checked out a few forums - decided to calibrate the screen - so powered it off and then powered it back on holding the power button and the + and - volume simultaneously. Now it won't power back on properly - I just the the soft buttons lighting up. It also won't power off. I have plugged into the ac power charger and the power light does not go on at all (orange or green). It had pretty much a full battery when all this happend about 10 minutes ago.

Fixed it - buy pressing the hard reset button adjacent to the SD card slot. Now working well.
The Following User Says Thank You to bleech For This Useful Post: [ View ] Gift bleech Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes