Remove All Ads from XDA

[Q] data problems on an unlocked rogers xperia x10 on telus network

47 posts
Thanks Meter: 3
By djkorben, Member on 1st October 2010, 06:57 PM
Post Reply Email Thread
Hey All,

i dont know if anyone else is having this issue or knows which specific forum to put this into would be the best, but here goes

i have an unlocked xperia x10, voice calls and text worked right away, but i had to go into the settings in the phone and insert an APN for telus to get the 3G connection working. i found all the correct settings on the telus mobility website but i cant put a link in this post

now, the map program, google talk, the browser, youtube and the market work just great, but trying to connect to the facebook app, the windows messenger app, the weather channel/weatherbug apps as well as the movies app just come up with errors saying theres no data connection or your user name and password are wrong

the funny thing is is using that "timescape" thing that comes on this phone, i can log into facebook just fine that way, but that program is kind of silly and i just want to use the normal app.

i'm typing in everything correctly but i just cant seem to figure it out.. anyone out there feel like shedding some light on this? i've asked telus about it and they call it a "grey" phone and just refuse service. haha. woe is me

thanks in advance!
5th October 2010, 06:19 PM |#2  
SlyGuy9999's Avatar
Junior Member
Flag Toronto
Thanks Meter: 0
The APN settings that has worked for me are:

Telus SP




(Not set)

(Not set)

(Not Set)

hxxp:// (replace the xx with tt)

MMS proxy

MMS port



APN type
(Not set)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes