Remove All Ads from XDA

[Howto] App2sd Step by step

223 posts
Thanks Meter: 53
By wolfilein, Senior Member on 5th October 2010, 09:45 PM
Post Reply Email Thread
24th May 2011, 03:23 PM |#491  
Junior Member
Thanks Meter: 0
if i want to install more than 10mb my phone is write this:Not enough space to install. ido all it and my apps/games was installed to sd but i cant install more than 10mb./LG optimus 2.1 eclair/
4th June 2011, 12:56 PM |#492  
Junior Member
Flag Jenin
Thanks Meter: 1
xperia x10i
when i try it for first time it's works very good
but when i flash my x10i this morning to:
Sony Ericsson X10i_2.1.B.0.1_CUST-DE GENERIC 1235-7836 - German Generic
Baseband: 2.1.67
Kernel: 2.6.29
rooted: Flashtool
adb shell
adb server is out of date. killing...
ADB server didn't ACK
* failed to start daemon *

Plz help
4th June 2011, 01:30 PM |#493  
Junior Member
Flag Jenin
Thanks Meter: 1
Smile worked
sorry it's work now...
the problem was I follow the instruction while "FlashTool" was opening
I close every thing and start again ... and it's works very good
23rd June 2011, 02:12 PM |#494  
Junior Member
Thanks Meter: 0
Wink drives me nuts
ok i followed all steps. had to restart all over again due to my incapability to read...
Finally made it to final step, my Xperia X8 rebooted and all seems to work fine.
When i install an app however it still installs it on my phone's memory. Basicly all that changed IMO is a loss of the memory i assigned to ext2.
running latest 2.1 update from sony and started with fresh install.
Where did I go wrong?

edit: i just installed a ~50MB app (pocket legends) and it seems it only took about ~10MB on my phone's memory. could it be that the max empty memory (e.g. 256MB) can't go higher than the factory's default and is in fact now shown as a percentage of my total memory? i.e. i have 1000MB total but it only shows 100MB. when i take 100MB from the total it goes down to 90MB (10%)
really confused now, hope to make a summary that makes sense when i've had my dinner
18th July 2011, 03:27 PM |#495  
CSankar's Avatar
Junior Member
Thanks Meter: 1
Thumbs up Hi
Originally Posted by wolfilein

i will add some pictures if a have the time

I am confused. I am new to XDA forum and I've E10i. Without deleting the /data/app in the internal memory, is it possible to have both Internal/External as app2? So that incase of any issues, we will still use the Old one correct?

I like your support. WELL DONE.
30th September 2011, 01:16 PM |#496  
srikzrulez's Avatar
Senior Member
Flag Kakinada
Thanks Meter: 25
I succed in rooting my device.. NOW going 4 this. . thank u
3rd September 2012, 12:18 PM |#497  
Flag Amman
Thanks Meter: 3
Can you please send me by email detailed steps to do this.
I'm trying to follow your steps but in CMD the adb not working with me and i do not know why and please advice what i need to download before I start.
Please reply to:

Thanks in advance

Originally Posted by wolfilein

a big part of this new tutorial is not from me, credits go to tot31

New version out !!

Now you can choose if you also want to move the dalvik cache an the /data/data directory to sd (if you have an slow sd-card this will be a bit laggy) (to use this you can now use the update funktion)

and i've added an update funktion and protectet the install function so now you can't install app2sd two times an brick your fimrware

and if this help you you can help/thanks me

If You have an x10 mini (pro) go here :

The leds on boot are Now working :

blue means:

no proplem with sd card booting normal

purple/voilet means
sdcard malfunktion booting with failsafe


How To : App2sd on Xperia X10i

Pre Installation.
Root the phone by using z4root ( )

Step 1 : Preparing your micro SD Card.
Please refer to this link ( ) on how to prepare your micro sd card.

For better performance I would advise that you use a Class 10 card instead of the original card that comes with the phone because the card is only Class 2 card. For more infomation on speed class rating of sd card please go here ->

An excerpt taken from wikipedia :-
The following are the ratings of some currently available cards:
* Class 0 - These cards do not specify performance, which includes all legacy cards prior to class specifications.
* Class 2 - Minimum of 2 MB/s performance. Lowest speed for SDHC cards.
* Class 4 - Minimum of 4 MB/s performance.
* Class 6 - Minimum of 6 MB/s performance.
* Class 10 - Minimum of 10 MB/s performance.

Note : The recommended maximum size of ext2 partition is 1.4GB. I've tried 3GB before and ended up with unstable system and eventually crash the phone. So if you're really greedy since you've bought a 16GB or 32GB card to partition the ext2 more than the recommended size and if your phone is unstable, you've been warn but normaly 1.4 GB are enough

Step 2 : Download the related files.
1. App2sd : see attachment
2. adb shell : see attachment

Step 3 : Enabling USB Debugging mode on you phone.
Go to Settings -> Applications -> Development -> USB Debugging (check this option).

Step 4 : Installing App2sd.
Create a folder name adb in your pc and extract all the files from into this folder.

Connect your phone to your pc and mount the sd card. Extract all the file from to the root of your sd card. Make sure to unmount the sd card before continue the next step.

In your pc open up a dos terminal box by typing cmd in the Search programs and files box.


cd /adb

then type

adb shell

then type

sh /sdcard/

you'll be presented by this screen...
|*Welcome To wolfilein's App2sd *|
|*installing script *|

~this version should be go on any device ~

|* Menu *|
|* *|
|*[0] install app2sd *|
|* *|
|*[2] exit *|

now just press the enter key & wait.

Important : Make sure to set your phone screen timeout to the max because Superuser will ask for your permission to allow this script to run. If your screen goes blank, you can't see this prompt and the installation will fail.

after a while you'll get this..

busybox is /system/bin/busybox
rm failed for /etc/, No such file or directory
| finished going reboot now |

the both messages above doesn't mean that your installation has failed

Finally after a reboot, your phone is ready with app2sd. From now on when you install any applications it will save into your sd card.

Disclaimer : Do this at your own risk. I will not responsible if any injuries or damage occur to you or your phone

8th April 2013, 08:53 PM |#498  
ramzidjoudi's Avatar
Senior Member
Thanks Meter: 86
not working for me i don't know why
i do all the steps
but when reboot i have nofified thad sd card is umpty and need to be formatted
an when i format it second partition (ext2) disappear
4th June 2013, 08:50 AM |#499  
Junior Member
Thanks Meter: 0
Originally Posted by ramzidjoudi

not working for me i don't know why
i do all the steps
but when reboot i have nofified thad sd card is umpty and need to be formatted
an when i format it second partition (ext2) disappear

so do i. i was try like the tutorial, but if i plug in my sd to phone only "sd card blank..." appeared.
i was try make the 2nd partition system as fat32 too, but new problem appear. only 2nd partition readed by phone. in this chase, i can link the app but i can't play musics i was copied from pc to sd cos in pc only sd #1 patition can readed and phone only read the #2 partition.

back to ext2/ext3/ext4 problem, i was tried to mount manually ext2 with terminal operator (like mount ext2 for /cache in ubuntu/proxy) but i realize how i can mount the partition while the sdcard not detected by phone.

---is x10 gb 2.3.3 support ext2 format?---

please anybody help me resolve this problem
17th November 2013, 06:46 PM |#500  
heavymetall66's Avatar
Senior Member
Flag Landshut
Thanks Meter: 113
Any News about DATA ON EXT4 ??
Post Reply Subscribe to Thread

app2sd, xperia

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes