FORUMS
Remove All Ads from XDA

[Info/brainstorming] Compiling modules for the 2.6.32 beta kernel OBSOLETE

1,640 posts
Thanks Meter: 3,930
 
Post Reply Email Thread
This thread is now obsolete.
Kernel sources for build 5.26.0 have been released:
https://opensource.motorola.com/sf/g...e_source_froyo

I've pushed some new pre-compiled modules to github, though beware, I haven't had time to test all of them on device yet:
https://github.com/nadlabak/android_...8d57186748a370

As the kernel sources are not yet available from the Motorola's open source project, here is an outline how I compiled the overclock and cpufreq governor modules. (Btw., the overclock module needed a substantial adaptation, see the source here: http://android.doshaska.net/2.6.32oc )

I'm using the sources from this AOSP repo:
Code:
git clone git://android.git.kernel.org/kernel/omap.git
git checkout --track -b android-omap-2.6.32 origin/android-omap-2.6.32
Use the sholes config:
Code:
make sholes_defconfig
flags that need to be disabled:

CONFIG_LOCALVERSION_AUTO
CONFIG_MODVERSIONS
CONFIG_DEBUG_MUTEXES
CONFIG_SCHEDSTATS
CONFIG_SCHED_DEBUG


[updated on 17.01.2011, thanks go to Skrilax_CZ]
At least the ext2 will work without panics when compiled using this config.

For tun, cifs and nfs there is still some additional config mismatch that prevents the modules to work without null pointer dereference oops.

Also, even when no custom kernel module is used, you can get the kernel panic very easily, try to enable wifi and do:
Code:
cat /proc/kallsyms

If you're interested in a more detailed android kernel compilation guide, you can e.g. roughly follow this Droid kernel guide: http://www.droidforums.net/forum/res...wn-kernel.html
The Following 2 Users Say Thank You to kabaldan For This Useful Post: [ View ]
 
 
18th October 2010, 04:22 AM |#2  
Senior Member
Thanks Meter: 141
 
More
Thanks for starting this thread kabaldan! It is a great starting point in tackling the issue of adding tun support to the new kernel (tun.ko module). I am not as good as many others in this, but trying won't hurt. Meanwhile if someone else is working on tun support - share experience here!
18th October 2010, 06:38 PM |#3  
xphp's Avatar
Junior Member
Thanks Meter: 0
 
More
If kernel seems to be ok, sometimes mounting with new version of busybox won't work.
I used to get kernel panic when use newer version of busybox (not Android kernel but my own embedded linux)
19th October 2010, 07:31 PM |#4  
Senior Member
Flag Sofia
Thanks Meter: 7
 
More
Hey Nadlabak can you add DLNA function of CM6?
22nd October 2010, 08:48 PM |#5  
yantz's Avatar
Senior Member
Thanks Meter: 161
 
More
same problem using droidx kernel sources. insmod ok, mount reboots the phone

yantz
22nd October 2010, 10:19 PM |#6  
Senior Member
Thanks Meter: 141
 
More
I tried droid2 kernel module - doesn't work either

I noticed OpenVPN included in CM6 also relies on this kernel module. Hence doesn't work. I guess we won't (ever) see kernel sources for that leaked kernel we are now using. I assume Motorola will release the sources sooner or later, but not before official Froyo layout. The waiting is killing me! kabaldan, can't you try to do some magic as you did with the overclock module? The beer is from me!!!
22nd October 2010, 11:56 PM |#7  
kabaldan's Avatar
OP Recognized Developer
Flag Prague
Thanks Meter: 3,930
 
Donate to Me
More
Can you test this attached tun.ko?
Insmod is OK, but I currently don't have time for any further tests...
EDIT: don't bother, kernel panic as usual
23rd October 2010, 06:46 AM |#8  
Senior Member
Thanks Meter: 141
 
More
Module loads fine, but when attempt to use it, phone reboots, just like with the module compiled from DroidX sources..
28th October 2010, 01:47 PM |#9  
Senior Member
Flag 天津
Thanks Meter: 8
 
More
Quote:
Originally Posted by leobg

Module loads fine, but when attempt to use it, phone reboots, just like with the module compiled from DroidX sources..

So, I got it loaded - insmod works just great, just like it did on the 2.1 kernel.

I'm trying to use the CM6 built-in OVPN settings, but I can't find any documentation on the setup. How did you get it set up?

I have

/sdcard/openvpn/

cert.crt
ca.crt
config.conf
config.ovpn
pem.key

I realize that config.conf and config.ovpn are the same file- but I use this VPN on windows and on Mac, and I wasn't sure the requirements on Linux.

If I can't find some documentation I'll try downloading the OpenVPN settings app from the market and playing with that.

Also, I don't know if it's true or not, but I heard the Milestone2 source compiled driver could work.
28th October 2010, 09:31 PM |#10  
Senior Member
Thanks Meter: 141
 
More
Are you trying the module kabaldan provided? It doesn't seem to work, at least for me. Loads fine, but phone crashes when setting up tun interface. I couldn't get OpenVPN in CM6 0.3 to work so far. I am testing the tun.ko with the cisco vpn package (which worked great on the old kernel with CM6 0.2) vpnc. When I initiate the connection, phone reboots if the attached here tun.ko is used. I also tried with tun.ko compiled from DroidX sources - same thing - phone reboots. I am not sure where did kabaldan take/compile this module from.

Sent from my Milestone using Tapatalk
29th October 2010, 12:47 AM |#11  
Senior Member
Flag 天津
Thanks Meter: 8
 
More
I was using the same one, I was thinking maybe he could use the info from more than one phone. I'll try get-a-robot or OpenVPN Installer, but I won't hold my breathe. I was just hoping to use the built-in functionality of the ROM.

*edit* Just saw he removed it because it doesn't work yet, oh well.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes