FORUMS
Remove All Ads from XDA

[GUIDE] Wrong hardware keyboard layout

441 posts
Thanks Meter: 104
 
Post Reply Email Thread
Okay. Since a lot of people are starting to link to this thread when people have problems with the hardware keyboard, I thought I would change this post to a guide instead

This guide is using ADB. Guide to root explorer method: http://forum.xda-developers.com/show...5&postcount=33 (Credits to the original poster).

1. Paste the following lines in a CMD (windows) or Terminal (mac) and it's assumed that you have root
Code:
adb shell
su
mount -o remount,rw -t yaffs2 /dev/block/mtdblock0 /system
cp /system/usr/keyboard-config/keyprint.xml /sdcard/keyprint.xml
Now you have the keyprint.xml on your SD Card. Open it with your favorite text editor (On your computer).

You will get a file looking like this:

Code:
<?xml version="1.0" encoding="utf-8"?>
<!--
 *********************************************************************
 *  ____                      _____      _                           *
 * / ___|  ___  _ __  _   _  | ____|_ __(_) ___ ___ ___  ___  _ __   *
 * \___ \ / _ \| '_ \| | | | |  _| | '__| |/ __/ __/ __|/ _ \| '_ \  *
 *  ___) | (_) | | | | |_| | | |___| |  | | (__\__ \__ \ (_) | | | | *
 * |____/ \___/|_| |_|\__, | |_____|_|  |_|\___|___/___/\___/|_| |_| *
 *                    |___/                                          *
 *                                                                   *
 *********************************************************************
 * Copyright 2010 Sony Ericsson Mobile Communications AB.            *
 * All rights, including trade secret rights, reserved.              *
 *********************************************************************
-->
<!--
    Keyprint name: QWERTY Swedish/Finnish
-->
<keyprint>
  <script name="cyrillic" keylayout="cyrillic"/>
  <script name="greek" keylayout="greek"/>
  <script name="latin" keylayout="qwerty-no-dk"/>
</keyprint>
It's the line
Code:
  <script name="latin" keylayout="qwerty-no-dk"/>
We're interested in. "qwerty-no-dk" represents your hardware keyboard layout.
This can be changed to anything found in the layouts folder.

You can see the avaliable languages by typing the following commands (I assume you started a new CMD or terminal)

Code:
adb shell
su
cd /system/usr/keyboard-config/layouts
ls
Now you get a list of all the avaliable languages in your firmware. And can change the keyprint.xml file accordingly.

When you're done, save the file. It's now time to upload it again.
And again, type the following commands, in a new CMD or Terminal.

Code:
adb shell
su
mount -o remount,rw -t yaffs2 /dev/block/mtdblock0 /system
cd /system/usr/keyboard-config/
rm -r keyprint.xml
cp /sdcard/keyprint.xml /system/usr/keyboard-config/keyprint.xml
Now you need to reboot your phone, and you'll have the new hardware layout

ENJOY!

(Oh, and if there's any errors in this guide, please tell me. This is done out of my memory.)

Quote:
Originally Posted by Original post

Hey!

I've changed my build.prop file to a NG2 code yesterday, and got the 1.2 update for my X10 mini pro.

However, now the keyboard layout of the hardware keyboard is swedish or something. I want it to be danish!

Æ becomes ä
Ø becomes ö

But å is right.

What file/files should I look in for the config?

I've got danish language on the phone, it's just the layout for the hardware keyboard that's wrong.

The Following 3 Users Say Thank You to dthomasen For This Useful Post: [ View ] Gift dthomasen Ad-Free
 
 
28th October 2010, 05:59 PM |#2  
Senior Member
Flag São Paulo
Thanks Meter: 66
 
More
http://forum.xda-developers.com/show...3&postcount=88
28th October 2010, 06:42 PM |#3  
dthomasen's Avatar
OP Senior Member
Flag Aarhus
Thanks Meter: 104
 
More
Quote:
Originally Posted by vlissine

http://forum.xda-developers.com/show...3&postcount=88

hmm thanks. but it didn't work

I've got the file, and as I thought it said swedish / finish layout.
It looked like this:
Code:
<keyprint>
  <script name="cyrillic" keylayout="cyrillic"/>
  <script name="greek" keylayout="greek"/>
  <script name="latin" keylayout="qwerty-se-fi"/>
</keyprint>
I've tried changing it to:
Code:
<keyprint>
  <script name="cyrillic" keylayout="cyrillic"/>
  <script name="greek" keylayout="greek"/>
  <script name="latin" keylayout="qwerty-dk"/>
</keyprint>
didn't work.
Then I tried:
Code:
<keyprint>
  <script name="cyrillic" keylayout="cyrillic"/>
  <script name="greek" keylayout="greek"/>
  <script name="latin" keylayout="qwerty-dan"/>
</keyprint>
And still no luck

Any ideas?
28th October 2010, 07:21 PM |#4  
Senior Member
Thanks Meter: 29
 
More
How about qwerty-da?
28th October 2010, 07:24 PM |#5  
dthomasen's Avatar
OP Senior Member
Flag Aarhus
Thanks Meter: 104
 
More
Quote:
Originally Posted by thekindladies

How about qwerty-da?

nope

Checked the folder Layouts inside the keyboard-config folder. And in there there's a layout called qwerty-se-fi (like it was when I pulled the keyprint.xml the first time), and there's one called qwerty-no-dk and i've tried changing the keyprint file to qwerty-no-dk, but still no luck :S
28th October 2010, 08:13 PM |#6  
dthomasen's Avatar
OP Senior Member
Flag Aarhus
Thanks Meter: 104
 
More
nevermind.. played around with the files, and now it works.. don't know what I did

But thanks for your help!
28th October 2010, 08:19 PM |#7  
Senior Member
Thanks Meter: 29
 
More
and I was just about to tell you I was going to try it out on my phone. I might do it anyway. I might be asking for your help
28th October 2010, 08:22 PM |#8  
dthomasen's Avatar
OP Senior Member
Flag Aarhus
Thanks Meter: 104
 
More
Quote:
Originally Posted by thekindladies

and I was just about to tell you I was going to try it out on my phone. I might do it anyway. I might be asking for your help

hehe.. You just do that

think the trick is to delete the original keymap file from the phone before copying. and not just overwriting.

And maybe to do a restart immediatly after, and selecting the right language (again) in the settings..

That's what I did when it worked
28th October 2010, 08:32 PM |#9  
Senior Member
Thanks Meter: 29
 
More
I simply moved my modified file to the keyboard-config folder with root explorer and it got overwritten. I now definitively have a qwerty keyboard. Tell me, where are those elusive Danish letters supposed to be?
28th October 2010, 08:54 PM |#10  
Senior Member
Thanks Meter: 29
 
More
ok, found them. though i didn't need to change the language in settings. lovely. i shall certainly not be keeping azerty =D
28th October 2010, 09:20 PM |#11  
dthomasen's Avatar
OP Senior Member
Flag Aarhus
Thanks Meter: 104
 
More
Quote:
Originally Posted by thekindladies

ok, found them. though i didn't need to change the language in settings. lovely. i shall certainly not be keeping azerty =D

haha
maybe that's not what did the trick then.. As said, I don't know what I did
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes