FORUMS
Remove All Ads from XDA

[Q] unable to update to 2.1 (download?)

219 posts
Thanks Meter: 16
 
By daml, Senior Member on 1st November 2010, 02:49 PM
Post Reply Email Thread
Ok so I tried updating my australian (3) X10minipro to uk generic. Sony companion tells me it was upto date.

Not a problem I thought, well I must have the uk firmware...

So I went ahead and edited build.prop again to install 2.1. Same problem? Sony companion tells me the phone is upto date.

Thats ok I went and tried to force repair of phone but now im told:


"unable to download your phone software. please check your internet or try again later."


Screenshot:

http://www.box.net/shared/cpvz526x06


Any help appreciated. Have I done something wrong. I am using the build.prop out of a thread in this forum.


Thanks
 
 
1st November 2010, 03:15 PM |#2  
OP Senior Member
Flag Melbourne
Thanks Meter: 16
 
More
Hmm now I'm trying to edit my build.prop to the uk one again. So I can try force restore on that then try the 2.1 firmware again.

rm build.prop
rm failed for build.prop, Read-only file system

Any idea on this too? It's all so frustrating no-one else seems to be having any problems.
1st November 2010, 03:16 PM |#3  
SRT_'s Avatar
Junior Member
Thanks Meter: 1
 
More
The update is not yet available anywhere else than the nordic countries... It will be more widely available in the next weeks... Changing to UK f/w won't help...
1st November 2010, 03:22 PM |#4  
OP Senior Member
Flag Melbourne
Thanks Meter: 16
 
More
That is correct. I am trying to update my australian x10 mini to nordic firmware. This is entirely possible.

http://forum.xda-developers.com/showthread.php?t=824766



Are you a sony ericsson representative?
1st November 2010, 04:12 PM |#5  
OP Senior Member
Flag Melbourne
Thanks Meter: 16
 
More
ok. Got the uk prop file on the phone. i used root explorer to mount the filesystems read write. same original error now.


pc companion download error.


im lost now... what am i doing wrong
1st November 2010, 04:38 PM |#6  
Member
Thanks Meter: 0
 
More
I can only tell you that changing to UK prop won't help because 2.1 has (to the best of my knowledge) not been released in the UK yet.
1st November 2010, 04:44 PM |#7  
OP Senior Member
Flag Melbourne
Thanks Meter: 16
 
More
But dont I need uk generic before doing an update to nordic 2.1?
1st November 2010, 04:48 PM |#8  
darfito's Avatar
Senior Member
Flag Tenerife
Thanks Meter: 7
 
More
That's true... I'm awaiting as well. I have the UK generic ROM... I thought will be the first one, but most of us were wrong...
1st November 2010, 04:52 PM |#9  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by daml

But dont I need uk generic before doing an update to nordic 2.1?

You need a nordic generic to update to nordic 2.1.
UK is not a nordic country (serious apologies if that comes across as patronising)
1st November 2010, 04:54 PM |#10  
darfito's Avatar
Senior Member
Flag Tenerife
Thanks Meter: 7
 
More
Quote:
Originally Posted by daml

But dont I need uk generic before doing an update to nordic 2.1?

why don't you wait only one day? i'm sure tomorrow or after tomorrow everybody will have the update.
1st November 2010, 05:45 PM |#11  
Senior Member
Flag Dundee, Scotland
Thanks Meter: 52
 
More
Quote:
Originally Posted by darfito

That's true... I'm awaiting as well. I have the UK generic ROM... I thought will be the first one, but most of us were wrong...

How do you know if you have the UK Generic rom?

I got my mini pro on o2 last week but there is no o2 branding at all on it.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes