Remove All Ads from XDA
Honor 9 Lite

X10 Mini 2.1 incl. Flashtool (Updated Flasher 14.11.2010)

2,005 posts
Thanks Meter: 5,929
By Bin4ry, Recognized Developer on 1st November 2010, 08:02 PM
Post Reply Email Thread
2nd November 2010, 01:04 AM |#31  
Junior Member
Thanks Meter: 0
Had the same problem with java SDK on 64bit but tried on another computer runnin on x86 system and 32bit SDK. Works like a dream!

Incredible job bin4ry and thanks to all the others who helped out!
2nd November 2010, 01:31 AM |#32  
Thanks Meter: 0
Thanks bin4ry
I'm from Croatia. Flashed like charm.
All working...
2nd November 2010, 01:35 AM |#33  
Junior Member
Thanks Meter: 0
@aZuZu and everyone else it worked for!
OS, java version..?

just tried a different pc with win7 32bit, got a different java error something with it not being able to open a channel...?!?
2nd November 2010, 01:48 AM |#34  
Junior Member
Flag Santiago
Thanks Meter: 0
Hey guys, I tried to do everything you said in here, but here's what I get...

Please choose:
1.) 32-Bit Windows XP
2.) 64-Bit Windows XP
3.) 32-Bit Windows Vista/7
4.) 64-Bit Windows Vista/7
Please choose: (1-4): 4
please connect Xperia in flash mode.
Press any key to continue . . .

01-11-2010 08:32:35 PM X10flash main
INFO: Start
01-11-2010 08:32:35 PM X10flash readReply
INFO: <<< cmd=1,flags=1,length=46
01-11-2010 08:32:44 PM X10flash readReply
INFO: ### read filed : checksum err! FFFFFFFF!=0
01-11-2010 08:40:09 PM X10flash testPluged
INFO: <<<
01-11-2010 08:40:09 PM X10flash writeCmd
INFO: write(cmd=1) (finish)
Exception in thread "main" java.lang.NullPointerException
at java.lang.String.<init><Unknown Source>
at X10flash.testCmd01(
at X10flash.main(
Press any key to continue . . .

Can anybody help me with this and tell me why I cannot upgrade my OS?? Please tell me how I can Install it... My cel is a Xperia X10 Mini (southamerican it's X10a or something like that?)

2nd November 2010, 02:00 AM |#35  
Thanks Meter: 0
how i did flash process...
connected cell so that pc camp can find it...

start >> run >> cmd

cd x10flash-2.1
x10flash.bat ...
1 >> becouse i have 32 bit xp..

press any key to continue...

i have shut down cell phone... unplug side from pc...
wait 10 sec... press back button and pluged cable in pc... then i have
holded back and turn off pc campaninon...
switch to cmd where x10flash is runing... pressed space... and release back
button ... and waited till flash is done...
2nd November 2010, 02:07 AM |#36  
Junior Member
Thanks Meter: 0
Thumbs up E10a
I flashed my e10a with this firmware.

Android 2.1 works fine but the 3g not works, but I prefer 2.1 and no 3g

If anyone have the x10a firmware, please publish this, Thanks
2nd November 2010, 03:14 AM |#37  
Junior Member
Thanks Meter: 1
Well, the flash failed with my mini e10i :s
Then i cant use the recovery mode with SEUS or pc companion, so there is a solution?
2nd November 2010, 05:05 AM |#38  
I am new in Android, could we expect any custom 2.1 roms now? some light version without SE preinstalled, software...generic one
2nd November 2010, 05:30 AM |#39  
Thanks Meter: 0
Does this work on e10a?
2nd November 2010, 07:23 AM |#40  
Junior Member
Thanks Meter: 0
Thumbs up
you are a genius! Thank you!
2nd November 2010, 09:51 AM |#41  
小鱼儿's Avatar
Junior Member
Flag Seattle
Thanks Meter: 0
Originally Posted by Bin4ry

Mini-Pro is problematic, because the hardware keyboard will be false :/
I can provide you the nordic firmware, but then you would have some scandinavian letters ...


Well, I just proofed the problematic result...the touch screen doesn't work any more.
Could you please upload the nordic firmware? Thanks.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes