/INIT process Desire HD lag problems...SOLVED ! See post 1

6,669 posts
Thanks Meter: 3,297
By Rixsta, Retired Forum Moderator on 2nd November 2010, 01:37 PM
Post Reply Email Thread
I'd like to know if anyone is having the same lag problems as I am getting from time to time..
The lag happens for no reason and comes at different times while doing different things.
I downloaded Watchtower from the Android Market to monitor what was happening. When the phone is running fast the /INIT process is showing as soon as the lag starts to happen I check Watchtower again and the /INIT process is at anywhere from 70% to 100% CPU usage.
I dont use an app killer but I donwloaded one to try and see if it would correct the problem, it doesn't. The only way to solve the lag is to Restart the phone, then its fine for the rest of the day, sometimes two days but it always comes back.
I sold my SGS because of the lag issue and now it seems I have it with the DHD..
I did google this and I found that it maybe something to do with android itself..looks like /INIT is an android process..
If you notice your DHD lagging then download Watchtower and I'd bet you will see the /INIT process killing your phone..

EDIT - A fix has been found to stop the /Init process lagging the phone.

On your phone go to..

Menu/settings/applications/development/now turn on Usb debugging..

This seems to keep the / init process at 0% CPU usage, it also works when the /INIT problem starts, turning USB debugging on will make the /INIT process drop back to 0%, very nice to see.
Ive contacted the Dev to find out if he can tell us why this method has fixed the problem.
Still need an update from Htc but at least we can use our phones again..
There doesn't seem to be any negative effects from turning this option on, the only thing to note is turning it off to connect to your pc could bring the /init process back and lag your phone. You can download Android Manager from the market for free which will allow you to transfer data from your pc using Wi-Fi, using this app you can keep the USB Debugging on.
EDIT 2 - It looks like you can connect to the pc via USB cable with the debugging turned on without problems, the only difference is that it will try and install additional drivers...because of the debugging mode..
Im using windows 7 and the ABD driver wont need to download Htc Sync on your pc which downloads the ABD driver !!
We should also watch the battery as this may actually increase battery life...

EDIT 3 - Not one single person has come back to me and said that the /INIT problem has returned after this fix...lets hope it stays that way.. 10/11/10
EDIT 4 - A lot of people including myself have found that this fix improves their battery life quite a bit.
Last EDIT before thread is locked just for reference and to help people !!!

For people that have the process that loads the CPU it stays at 80-90% all the time, and i have autosync on, if you stop auto sync the process goes out....

So here is the final fix in the link below (post 7)

Thank you to everyone in this thread for there efforts...amazing response.
Thanks to all the XDA Community...Including the Devs and Mods

Thread Closed
The Following 8 Users Say Thank You to Rixsta For This Useful Post: [ View ] Gift Rixsta Ad-Free
2nd November 2010, 01:44 PM |#2  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
Originally Posted by nednapalm

I'm getting the problem.

No apps installed except the flash and maps update, oh and OS Monitor.

Have turned off "Fast Boot" and removed battery to reset, ok for now. Very scared to start installing more apps, nearly unusable when it is lagging

I also tried the "turn off fast boot and it was ok for 2 days, it came back this morning though..It is very worrying and yes, the phone is unusable until it is Restarted..Thanks for the reply.
2nd November 2010, 01:58 PM |#3  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
Originally Posted by sanju007

I hope not, the samsung galaxy s have lag issus and its very bad and i sold de sgs
And now the DHD gets also lag problems ?
Ik hope not, then i will not buy this phone
Maybe an good task killer wil help ?
More people have lag issus ?

Can you make a video ?

An app killer doesn't solve the problem and Im unsure how many people are having this problem, to my understanding its not many...that's why I started this thread to try and find out.
I wouldn't worry yet...

I will make a video when it happens may take a few days to come back....but it always does...a video added to this thread would be most useful...just have to wait till it rears its ugly head again.
3rd November 2010, 12:54 PM |#4  
lynxboy's Avatar
Senior Member
Flag Leeds
Thanks Meter: 345
So it seems that /init is a core process regarding the initialisation of the Android system and userspace hence the fact it cannot be killed using OSMonitor. It is always the first process that runs on Linux systems after boot and acts as a parent process which itself initialises then processes needed to get the OS going.

Here is a description of the Android Init Process from elinux,


A key component of the Android bootup sequence is the program 'init', which is a specialized program for initializing elements of the Android system. Unlike other Linux systems (embedded or otherwise), Android uses its own initialization program. (Linux desktop systems have historically used some combination of /etc/inittab and sysV init levels - e.g. /etc/rc.d/init.d with symlinks in /etc/rc.d/rc.[2345]). Some embedded Linux systems use simplified forms of these -- such as the init program included in busybox, which processes a limited form of /etc/inittab, or a direct invocation of a shell script or small program to do fixed initialization steps.

The init program processes two files, executing the commands it finds in them, called 'init.rc' and 'init.<machine_name>.rc', where <machine_name> is the name of the hardware that Android is running on. (Usually, this is a code word. The name of the HTC1 hardware for the ADP1 is 'trout', and the name of the emulator is 'goldfish'.

the 'init.rc' file is intended to provide the generic initialization instructions, while the 'init.<machine_name>.rc' file is intended to provide the machine-specific initialization instructions.

The Bug

The /init bug has presented itself on numerous handsets including the HTC Desire, Nexus One and Droid X models. It seems to be specific to Android 2.2 and reports the same symptoms on all handsets. Primarily this is due the 99% CPU usage causing system slowdown and left unchecked, high battery usage. It is not specific to HTC Sense ROMs as it also presents itself on stock releases. The only solution so far is a reboot. Hard Reboots and altering system settings seem to have no effect on the reproduction of this bug.

I can only speculate to what is causing the issue and hopefully a Dev can shed some more light.

Logically it seems as though a 'rogue' process is triggering /init to resume its primary function in regards to checking filesystems and attempting to spawn other system process. Due to some form of miscommunication between the processes in question, /init continues to perform these post boot tasks in a constant loop.

Think of it like this, if you try perform tasks straight after boot, the phone is unresponsive while the SD is mounted/checked and all other processes are fired up. The /init process is responsible for these tasks. If it were to loop, you would experience the symptoms we are having.

I found this on Wikipedia:

After /init has spawned all of the processes specified, init goes dormant, and waits for one of three events to happen:- processes it started to end or die, a power failure signal[clarification needed], or a request via /sbin/telinit to further change the runlevel.

So our trigger should hopefully be narrowed down to these three events.

Regarding what I posted before, the connection between sync and the bug has proven itself to be a false one.

I've also noticed that sometimes the bug can be present, however there is little impact on the responsiveness of the OS. It can seem as though everything is ok yet the CPU load can be extremely high, resulting in poor battery performance.

Anyway, hopefully more people can contribute to this thread so we can build up a better picture of what is going on. I will also try and grab a Logcat and ask anyone else near their PC when it happens to do the same.

There is a thread here which has users complaining of the same problems, yet no solutions are presented. Hopefully we can make a bit more noise and get some definitive answers.

The Following User Says Thank You to lynxboy For This Useful Post: [ View ] Gift lynxboy Ad-Free
3rd November 2010, 03:13 PM |#5  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
Hey guys some great feedback here, as with my link on starting this thread the /INIT is an android 2.2 process, auto sync on/off doesn't solve the problem neither does a hard reset, taking the battery out ect...
The guy in the link says his method worked for him, can't say the same for myself, I have a feeling his problem will be back...but if it did fix it for him then thats great, just cant say the same for me

I have gone 5 days without the problem coming back and then Oh no its back, sometimes it happens twice a day, all the above doesn't fix this problem im afraid from what I have experience anyway.
The /INIT process is only 132k, something so small causes the phone to be basically unusable....very frustrating.
The 1.32.405.6 update also doesn't solve this problem, I updated yesterday and 10 min later I had the dreaded /INIT problem...
The so called "turn off fast boot doesn't fix the problem either, I have had the /INIT lag problem with it switched on and off...
What I find to be the most strangest thing is that if this is indeed an android process which it most likely is then why doesn't every DHD phone have this lag from time to time???.....why only certain phones??..
I haven't had the problem since yesterday (around 12 midday), when it occurs again I will be posting a video as requested...
The mystery continues.......There is NO solution as yet that fixes this problem.

Thanks to Lynxboy, your posts give some good information.
3rd November 2010, 03:44 PM |#6  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
I wonder if this has any relevance to the problem from a linux based PC..

It seems that /INIT uses the same Process ID - 1 (found from using watchtower)
3rd November 2010, 08:55 PM |#7  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
Originally Posted by BigMango

You purchased it from ebay, but did you buy it from a shop or from an individual (second hand)?

If you got it from an ebay shop they should give you a receipt. If it was from an individual, he should give you his original receipt (that's when the warranty started).

Anyway, the phone has a 2 years warranty, so you are covered for the next 2 years minus 1 or 2 weeks. And the paypal transaction is a valid payment receipt (it can be verified directly with paypal); so even without the receipt from the first owner HTC should cover you since the phone can't be 2 years old.

Get in touch with HTC directly, they should replace it. But the tricky part is that the problem must happen when they check it out, for this reason I would also make a video of the problem the next time it happens and send it to them by email so they can keep it on file with your RMA.

Thanks for the advice, Im going to contact the seller, he had it on upgrade and shipped it to me the following day..he seemed a nice guy so It should be ok...Now its just a matter of waiting for MR INIT to show up haha....wonder if he wears a hoodie LOL
3rd November 2010, 10:42 PM |#8  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
Originally Posted by bimmerfox

I'm not wrong because I see it with my own eyes. Even my DHD had the same problems as described. After the update no more /INIT at 90% and it keeps running smooth now.
Try to keep your patience before quoting a person who is willing to help others.

What?? Why do you think I made this help myself and we do at XDA....the update doesn't fix the problem....just because yours hasn't lagged since the update doesn't mean its fixed....I've gone 5 days with no lag and it came yours probably will.

EDIT- You can't post a statement that the problem as been fixed when numerous people have done the update and still experienced the /INIT can it be fixed??...and since the update only came out yesterday you have no way of knowing this for sure... its way to early to say that.. Try reading through posts in the forum and gather some information next time.... the update was for the youtube fix, we're not even sure that HTC were aware of the problem at the time.
3rd November 2010, 10:59 PM |#9  
lynxboy's Avatar
Senior Member
Flag Leeds
Thanks Meter: 345
Hi guys,

Just finished work and have caught up with the thread since I last posted and wanted to clarify a few things. I would also ask any new readers to find my previous post which covers much of the nature of the /init process.

The problem is solely software based. The hardware is NOT at fault!

The /init process is the parent process of Android/Linux, hence the PID 1 in OS Monitor. Imagine it as the ignition system in your car. You need to turn the ignition to fire up the other systems and that technically is the role /init takes.

It is not a rogue process in itself. It cannot be killed or closed via a task manager.

The latest update was not a fix nor does it resolve the issue.

The bug IS a Froyo bug and affects numerous devices not just the DHD although it is not present in all Froyo ROMs.

It is possible the memory management is to blame however I have run many Froyo based ROMs from FRF55 and not experienced it before; they all use the same memory management.

The three triggers for /init to awaken after its boot tasks are completed are specified in my previous post. These are the most likely causes for our issue and are in my mind triggered by some rogue process interactions.

A logcat will only really be useful if it captures the event taking place. A logcat taken when the /init process has started will report back specifically that.

Just because you haven't experienced the bug in 2days doesn't mean you are bug free, nor is there a bad batch of phones as this would indicate a hardware issue.

Continuing this thought, it is possible if you are on a branded operator ROM you may be bug free.

The /init bug is extremely annoying.

21st November 2010, 12:46 PM |#10  
Rixsta's Avatar
OP Retired Forum Moderator
Thanks Meter: 3,297
Yes off topic...

Im asking the mod to still keep this a sticky but to lock the thread as there is really nothing left to discuss and its just here for people that are still having the /init problem as a reference...

EDIT - Thread being locked soon so....

Agian thanks to all xda community !!
13th January 2011, 02:38 PM |#11  
M_T_M's Avatar
SeƱor Moderator - I Regret Nothing!
Flag Texas
Thanks Meter: 9,810
Is this stickie needed anymore? Has this been corrected by any software update?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes