Remove All Ads from XDA
Honor View 10

[RLZ][v7.2.2] Patched Market (latest v.2.2.11 / Froyo & Gingerbread)

565 posts
Thanks Meter: 284
By Sympnotic, Senior Member on 7th November 2010, 02:57 PM
Post Reply Email Thread
*we love wine, not whine*

* Supported roms :
- Sense roms (Wildpuzzle / Leaf / SunaAbh / DK etc..)
- Aosp roms (OpenFire / GingerFire)
- CyanogenMod roms (CM 6.1.0 / CM 7 )
- Theoretically every 2.2 & 2.3 roms for Wildfire

/!\ Quick Info /!\
G-apps MDPI (tiny or not) REQUIRED on CM6.1 / CM 7
- Depending on countries (and possibly fingerprints) you might get different results !
- If you can't download, blame google and their servers !
- If you feel like doing a Nandroid backup, do it !


What it does :
- shows non-Qvga (up to 800*480=WVGA) apps in market (ex. Rom-Manager)
- show protected apps (ex. Paypal(?) / Dr. droid )
What it does NOT :
- doesn't show paid apps in countries which... don't show them, use Market Enabler for that.


Requirements :
- A custom rom (or at least a rooted phone with custom recovery)
- Cyanogen only : Pre-installed G-apps

Install instructions :
- Download
- Put in on your SD-card root
- Reboot under Recovery
- Flash as usual (select a zip from sdcard => naviguate to .zip => select "yes" and wait it's done)
- Reboot under your rom, tap on the market icon
- Accept ToS (if not, see the FAQ, Q°4) and enjoy


1 - An app not showing ? Check on if the requested app isn't missing from the market ! (ex : ScummVM)

2 - Can't download from the market ? The patching method I used is a known process and it's 99.9% impossible that it causes problems. If downloading apps fails, it's a google-sided problem.

3 - Don't know what it does ? Look at screenshots, XXX results for a "video" search Search for "video" to see the difference (or compare before and after patching) !

4 - After flashing the market, you still can't see more apps ? You'll need to go to "Settings", from there go to Applications -> Manage Applications -> All -> find the Market app ==> Purge its datas & caches : Accept ToS again.

5 - Can't reboot / bootloops right after flashing this patch ?!??! Well, I'm not going to open an Aftersales service, but first : You did something wrong !
=> This patch only do things related to Vending.apk (market app) & its cache, nothing more ! Therefore, having a PHONE issue (like not rebooting / needing to flash a previous nandroid backup) ISN'T MY RESPONSABILITY NOR THIS PATCH'S FAULT. This being stated, I still can point out some of those WRONG BEHAVIOR and what it does :
*removing Vending.apk from G-apps* => perfectly stupid !
*not installing G-apps before flashing* => YOU NEED THEM !
*flashing this patch to a stock rom* => I never tried, but if it works, it's kewl.

6 - New v2.2.x gives you FCs ? Use the to purge the market :
1- Put the file on your SDcard
2- Flash it under Clockwork Recovery
3- Reboot, let your rom boot (WITHOUT directly flashing a patched market)
4- once your rom booted, check market disapeared and can't be launched by any leftover shortcut.
5- Reboot under recovery and flash as normal

*another wierd problem not listed below?* => No, this isn't stupid to ask if you did everything GOOD, if no matter what you still have shits, just post a Logcat and/or the maximum infos about what's going wrong.


Changelog :
- V7.2.1 : Skoobly-Oobly-Doobob - normaly properly functional (we're better off not using gingerbread's G-apps Vending.apk)
- V7.1 :
- v2.2.11 / still the same / gingerbread's apk used
- RM Premium is normally back
- Forgot to purge caches in updater-script
- Nice / With uber-leet comment updater-script remake for Market&Permissions&Remover package.
- removed v5.2 / oldest "changelogs", if needed PM me, i'll post it back

- v7 : v2.2.11 / similar as before / Separated permissions fix (only needed on CM6.1) UpdateR-script back
- v6.1 : v2.2.7 / similar as before / Separated permissions fix (only needed on CM6.1) / Now stable / New Package :, see FAQ n°6
- v6 : v2.2.6 / shows apps up to 800*480 / Added some /etc/permissions missing in CyanogenMod releases.

*everyone's amazed by Gingerbread... GINGER? FFS!?*

CM6.1 & CM7 users need to flash an additional file :
CM6.1.0 / FROYO => (simple permissions fix)
CM7 / GINGERBREAD => You might need to fake your fingerprint to latest Nexus S fingerprint :
- Edit and flash your Build.prop according to this :
[/code] 2.3.1 GRH78 85442 release-keys
Only for CyanogenMod

Download links :
Attached Files
File Type: zip - [Click for QR Code] (160.5 KB, 3803 views)
File Type: zip - [Click for QR Code] (1.34 MB, 5004 views)
File Type: zip - [Click for QR Code] (164.2 KB, 3399 views)
File Type: zip - [Click for QR Code] (1.37 MB, 12997 views)
The Following 24 Users Say Thank You to Sympnotic For This Useful Post: [ View ] Gift Sympnotic Ad-Free
7th November 2010, 03:08 PM |#2  
makaaaa's Avatar
Flag Almelo
Thanks Meter: 2
Ok thnx..installing it right now!
Good post

Sent from my HTC Wildfire using XDA App
The Following User Says Thank You to makaaaa For This Useful Post: [ View ] Gift makaaaa Ad-Free
7th November 2010, 03:23 PM |#3  
Thanks for the new update installing now

Sent from CM6.1 RC2 on my HTC Wildfire using XDA App
7th November 2010, 03:25 PM |#4  
johnnyslt's Avatar
Inactive Recognized Developer
Flag Bucharest
Thanks Meter: 6,259
Donate to Me
nice work.

PS : do think you can attach the original market also? maybe some people what to return the original one without restoring from nandroid backup.

7th November 2010, 05:19 PM |#5  
Thanks Meter: 0
I got stuck in a bootloop after flashing.
Cyanogenmod RC2

E: Yep. Endless bootloop. Flashing CM over it wont help. Trying nandroid backup now.
7th November 2010, 05:32 PM |#6  
Thanks Meter: 2
Not working for me, I'm not getting as much results as you do in those screenshots.

Saw the BBQ!!! thing while flashing (and running CM RC1)
7th November 2010, 06:02 PM |#7  
Flag Књажевац
Thanks Meter: 0
Originally Posted by lasharor

Not working for me, I'm not getting as much results as you do in those screenshots.


I have only ~700 results for search term. „video“. Something is strange...
7th November 2010, 07:43 PM |#8  
Junior Member
Flag Novi Sad
Thanks Meter: 0
It won't show payed apps if your country doesn't support them. I'm pretty sure Serbia doesn't.
7th November 2010, 07:57 PM |#9  
Flag Књажевац
Thanks Meter: 0
OK, but when I fake my country with Market Enabler (set to T-Mobile USA) i have 1093 results for „video“, not 3000+ like we can see in the screenshot above
7th November 2010, 11:45 PM |#10  
Sympnotic's Avatar
OP Senior Member
Thanks Meter: 284
Did you have to accept ToS when you run market again ? You might need to fake your fingerprint, i'll post something about that.
The Following 2 Users Say Thank You to Sympnotic For This Useful Post: [ View ] Gift Sympnotic Ad-Free
8th November 2010, 04:54 AM |#11  
Senior Member
Thanks Meter: 4
Originally Posted by Sympnotic

- An app not showing ? don't whine... Check on if the requested app isn't missing from the market ! (ScummVM for ex.)

Be that as it may, the market in wildpuzzlerom eclair 2.1 still shows more apps than this patch applied to gapps-mdpi-20101020 when installed on CyanogenMod RC2? How's that possible? For instance I can't for the love of god find the app called "Appie". In the wildpuzzlerom market it's easy to find...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes