Remove All Ads from XDA

[DISCUSSION] Exchange 2010 Sync issues

48 posts
Thanks Meter: 5
By mccabeross, Member on 8th November 2010, 04:16 PM
Post Reply Email Thread
19th November 2010, 10:36 AM |#21  
thevinylpimp's Avatar
Junior Member
Flag Alkmaar
Thanks Meter: 0
Originally Posted by zappoo

You should mention to them that the HTC Desire HD had identical problems and HTC issued an over-the-air (OTA) update that fixed it - by changing the EAS policy back to version 12..

PLease keep us informed!!

Just updated the Incident (case) i have in their callsystem.. hope they use this information to spread the word internally.. perhaps it's possible to use the same fix as they used for the Desire HD.. poor support so far :/

Ofcourse i'll keep u posted!
24th November 2010, 01:30 PM |#22  
thevinylpimp's Avatar
Junior Member
Flag Alkmaar
Thanks Meter: 0
Thumbs down Update
I still don't have the feeling really that HTC Support Benelux takes my complaint very seriously..

Very B.A.D. Support
24th November 2010, 11:31 PM |#23  
Senior Member
Flag Sydney
Thanks Meter: 36
Keep pushing them. They released a fix for the Desire HD.. so they obviously know it's a problem. Crazy they haven't issued the same fix for the Z.
25th November 2010, 12:08 AM |#24  
Junior Member
Thanks Meter: 1
I spoke to HTC Support Norway yesterday, and they were aware of the sync-problems with exchange 2010. They told me that they had an ongoing dialog with Microsoft on how to solve these issues..

Didn't they just fix the very same problem on the DHD??
25th November 2010, 11:02 PM |#25  
marka2k's Avatar
Senior Member
Thanks Meter: 7
Thank you for this solution just got my Desire Z and had this issue drove me crazy until I came across this thread and your solution.

Originally Posted by zappoo

So i have a work-around after reading the above and other forums.

i turned off "Exchange" sync in my phone for email – left it on for calendar as i like the HTC calendar widget.

Then installed this stock email APK

Then set it up to sync JUST email..

Then changed the "Mail" (HTC) icon on my home sceren to the "Email" (Stock android) icon.

Now all works well.

The HTC mail app is a BIT nicer – but not by much. The stock app is pretty good too.

So until HTC release an OTA update for this problem (like they have for HTC Desire HD), the above is a reasonably good work-around.

Wonder if we should contact HTC to tell them? Or will they issue an update soon enough?

When using the HTC app, the EAS version reported by webmail is 14.
When using the stock android app, the EAS version is 12.

26th November 2010, 06:04 AM |#26  
Senior Member
Flag Sydney
Thanks Meter: 36
marka2k - no problem happy to help. I found this solution elsewhere so can't take credit
4th December 2010, 06:02 PM |#27  
Junior Member
Thanks Meter: 0
Originally Posted by thevinylpimp

We have the same issue here at my work.

We ordered 45 HTC Desire Z phones, and me and my colleagues are one of the lucky ones to get a new business phone

We have a Microsoft Exchange 2010 Mailserver with ActiveSync OWA email services enabled. We make use of the Activesync EAS Policy (EAS14?) that enables Remote Wipe, requires user to set a system pin (simple pin) and uses phone encryption.

Now on all other HTC phones (HD2, Desire standard, Touch Pro 2) we have no problems using this phone and exchange 2010 with policy combination.

The HTC Desire Z has some other Email client that cannot handle this Policy..

Tuesday i contacted HTC Benelux (NL) but the problem was not yet known there.. i believe the combination of the Desire Z with Exchange 2010 and a EAS policy is quite unique, so worldwide there are not a lot of users that have problems i think..

HTC is still investigating on my Incident, and they are now using a test account on my Exchange OWA. I really hope they bring out a fix soon.. i'm not about to change my Policy settings, and licensing 45 phones with Nitrodesk Touchdown is not really part of the plan..

Same configuration here - the OWA account/phone details shows that the security policy is not applied to the phone; this is confirmed by the fact that when setting up activesync on the "Z", there's no prompt to change the security code (if the policy is in force). I also noticed that the "Z" runs version 14 of the ActiveSync client - the Desire (non-"Z") runs 12.1, and runs perfectly.

On my "Z", I can receive emails and contacts during the first sync but not the calendar. Subsequent syncs always fail on contacts and calendar.

Roadsync and Touchdown do run well on the "Z" and do not face the issue; this tends to confirm that the issue lies within the HTC Activesync 14 client.

Not sure it will help finding a workaround, I guess it's now HTC's call to fix it - ASAP please .

10th December 2010, 11:01 AM |#28  
Junior Member
Thanks Meter: 0
I submited a ticket with HTC Support Russia on 19th of november regarding this.
They have since requested a test account and iis logs from me. All was provided.
On 30th on November ticket was escalated to TW department for deeper investigation. Still no solution.
Today I found this thread and updated the ticket with Desire HD fix info.
Let's see what happenes next.
10th December 2010, 07:27 PM |#29  
Senior Member
Flag Montreal
Thanks Meter: 107
Same problem here with an ES 2010. I am using the Email.apk workaround which is manageable as it's free, but I'm missing the email widget from the stock HTC Mail application
12th December 2010, 03:19 PM |#30  
pitt72's Avatar
Thanks Meter: 8
Thumbs up Solution for your own Exchange 2010
Hi Folks

if you manage your own Exchange 2010, than there is a workaround for this issue. I found it on other Forum. Worked like a charm for me.

- Install URL Rewrite Module 2.0 on your IIS and create some rules:

Hey. So after you have the module installed, open the IIS manager on your Exchange CAS, navigate to the Microsoft-Server-ActiveSync directory, and open URL Rewrite. You'll be creating one Outbound rule for each header. If I don't specify a value for a certain field, then leave it at the default setting.

Note: Before adding the rules, I suggest removing the EAS account from your phone and then deleting the htcglacier entry from the Phone area of your OWA 2010 account.

1. Add Rule(s)...
2. Outbound rules -> Blank rule
3. Name: MS-Server-ActiveSync
4. Match > Matching scope: Server Variable
5. Match > Variable name: RESPONSE_MS_Server_ActiveSync
6. Match > Variable value: Matches the Pattern
7. Using: Wildcards
8. Pattern: *
9. Conditions > Add...
10. Add Condition dialog > Condition input: {HTTP_USER_AGENT}
11. Add Condition dialog > Check if input string: Matches the Pattern
12. Add Condition dialog > Pattern: Android-EAS/0.1
13. Add Condition dialog > OK
14. Action > Action type: Rewrite
15. Action > Action Properties > Value: 12.1
16. Apply (the rule becomes active immediately)

Then redo those steps with these substitutions.
3. Name: MS-ASProtocolVersions
5. Match > Variable name: RESPONSE_MS_ASProtocolVersions
15. Action > Action Properties > Value: 2.0,2.1,2.5,12.0,12.1

The User-agent condition should prevent other EAS 14.x capable devices (Windows Mobile, iPhone) from downgrading to 12.1. If you need even more granular filtering, you could probably also add a condition that checks the request URL for htcglacier. I didn't need that, so I didn't bother. As the rule is configured above, it will apply to any Android device that uses either the native or the HTC Mail program.

If you check your web.config, this is the XML that should be generated from those two rules.

I noticed that this also fixes two other issues that weren't mentioned. Before doing this, the EAS policy was not being applied and you could not switch between HTML and Plain text formatting for messages viewed on the phone.

I hope this can help some of you who are fighting with this problem.
As far as I can see, these rules don’t affect the other functionalities from the IIS. My IPhone is still listed as a 14.0 EAS Device.

The Following User Says Thank You to pitt72 For This Useful Post: [ View ] Gift pitt72 Ad-Free
12th December 2010, 03:52 PM |#31  
Flag Turku
Thanks Meter: 4
interesting, didn't even notice this (well used desire Z for less than a week now). The default e-mail client used to work with the normal desire with our organizations Exchange 2010 SP1, but doesn't seem to work eith the Desire Z. I could try that fix posted above tomorrow and report back.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes