FORUMS
Remove All Ads from XDA

[Q] Alcatel OT-980 root and rom development

107 posts
Thanks Meter: 2
 
By Gibla, Senior Member on 13th November 2010, 10:05 AM
Post Reply Email Thread
19th December 2010, 12:17 AM |#31  
Junior Member
Thanks Meter: 0
 
More
me too
Hi, I'm french, and I've got one Alcatel OT 980.
Azerty en FR with android 2.1(update1).
Factory reset is working with power and volume down pressed at the boot time.
But my IDE (Eclipse under 7) don't recognize the phone when usb plugged. Dev mode doesn't work for me
 
 
23rd December 2010, 12:32 AM |#32  
Junior Member
Thanks Meter: 0
 
More
root out of box OT-980A
hello all i just got a ot980a that appears to not need root. it has su permissions out of the box but is missing NAT for Wireless tethering. i am looking for way to enable NAT. i would also be glad to share this image with anyone who can tell me how to make the file/files they need. i have root one eris from pc that is limit of my experience so far. open to all comments.

phone info

model #
Alcotel ot-980a
firmwarever
2.1-update1
kernel ver
2.6.29-perf
[email protected]#1
build #
ere27.v26g-0
14th January 2011, 09:19 PM |#33  
Senior Member
Thanks Meter: 11
 
More
Just bought an OT-981a. Nice phone, but needs 2.2 or 2.3. How do we get this rolling?
The Following User Says Thank You to nabicat For This Useful Post: [ View ] Gift nabicat Ad-Free
14th January 2011, 10:10 PM |#34  
Senior Member
Thanks Meter: 11
 
More
Quote:
Originally Posted by GrandMstrBud

How were you able to get root on this? I have an 980A with 2.1 update 1 on it and would like to have root access for the wireless tether app. I don't expect to get much ROM support for it but it would be nice though.


Androot worked on my ot-981a. Should be the same for the 980.
The 981a is missing netfilter in the kernel, so the normal wifi tether app won't work.
The Following User Says Thank You to nabicat For This Useful Post: [ View ] Gift nabicat Ad-Free
20th January 2011, 11:05 AM |#35  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Gibla

Hello,

just bougth a low-cost and really little android phone: Alcatel OT-980. It's quite cheap as long I bought for 79 gpb from new. And it has quite nice specs:

-CPU 600mhz
-256 Rom / 192 Ram
-Android 2.1
-Slide-out QWERTY keyboard

Anyone is working on it? Is it possibile to have root access? What about a new page on XDA for it?

Let's start talking about it guys

That’s really great to hear, I too agree that Alcatel phone is really good. It is one of the best phones available in the market today. The best part about it is that it is very cheap when compared to other phones, but still it offer all the latest features. Thanks for sharing.
21st January 2011, 12:11 AM |#36  
Senior Member
Thanks Meter: 11
 
More
Not ROM development, but did anyone else's phone come missing the 2.1 voice to text keyboard? I was a bit annoyed, but finally got it installed. Also took out a few of the preloaded apps as I won't need them.

Has anyone got a method for installing app2sd support on the factory ROM? I've run out of space already.
21st January 2011, 02:48 PM |#37  
Junior Member
Thanks Meter: 0
 
More
I've got the boot, recovery, and system images using cat.

# cat /proc/mtd
dev: size erasesize name
mtd0: 00500000 00020000 "boot"
mtd1: 03200000 00020000 "cache"
mtd2: 00500000 00020000 "recovery"
mtd3: 00060000 00020000 "splash"
mtd4: 04880000 00020000 "system"
mtd5: 08200000 00020000 "custpack"
mtd6: 0b0c0000 00020000 "userdata"
mtd7: 00080000 00020000 "studypara"
# cat /dev/mtd/mtd2 > /sdcard/recovery.img

I built a bootable, but non-working, clockwork recovery image by following Koush's guide. You can boot into it, but keypresses doesn't work. The menu selection just scrolls wildly to the accelerometer. I suspect this is due to the really barebones recovery image we have, which doesn't allow any user input and just reset the phone to factory defaults.

Would someone who is familiar with clockwork recovery give some pointers or be willing to give this a try? I've tried looking at the HTC samples and copying over my device's keychars and keylayout files to the recovery image, but haven't had any success. Information on how to fix the button input and how to enable USB would be very much appreciated!
25th January 2011, 02:04 PM |#38  
Junior Member
Thanks Meter: 0
 
More
Were you able to make any further progress? I know it's been only a few days, but thought I'd ask.
25th January 2011, 09:06 PM |#39  
Senior Member
Flag Toronto
Thanks Meter: 517
 
More
I'd assume that on a phone with so many keys and buttons, it should be somehow possible to program the recovery image to use them. But I'm no programmer!
26th January 2011, 04:46 AM |#40  
Mistix's Avatar
Junior Member
Flag Edmonton
Thanks Meter: 0
 
More
Thumbs up Thanks nabicat
Quote:
Originally Posted by nabicat

Androot worked on my ot-981a. Should be the same for the 980.
The 981a is missing netfilter in the kernel, so the normal wifi tether app won't work.

Thanks for the help, I installed Androot and although the "Soft Root" (temp root) did not work the "Hard Root" (pertinent root) did work.

Anyone who wants to know I rooted with 2.1 update-1 using Androot 1.6.2 beta 5. I checked and my device was NOT rooted before I used Androot and is now rooted.


I just got my Alcatel OT-981A with WIND Canada today. The phone works good WIND's network sucks as I get dropped of HOME 3G/3.5G downtown Edmonton but cant argue with the price. I am looking foreword to ROM development for this phone however I understand this may never happen.

Also on a non-root note: I am looking for an App that will auto scan/connect to WIND/any 3G+ tower after loosing connection. (My phone gets lazy with finding the best towers even with factory settings.)
29th January 2011, 08:59 AM |#41  
XBrav's Avatar
Senior Member
Flag Calgary
Thanks Meter: 21
 
More
Well I'm trying to learn as much as I can about this phone. I'm coming from a Dream, doing WIND in Calgary now.

So rooting went perfectly fine. As noted above, Universal Androot works fine. I also put on Root Explorer, and SetCPU.

Surprisingly, the default clock is 600/122. I kept it at that, due to the incredible stability at that speed.

Here's where I get a bit baffled.

The battery life is outright terrible. We're talking 7 hours of average usage here. The battery stats report the system using 95% and up of the battery. I've never seen it this way before.

The only thing that is out of place on the list of apps is this com.android.qualcomm. I cannot find any info online for this app.

Now, here's where you will all love me.

Indeed, ALL of the fun stuff is nicely organized on the CUSTPACK partition. Luckily, with Root Explorer, I was able to zip it for ya. I'll have it in an open Dropbox later.

I have the full keypad files, kl and everything, if that helps.

I also found the bootanimation.zip residing in /custpack/JRD_custres/media, if you want to dump your WIND animation

I'll find out more this weekend for you all. I'm by no means a dev, but I am finding a lot of cool items in here. FYI, removing Google Maps made my phone run longer. I really want to dig into this com.android.qualcomm though...

*EDIT*

Here are the links I promised!

http://dl.dropbox.com/u/11358311/custpack.zip
http://dl.dropbox.com/u/11358311/keypad.zip
The Following User Says Thank You to XBrav For This Useful Post: [ View ] Gift XBrav Ad-Free
Post Reply Subscribe to Thread

Tags
alcatel ot-980, alcatel ot-981, clockworkmod, recovery, root access

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes