Remove All Ads from XDA

Getting Started [Update 12/23 - OTA Update Install fix for root]

4 posts
Thanks Meter: 0
By bigdinosaur, Junior Member on 16th November 2010, 08:21 PM
Post Reply Email Thread
[Update 12/23] For those of you unable to install the new system update, I've found a solution -- scroll down to the update! I AM NOT RESPONSIBLE FOR ANY DAMAGES THAT MAY OCCUR!

So I figured I'd at least get things started - Credit goes to whomever first tried z4root on their Droid Pro - and to mahst687 for the deodexing.

Lets Begin!

Motorola ADB Driver
Android SDK
xUltimate V2.2.2
(Can't post links apparently, sorry -- googles your friend!)

#1 Root:
As seen on numerous android sites already, root is obtainable via z4root in the market. It may not work the first, second, or even third time -- just keep trying, it works I promise.

#2 Bootstrap and Clockwork Recovery
Download and install 'Rom Manager' from the Market. Once installed flash the Droid2 Clockwork Recovery. After flashing, obtain the Droid2 Bootstrapper and install it. Confirm Clockwork Recovery works by booting to recovery via Bootstrap.

#2 Deodex:
Download Android SDK for ADB, as well as the Motorola ADB Drivers posted above. Second, download xUltimate - also posted above. Once everything is downloaded and installed we're ready to begin.
1. Run Main in the xUltimate package - if the ADB drivers installed successfully you should be greeted with a menu containing several options - great!
2. Next run option 1.
3. Run option 2.
3. Run option 3 - sit back and relax for a bit
4. Once option 3 is done doing its thing, navigate to the xUltimate folder, more specifically the "origi_frame", and delete guava.odex
5. Run option 4 - it'll be a short wait
6. Exit the xUltimate
7. Enable USB Mass Storage on the phone and transfer both "done_app", and "done_frame" to the ROOT of the SD card.
8. Once both folders have transferred disable USB Storage, but keep the phone plugged in via USB.
9. Open up a command prompt and browse to the android SDK Tools folder (or where ever your ADB executable is located).
10. Enter the following commands:
adb shell
mount -o rw,remount -t ext3 /dev/block/mmcblk1p21 /system
cp /sdcard/done_app/* /system/app/
cp /sdcard/done_frame/* /system/framework/
rm /system/app/*.odex
rm /system/framework/*.odex
mount -o ro,remount -t ext3 /dev/block/mmcblk1p21 /system
11. If all went well your phone should reboot - which may take a few minutes. Enjoy!

For those of you unable to get the new Droid Pro OTA working I have found a solution! You will need:
2)Clockwork Recovery
3)System.img from update
4)Current Nandroid backup of your phone
5)ADB drivers and ASDK

So lets begin.

1)Boot into Clockwork recovery and create a backup of your phone.
2)Once complete, mount the phone as USB storage and pull the system.img file from the nandroid backup folder, as well as the nandroid.md5 (KEEP THESE FILES SAFE!!!!!)
3)Obtain the system.img file from here (Compliments of whoopsiedaisy).
4)Replace the system.img file in the Nandroid backup folder on your PHONE.
5)ADB into your phone (preferably still in recovery) and do the following:
adb shell
# cd /sdcard/clockworkmod/backup/2010-xx-xx.xx.xx.xx
# rm nandroid.md5
# md5sum *img > nandroid.md5
6)If all goes will it should create a new MD5 checksum file utilizing the new system.img
7)Go to the 'backup and restore' menu in Clockwork, and select 'Advanced Restore'
8)Select the correct nandroid backup folder where the new system.img file is located, and then select 'Restore System'
9)Assuming all goes well, go to Settings, About and check your new system version!
18th November 2010, 10:08 AM |#2  
Thanks Meter: 4
Nice, can't wait to try this on my wifes phone after work.

Sent from my ADR6300 using XDA App
18th November 2010, 03:41 PM |#3  
jayhammy's Avatar
Senior Member
Flag Schenectady, NY
Thanks Meter: 18
Is the second step necessary if you just want root access so you can install Wireless tether, etc?
19th November 2010, 08:11 AM |#4  
Senior Member
Thanks Meter: 20
Originally Posted by jayhammy

Is the second step necessary if you just want root access so you can install Wireless tether, etc?

Not at all. Simply run z4 if all you require is root access (and a host of apps like Wireless Tether, DroCap, Titanium Backup ...)
20th November 2010, 07:34 AM |#5  
Senior Member
Thanks Meter: 1
Can you please post the quickoffice apk from the Dpro so I can put on an DX? Same would go for the software that allows me to Invite attendees to meetings using GAL. It be copasetic if you can.
26th November 2010, 10:20 PM |#6  
Senior Member
Flag Jacksonville, FL
Thanks Meter: 13
Thanks a ton! Freaking worked flawlessly on my Droid X.

30th November 2010, 07:27 PM |#7  
Thanks Meter: 0
Cool. Cant wait to try this on my wife's phone.
10th December 2010, 05:44 AM |#8  
Junior Member
Thanks Meter: 0
I downloaded everything you said and i started my deodex but when i select option 3 in main it tells me "error no odex file" have i done something wrong please advise
11th December 2010, 07:40 AM |#9  
lngwstx's Avatar
Junior Member
Flag Phoenix
Thanks Meter: 0
Question Is it really that simple?
I feel like I must be missing something. I just download an app from the market and reboot and I'm rooted?

Also, what is the deodex for? I want to root my phone to install the apps I want and I want wifi tether. Do I need it?

Also, I really want to understand what is going on under the hood, but I don't know where to start. Is there a 'for dummies' tutorial somewhere that I can go to to start understanding what all of this stuff is, so I can make informed decisions for myself about what I want instead of begging for help on internet forums? Thanks in advance for any suggestions.
11th December 2010, 03:55 PM |#10  
Senior Member
Thanks Meter: 0
Is there a way to unroot? I am not rooted but just curious.
11th December 2010, 04:03 PM |#11  
jayhammy's Avatar
Senior Member
Flag Schenectady, NY
Thanks Meter: 18
Originally Posted by rllong1

Is there a way to unroot? I am not rooted but just curious.

Yes, Z4Root app allows you to root, re-root, and UNroot.
The Following User Says Thank You to jayhammy For This Useful Post: [ View ] Gift jayhammy Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes