FORUMS
Remove All Ads from XDA

Getting smb to work?

2,148 posts
Thanks Meter: 19
 
By lbhocky19, Senior Member on 7th December 2010, 08:31 PM
Post Reply Email Thread
it didn't work for me on 2.1, figured 2.2 would fix it. nope.
it sees my homegroup and my computer but then it just says folder empty when i open it.
ive set many folders and files to be shared to "everyone" homegroup and directly to the device and it still never sees them.

im running windows 7
 
 
7th December 2010, 08:46 PM |#2  
Junior Member
Thanks Meter: 0
 
More
Try using es file explorer, that ussualy does the trick.
Does not work for the build in video and music app, but it's a workaround to get descent file sharing till Archos fixes the smb issue.
7th December 2010, 09:23 PM |#3  
Junior Member
Thanks Meter: 0
 
More
I used es explorer to navigate to an SMB via IP and since then it has shown up in the Archos file explorer (sometimes it requires a refresh).
7th December 2010, 09:45 PM |#4  
e4xda's Avatar
Member
Thanks Meter: 7
 
More
I had a ton of trouble getting my 101 to see shares on my Win7 machine. I have since moved all of my shared data to my Ubuntu machine and I'm able to see everything, every time through any app on the 101 (files, video, etc).

I've not found Win7 to share very nicely with anything that's not M$. Just my personal experience.
7th December 2010, 09:53 PM |#5  
Junior Member
Flag Chicago
Thanks Meter: 2
 
Donate to Me
More
I'm on firmware 2.0.54 / Android 2.2 Update 1 and what is working for me is:

Maintenance of existing SMB Information: Settings -> Wireless & Network -> Shared Folders Setting" This provides a list of known SMB entries and their security information (e.g. username and password).

Creating: While I know some people used the EStrong ES File Explorer, I have been using the "Files" application that came with the tablet to locate the SMB entry. Once I create it, I maintain it as I mention above.

As for the EStrong ES File Explorer, I've been using it for local files, but after reading the entries in this thread will look at using it for LAN, also.

Bert Moshier
8th December 2010, 12:23 AM |#6  
OP Senior Member
Thanks Meter: 19
 
More
es was at least able to connect. it still didnt see all my files though for some reason. and it couldnt play any. a basic avi file it would fail on and with mkvs it would say not supported file type
8th December 2010, 12:00 PM |#7  
Senior Member
Thanks Meter: 143
 
More
Tried the Menu and Refresh in Files?

Also mkv is working but you might have AC3 sound in there and that's not supported without an additional plugin.
8th December 2010, 08:20 PM |#8  
Cthugha's Avatar
Member
Thanks Meter: 2
 
More
I also have this problem. Can see and browse all (Windows) SMB shares using ES File Explorer. Archos Files app can't find any SMB servers...

ES File Explorer can't stream video from the shares :s Can the Files app do that? (I can't remember if that worked before Froyo...)

Using Windows 7 and Windows Server 2008 R2. SMB streaming works perfectly to my HTPC (running XBMC) and my TViX box.
8th December 2010, 08:52 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Same form me.
With Androod 2.1:
SMB (from XP and Linux) worked with the standard explorer. Streaming works.
ES Explorer not tested.

With Android 2.2:
Shares on XP no longer listed in the standard explorer.
Shares from a Linux based device (Dreambox) are still listed. Streaming works.
Using ES Explorer, XP shares can be accessed, but streaming does not work with ES Explorer.

Sent from ARCHOS 70 using Tapatalk.
8th December 2010, 09:25 PM |#10  
I seem to have read somewhere that sharing drive root doesn't work. That's the way I traditionally share my internal files.

I set up a few sub directory shares \Video, \Photos, etc, refreshed and after authenticating, can see and stream using built in files app. couldn't before with this machine.

using XP Pro as server. works in video program, too.

A101IT-V6 - 2.2.1 - gApps, z4

AH HA!!!!

the video program is one of those that goes in and resets max CPU to 800 when running setcpu...

!!
8th December 2010, 10:20 PM |#11  
Junior Member
Thanks Meter: 0
 
More
So frustrating, largely because this was a key feature that attracted me to the Archos, and because it worked SO WELL before the "update."

I can browse the shared folders of my Windows Home Server or Win7 desktop just fine with ES, and in the Archos File explorer I can see the machine names in the workgroup, but clicking the machine name gives me "folder is empty" every time. even after browsing the shares with ES, the Settings -> Wireless & Networks -> Shared Folder Settings is blank - I've never seen a profile there.

Anybody have any suggestions?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes