Remove All Ads from XDA

myTouch 3G will not connect to pc other than for charging

7 posts
Thanks Meter: 0
By kylesuo, Junior Member on 19th December 2010, 06:55 AM
Post Reply Email Thread
I bought a used MyTouch 3G with the 3.5mm jack. Everything seems to work, except for connecting to either of my windows 7 pc's. I have the oem usb cable that came with the phone. When I plug it in, Windows says the usb device is not recognized and is malfunctioning. I attempted to install the drivers that come with pdanet to no avail. I also installed htc sync. When I plug the phone into my computer, it starts charging, but the taskbar message on the phone does not show it as connected to a pc.

Any ideas here?
19th December 2010, 08:14 AM |#2  
Senior Member
Thanks Meter: 68
try another usb cord?

23rd December 2010, 12:01 PM |#3  
Junior Member
Thanks Meter: 3
Try to install the USB drivers that come with the Android SDK?

(I don't think you need the HTC sync stuff for that).

Depending on what ROM you are running, or if it was made by some paranoid network provider, you might not be able to use the phone as a modem (tethering)... I've heard that some network providers disable the tethering feature...

With CM ROM, I've had no problems tethering over USB in: Windows Vista, Windows 7, Ubuntu 10.4 (Windows XP didn't work at all).

You have to enable the tethering feature first on the phone before it will work (I'm not talking about installing some app from the market, I'm talking about the built-in setting: settings-->wireless&networks-->tethering).

Have you tried mounting your SD card to access it as storage device over USB?

If neither tethering or USB mount wants to pick up when you plug the cable in, I'm guessing your cable is bust or your phone...

Have you tried the same cable on another PC?

Are you using some dodgy USB add-in card or USB hub on your PC? Did Windows 7 install the correct drivers for your USB controller on your motherboard? (do any other USB devices work on your PC?)
22nd July 2011, 11:50 AM |#4  
sxristi's Avatar
Junior Member
Flag Athens
Thanks Meter: 0
same problem HTC my touch 3g
I have a google tmobile htc my touch 3g 32B 2.2.1 android and under vista i have a load of usb problems device not recognized. have tried many many things still nothing works. called htc they told me to call ms. perhaps some conflict with the device. problem rooting it with sapping and gold card method and sapping as well. any suggestions?
22nd July 2011, 03:48 PM |#5  
Senior Member
Flag Copenhagen
Thanks Meter: 630
Donate to Me
Maybe you have a corrupted misc partition :0|
30th January 2013, 06:32 PM |#6  
Junior Member
Thanks Meter: 0
Thumbs up
just restart your phone... it will surely work
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes