Remove All Ads from XDA
Honor 9 Lite

[MOD] Nexus S Gingerbread on Steam (with working keyboard)

1,061 posts
Thanks Meter: 878
Post Reply Email Thread
Just to demonstrate the power of Steam, I hereby provide you a Steam Powered Gingerbread

This is based on SC's idea of using /data to store the gingerbread files, which works even if FSR is not loaded.

I also went forward and fixed the keyboard issue, so now the home, back and menu buttons work as expected! Oh, and also added recovery mode (running steam recovery of course ), that can be opened using the ususal three button combo. ("adb reboot recovery" or similar will not work however)

What still doesn't work:
- Wifi
- Modem (3g and phone)
- Camera
- Gps

1. Download the system dump from here, and put the file on the root of your internal SD card
2. If not already on ext2 or ext4, convert your /data partition to ext4. (because the next step requires Steam Recovery, I'd go with Steam kernel, if your current one doesn't support ext on /data)
3. Download the afterburner install files from here
4. Create a steam directory on your internal sdcard, and put the previously downloaded file there. If there are other afterburner*.zip files there, delete them.
5. Enter Steam Recovery (there are multiple ooptions on how you can get it), choose afterburner, select both options, then press "Install". This will take a while. You might want to switch to log window 1, where you can see the /system extraction progress
6. After finished, reboot. Gingerbread will boot up.
7. If asked to install Steam kernel you can do so, but first read note.
8. Enjoy. To switch back, flash any kernel. If you want your old data back, flash a kernel with ext4 support.
9. If you switched back to a "normal" kernel, you can use afterburner to get back to gingerbread too. Only select the second option when running afterburner, and on the next reboot, gingerbread will greet you in a state as you've never left it.

Note: A steam kernel installation requires you to reboot into recovery after installing it. On base Galaxy S ROMs this is done automatically, but gingerbread's kernel lacks the commands needed to programmatically reboot into recovery. Therefore it will always reboot into normal android mode, where he finds out that he needs to reboot into recovery, but boots into normal mode, etc... to exit this loop simply reboot into recovery manually (using the three button combo), to finish installation of Steam Kernel. You will be greeted with the afterburner window, press back without selecting any of the options (they won't work anyway), and you're done.

Alternate install: Of course you don't need afterburner to install this. Simply follow the instructions on supercurio's page, but use the kernel found inside, instead of the one provided on the mentioned thread. /data needs to be converted to ext4 though.

Steam Kernel: (all directories starting with android_bootable_steam_ / tag
Fixed kernel:

You can compile it by yourselves using the Android Compiler VM 2.0 with the compiler scripts found here
The Following 29 Users Say Thank You to sztupy For This Useful Post: [ View ] Gift sztupy Ad-Free
22nd December 2010, 07:37 AM |#2  
DemonWav's Avatar
Senior Member
Flag Lawton, OK
Thanks Meter: 775
Donate to Me
Not exactly following you on how to install the Steam Kernel. Do I need to pull the battery at some point? If so, when? If not, what am I supposed to to do manually get it into recovery mode? No matter what I do I am always greeted with "Steam doesn't seem to be installed, or it was recently uninstalled." etc.
The Following User Says Thank You to DemonWav For This Useful Post: [ View ] Gift DemonWav Ad-Free
22nd December 2010, 07:37 AM |#3  
Retired Recognized Developer
Thanks Meter: 2,881
Nice work, you lift up the level of this forum

Some x-mas beer for you :16T35690B39571910
22nd December 2010, 08:05 AM |#4  
Senior Member
happy place
Thanks Meter: 272
This is awesome!

Happy x-mas
22nd December 2010, 08:27 AM |#5  
Senior Member
Thanks Meter: 22
Great job, will play with it ...
22nd December 2010, 08:47 AM |#6  
Senior Member
Thanks Meter: 20
Thx a lot for your work ! -> 1VL15892XA210614G
22nd December 2010, 09:13 AM |#7  
Senior Member
Thanks Meter: 12
you are awesome. just awesome.

i have a vibrant. But i lurk here to keep an eye on development.
22nd December 2010, 09:27 AM |#8  
Thanks Meter: 2
Great very interesting indeed. May I know wats working and wats not? Thx and gd work!

Sent from my GT-I9000 using XDA App
22nd December 2010, 09:57 AM |#9  
nesquix's Avatar
Senior Member
Flag Cannes
Thanks Meter: 64
Amazing. i will pay you the 2011 Sziget if that works. lol
22nd December 2010, 10:18 AM |#10  
Senior Member
Flag Paris
Thanks Meter: 43
Hmmmm nothing happens when I choose "Install" in afterburner menu.. It seems to be instant. Just like it didn't found the install file.
I named the folder "steam" at the root and put the into it though..

Edit: Okay I'm f***** stupid, didn't check the two options. It works now.. really sorry

Edit2: It seems like I'm stuck in steam recovery. Everytime I reboot I get this message : "Partition /res/.fake/gingerbread/cache could not be mounted!"
The "format partition to ext4" function doesn't seem to work as well. Same for the proposition of installing Steam kernel..
I had my /data partition formatted in ext4 via voodoo though.

So basically, whatever choice I make, it'll never boot... Do I have any other solution than a flash with odin to get something working ?
22nd December 2010, 10:19 AM |#11  
Junior Member
Thanks Meter: 1
huge work, and it works !
well done
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes