Remove All Ads from XDA

[Dec 27] Ubuntu for HTC HD2 - v0.3 released

707 posts
Thanks Meter: 259
By dcordes, Retired Senior Recognized Developer on 27th December 2010, 02:13 PM
Post Reply Email Thread
28th December 2010, 09:35 PM |#121  
Senior Member
Thanks Meter: 25
Originally Posted by Troji

exactly the same here I even used a usb hub with no luck ... i see that this 0.3 is not official and only a modification to its user interface lets call it 0.2.1

did you change the startup.txt to use the usbhost instead of adb?


# USBETH allows for conventional usb ethernet connectivity
# ADB will provide android debug bridge conectivity
# USBHOST will allow connection of peripheral usb devices
# when supplying +5V externally.

set kernel zImage_htcleo_adb_2.6.32.9-38182-g6ad7e77
# set kernel zImage_htcleo_usbhost_2.6.32.9-38182-g6ad7e77
# set kernel zImage_htcleo_usbeth_2.6.32.9-38182-g6ad7e77

put a # before the first "set kernel" and remove it from the middle.

there are major changes if you look in the left top corner beside the clock.
the mouse is indeed a bit buggy, on the first try's it did work but now moving your finger left-right moves the mouse up-down.
finger up-down results in the pointer going left-right.
can somebody validate this as this happend after i disabled the automatic login from gdm, in the hope to reach a command prompt.
as ctrl-alt-f2 doesn't push gnome away to show the command prompt.
doing a reinstall right now to see if the mouse works again.

28th December 2010, 09:39 PM |#122  
Senior Member
Thanks Meter: 25
Originally Posted by dragos193

sorry for my noobish question .. but , if i have an android build on my phone can i run this ubuntu ? they don't have any conflict ?

it runs from the sd card without touching your phone's internal flash mem, so no it shouldn't cause any problems.
you just need a different method of booting.
can't remember how but it's mentioned in this thread on the first couple pages.

28th December 2010, 09:44 PM |#123  
Flag saint-brieuc
Thanks Meter: 11
Originally Posted by 0netwo

pardon my retardeness
but can u call with it?

call is possible but no sound. it can receive sms maybe send too.
28th December 2010, 09:51 PM |#124  
Junior Member
Thanks Meter: 0
you need to download " VUZE" it's a torrent client its free. After you download it install it on your pc, I dont know to much about mac, go back online and download the hd2_ubunto, and the VUZE torrent will do the rest. Good luck, dont for get you nee to download the HSPL_3 install it on your phone first before installing the unbunto.
28th December 2010, 09:52 PM |#125  
dcordes's Avatar
OP Retired Senior Recognized Developer
Thanks Meter: 259
Donate to Me
Thanks a lot for the extensive feedback !
Although the preparation for this release was long - it wasn't the first approach to finish 0.3 and I tested many things in the process - it shows that I did the final thing in a hurry.
Let's regard this as a beta test for 0.4 . It will be best to just answer to some posts:

Originally Posted by shree.cse

Everything except Sound in voice calls. But we can wait for a fix from the next Ubuntu related kernel.
Thank you Dcorders!

Originally Posted by pkchips

Wow this is absolutely awesome!

Dcordes, any idea if we might ever get in-call audio support? I might actually start using ubuntu on my phone full time!

It is definetly possible but exceeds my personal capabilities. Non working audio in any non-android builds is due to the fact that the way sound works in android is different vs conventional Linux. This applies to following functions:
-battery status (might get fixed)
-backlight (my friend GNUtoo fixed it, see kernel changelog)
-power saving functions like sleep (might get fixed)
-accelerated graphics (unlikely to ever get it working)

This is not limited to Ubuntu. If you try to get meego going you will face the same problems.
You might judge google for it - that way people have a hard time getting non-android on there phones. Economically it is not of interest for google when you guys have the freedom of choice...
It always seems android gives the user so many liberties but these things restrict the full spectrum of possibilites Linux has to offer.
That said, without android we wouldn't see so many cell phone hw platfroms with Linux support today!

Originally Posted by g30rg10u

dcordes please confirm if this is the file:

Originally Posted by cortk

For those people not getting the unity interface, I did this:
I clicked on my storage card on the desktop, then clicked the purple computer icon in the toolbar, then clicked file system, usr, share, applications, login items. Clicked unlock, entered "ubuntu" as password, changed the login environment to the netbook one (instead of blank), then clicked close.

Then rebooted:
Pressed the lock icon on topmost taskbar, switch user, clicked power button and shut down, rebooted.

Stupidly I assumed because netbook-launcher-efl (that's the name of the fancy background menu program) started 10/10 times in my local tests, I thought it would work for everybody else. I start it via gnome session startup with some seconds delay. Maybe with a faster SD card it is too early
You can always add the main menu in the panel:
Tap and hold (not so easy, make sure you have clean screan) on the top panel for few seconds and then relase. That simulates right click. You can now add main menu or menu bar in order to start applications. In system / startup programs you can edit the delay in order to fix.
Or you can work around it by changing the default session to ubuntu netbook 2d - also via system menu.
Originally Posted by TacoLoco

Pls somebody make a lil video.. Still waiting for my new display but want to see this in action

I would also welcome a video. Could add it in the first post.

Originally Posted by curiousGeorge

Performance is certainly better this time around. I think posting (part of) the readme on the first page would help a lot of confused users. It includes a changelog, password (ubuntu), a list of what works and what doesn't, etc -- just like the Android builds.

My impressions of 0.3 are in some respects better than 0.2, but for all of my use cases, it is one step forward, 2 (or 3) steps backward. But I do not mean ANY insult by this, honestly. It is obvious a lot of work has gone into the release, despite delays. The lack of sound and keypad (X issue? Did you open a ticket/report?) and proper stand-by are the biggest remaining administrative niggles. I'm impressed by the Unity interface, even though it occasionally fails to load properly. (It loaded the first time, but on every subsequent reboot it never loads.)

- I see the available memory is now 412.3MB. This is good.
- Applications (as well as boot) speeds are much improved.
- There is no openoffice. This is a big regression, since the "Zoho" nonsense is no better than Office Mobile, Android's QuickOffice, or anything else, but much worse due to compatibility trouble, functionality, and usability on the go. A big allure to "Ubuntu" is that it contains full desktop compatible software, not watered-down items tethered to an internet connection (read below: wifi does not work). Real Office (OpenOffice) was one if not THE major use case for Ubuntu on the device, since a system with no sound, no calls, etc is only truly useful for desktop use cases.
- Wifi does not work, and my home network is not even detected. I'm looking into this and seeing if there isn't something I can do to get it running. (edit: only eth0 interface is detected by wicd, there is no wlan anywhere). Is the firmware included?
- Battery status partially works (you need to click an icon to get the status and fill %), and charging still does not seem to work (tested by hooking the USB to the computer).

All in all, this release is not usable in its current form -- no unity launching, I had to create desktop launchers for system monitor, terminal, etc, and no wifi means no ability to download openoffice from software center, I cannot browse the web or view/work on documents, etc.

An impressive effort, and I can see this is a step forward. But again, it is with great pain (and hours of struggle with the system) that I must report that for me it is multiple steps backward as well. I also wish, in hindsight, that the development progress had been posted here so I could comment/test/help out wherever I could. I'm going to keep trying to enable wifi, which will allow me to debug Unity (or remove it and install a real netbook interface like KDE's).

Geroge, thanks for this thought out and extensive feed

I will add some info in first post.
I'm glad you noticed the performance improvement
It is a good idea to report the keypad problem in Xorg mailing list.
Standby requires minor driver patching. Nothing impossible.
I noticed the subsequent hanging on early boot as well. I am considering to switch to the other kernel repository (evo based). I am using htc-msm-2.6.32 because it was easier to add the gnu specirfic patches.
iirc canonical is unable to provide via the repositories in maverick due to arm related build time problem. Try adding a ppa package !
For me scanning for wifi networks works. Anybody else havging trouble?
It is expected to not see charging mode when using usb host kernel. Also note it charges much slower on pc..
Regarding debugging: Did you notice it has automatic usbnet and adb capabilities? please check readme regarding it.
Readme also has the link to the wiki page which documnents many things needed to reconstruct the images.

Originally Posted by matejdro

Mine shows me error "bad newroot" and then reboots. Any idea?

Make sure you have the linux folder in the root directory of your sd card. Else try formatting sd card.
Originally Posted by denyboy

mine everytime restarts the phone...weird

becoure every android build works

Strange that only ubuntu wont work. I know these are different worlds but sill...

see above
Originally Posted by jameschurchman

this is really really good!!! so thanks guys, far better than i could even imagine ubuntu would be on a phone!

bigest annoyance for me!! no screen rotation. it was in the last one. As the screen is not 768 px high, many windows you cant click the buttons, so i cant install anything from the syn package manager. does anybody know a fix? there was an icon to rotate the screen for 0.2!

the hardware buttons or right click, drag window etc.. no longer work as they did in 0.2

sound is no biggeie for me, tho (and i know if might not be possible there might not be linux drivers for the HD2) but i would love bluetooth, to allow a bluetooth keyboard. this would make the HD2 + ope office a real option!!

Thanks again guys, you have done an amazing job! (and any work around for the screen rotation, i tried changing the boot script to screenrotation=0 but that did nothing! )


I will definetly add the rotation again in 0.4 . I simply frogot it. Look into using command line to install prgorams for now. I might append the xorg.conf for rotation but we also need shortcuts and disable the touchscreen rotation script.

Originally Posted by en!gma

This is a good effort, but being unable to restore the overlay is a deal-breaker for me.
Also, the mouse orientation at the login screen (not the lock screen) is incorrect, which makes shutting down a hassle.

I need to check what went wrong with that. Thanks for reporting it !
Originally Posted by oxdamas

thanks a lot for the release
a bit disappointing gnome no sound
keyboard always in the way and not very responsive
anyway thanks a lot for the effort and privtlege

The keyboard was not designed for touchscreen devices. I added some bug reports to report it in ubuntu launchpad.
Originally Posted by Sinistersky

will this work for omnia i8000?

If it is a linux based device with enough performance we can look into it. It would be very nice to run this on the dell streak as well.

Originally Posted by HJ200

Hi everyone,

I've been running Ubuntu v0.2 on my HD2 a few months ago. I'm currently running Android as my main OS. Is it possible to boot Ubuntu from within Android?

It is easy to boot a new linux kernel from within linux. You just need the kexec kernel configuration option.
Originally Posted by laithnkirk

hey mate i don't know if it is in the read me or in somewhere else all i know that i went to the :
2:update package
when i want to install it i got the authorization message which wants me to type a password so what is the password it is not Ubuntu
and for god sake where is the @ !!!!!!!!!!!!!

sudo is authorized automatically (see readme) this might be some gnome keyring stuff which you can abort usually..
Originally Posted by Jaxbot

This just had to be released while I was on my vacation away from my HD2, didn't it? Can't wait to try it out..will probably release a video soon too.

Nice work dcordes!

Videos would be very nice.
Originally Posted by Luke3113

Just installed it and after restarting I got the menu...
Now I tried connecting a mouse with a (self-built) Y-cable.
The Y-cable worked perfectly ond the v0.2, but now it seems to have problems...

I connected everything (1 to the computer, 1 to the mouse, 1 to the hd2) like I did with v0.2, started the phone, started haret, but it just doesn't recognize my mouse... why? It recognize the power and runs on external power, but my mouse just doesn't work...
Am I doing it properly?

Thanks for your help...

Can you try the exact hardware setup with 0.2 ? Are you sure you are using the usb host kernel? Please double check your startup.txt !
It would be very nice to see some video or photos with 0.3 w/ usb setup

Thanks again for all the feedback this helps a lot to improve further versions!

The Following User Says Thank You to dcordes For This Useful Post: [ View ] Gift dcordes Ad-Free
28th December 2010, 10:24 PM |#126  
Junior Member
Thanks Meter: 0
Thumbs up Thank
Very Thank Dcordes is a God Very Very thank For your WORK
28th December 2010, 10:29 PM |#127  
Junior Member
Thanks Meter: 0
Lightbulb :)
If you want a server to store the HD2 I give to my own that I use
29th December 2010, 01:09 AM |#128  
Junior Member
Thanks Meter: 0
darkstone is da man
use (mirror darkstone ) to download.
The limewire bittorent is under court - blah blah, blah
29th December 2010, 01:17 AM |#129  
Senior Member
Thanks Meter: 139
@dcordes now that is proper answer post

EDIT: yeah the problem was that i renamed folder to Ubuntu instead of leaving linux.

Wifi is not working for me (no network detected), so this build is mostly useless to me since i don't have data plan. Anyway, great job. Everything is smooth and fast. Way faster than i would expect from desktop OS on mobile device.
29th December 2010, 01:23 AM |#130  
dïnnïra's Avatar
Senior Member
Thanks Meter: 10
It's my 1st time loading linux in HD2, seems to be working well only as what others said, sound is not working. Batt indicator remain red & can't seem to find the button '@'. Others I'm still not too familiar hehe.
29th December 2010, 01:53 AM |#131  
Thanks Meter: 1
Red face
can anyone tell me what is this rom??i like to try this one..but what is this acutely??...thanks..
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes