Remove All Ads from XDA

[HOW-TO] Work-arounds for issues with stock Nook Color ROM

434 posts
Thanks Meter: 107
By wvcachi, Senior Member on 27th December 2010, 10:58 PM
Post Reply Email Thread
30th December 2010, 10:11 PM |#31  
Musicman247's Avatar
Senior Member
Flag Texas
Thanks Meter: 8
Posted this in another thread, but figured I should post here too:

Can you add books to your Home screens from the Library if you install a different Home screen (like LauncherPro)?
31st December 2010, 12:48 AM |#32  
Senior Member
Thanks Meter: 26
It's not really necessary or really fully finished but I made a really simple Python Script to auto crop wallpapers that are 1280 by 1024.

Uses PIL:

I'm not sure how to go about other resolutions b/c it would require user input at some point as far as I know without forcing the crop box to start at a predefined location.

Yes I'm aware there are programs which would do this and such but I just like using Python to do stuff instead of another downloaded program
31st December 2010, 05:22 AM |#33  
tytdfn's Avatar
Senior Member
Flag New York
Thanks Meter: 11
Heres a workaround for the issue with adb devices returning ???????????? no permissions in linux : I found a couple of people that haven't been able to fix it but here it is:

sudo adb kill-server
sudo adb start-server

31st December 2010, 06:50 AM |#34  
Senior Member
Thanks Meter: 5
I don't know if this is covered, or even helpful, but, I noticed that busybox was installed during root yet, only ls was linked. This may not be the right place to post this information so, please just let me know if there is somewhere else I should post it. I am just trying to help.

For those who use adb shell, busybox -- a small executable combining several UNIX/Linux commands for embedded systems -- just needs you to symlink the tools to it in order for them to work without needing to type busybox in front of each one. For instance, if you try and copy a file -- the command is `cp` (without quotes) in Linux -- you may find that the cp command doesn't exist. You can run it with `busybox cp` but with long commands, you may find yourself typing busybox 15 times. To correct, just run the following from an "adb shell":

cd /system/xbin
ln -s busybox cp

You can follow that by any tool that is compiled into busybox. Here are the ones I linked to and the commands I used:

cd /system/xbin
ln -s busybox cp
ln -s busybox vi
ln -s busybox telnet
ln -s busybox telnetd
ln -s busybox grep
ln -s busybox killall
ln -s busybox find

There were more but, I think you understand how it works.

I just got my NookColor and am loving it. I haven't had much time to play around with it yet. I am going to get some tools installed this weekend to help me hack it easier. I will try and post things as I get them working.

Here are the commands that you can link:

[, [[, acpid, addgroup, adduser, adjtimex, arp, arping, ash, awk, basename, beep, blkid, bootchartd, brctl, bunzip2, bzcat, bzip2, cal, cat, catv, chat, chattr, chgrp, chmod, chown, chpasswd, chpst, chroot, chrt, chvt, cksum, clear, cmp, comm, cp, cpio, crond, crontab, cryptpw, cttyhack, cut, date, dc, dd, deallocvt, delgroup, deluser, depmod, devmem, df, dhcprelay, diff, dirname, dmesg, dnsd, dnsdomainname, dos2unix, du, dumpkmap, dumpleases, echo, ed, egrep, eject, env, envdir, envuidgid, ether-wake, expand, expr, fakeidentd, false, fbset, fbsplash, fdflush, fdformat, fdisk, fgconsole, fgrep, find, findfs, flock, fold, free, freeramdisk, fsck, fsck.minix, fsync, ftpd, ftpget, ftpput, fuser, getopt, getty, grep, gunzip, gzip, halt, hd, hdparm, head, hexdump, hostid, hostname, httpd, hush, hwclock, id, ifconfig, ifdown, ifenslave, ifplugd, ifup, inetd, init, insmod, install, ionice, ip, ipaddr, ipcalc, ipcrm, ipcs, iplink, iproute, iprule, iptunnel, kbd_mode, kill, killall, killall5, klogd, last, length, less, linux32, linux64, linuxrc, ln, loadfont, loadkmap, logger, login, logname, logread, losetup, lpd, lpq, lpr, ls, lsattr, lsmod, lspci, lsusb, lzcat, lzma, lzop, lzopcat, makedevs, makemime, man, md5sum, mdev, mesg, microcom, mkdir, mkdosfs, mke2fs, mkfifo, mkfs.ext2, mkfs.minix, mkfs.vfat, mknod, mkpasswd, mkswap, mktemp, modinfo, modprobe, more, mount, mountpoint, mt, mv, nameif, nc, netstat, nice, nmeter, nohup, nslookup, ntpd, od, openvt, passwd, patch, pgrep, pidof, ping, ping6, pipe_progress, pivot_root, pkill, popmaildir, poweroff, printenv, printf, ps, pscan, pwd, raidautorun, rdate, rdev, readahead, readlink, readprofile, realpath, reboot, reformime, renice, reset, resize, rev, rm, rmdir, rmmod, route, rpm, rpm2cpio, rtcwake, run-parts, runlevel, runsv, runsvdir, rx, script, scriptreplay, sed, sendmail, seq, setarch, setconsole, setfont, setkeycodes, setlogcons, setsid, setuidgid, sh, sha1sum, sha256sum, sha512sum, showkey, slattach, sleep, smemcap, softlimit, sort, split, start-stop-daemon, stat, strings, stty, su, sulogin, sum, sv, svlogd, swapoff, swapon, switch_root, sync, sysctl, syslogd, tac, tail, tar, tcpsvd, tee, telnet, telnetd, test, tftp, tftpd, time, timeout, top, touch, tr, traceroute, traceroute6, true, tty, ttysize, tunctl, udhcpc, udhcpd, udpsvd, umount, uname, unexpand, uniq, unix2dos, unlzma, unlzop, unxz, unzip, uptime, usleep, uudecode, uuencode, vconfig, vi, vlock, volname, wall, watch, watchdog, wc, wget, which, who, whoami, xargs, xz, xzcat, yes, zcat, zcip

UPDATE: I forgot to say that you can also run: busybox --install
It will add all of the symlinks automatically but, I have no idea the effect on the NookColor at this time so, I don't recommend it. Just select the commands you need. I will look to see if there is a way to put the commands in a specified directory using the install command and will update everyone.

UPDATE2: busybox --install doesn't work properly because it is expecting a /bin, /sbin, /usr/bin, etc... type system and the NookColor is /system/bin, /system/sbin, etc... I was going to play around with chroot and try the install to see if I would break anything but, I was worried that it would existing files and that would leave me only the toolbox version of the command. So, since /system/xbin is last in the path, I decided to write a while loop to add all of the symlinks to the /system/xbin directory. This is messy and I am sure there are simpler ways of doing this but, I am very tired, it works awesomely for me and my NookColor is running without any issues.

Here is what I did (USE AT YOUR OWN RISK):

mount -o remount,rw /dev/block/mmcblk0p5 /system
cd /system/xbin
ln -s busybox grep
ln -s busybox sed
busybox | grep "," | grep -v C | sed 's/,/\n/g' | while read name; do ln -s busybox $name; done
mount -o remount,ro /dev/block/mmcblk0p5 /system

Now, when I type a command like mv, it uses /system/bin/mv but, if I need to use busybox's mv, I can just use the command /system/xbin/mv. For instance, the default "ls" command doesn't have many sort options. The busybox one has several.
The Following User Says Thank You to LordDavon For This Useful Post: [ View ] Gift LordDavon Ad-Free
31st December 2010, 08:42 AM |#35  
Senior Member
Thanks Meter: 5
Now that I have all of the utilities that I needed (without needing to type busybox in front of all of them), I wanted to SSH into my NookColor. I like using Putty when I am working on a device since it provides me with a larger interface, allows the arrow keys to work, tab completion, works well with vi, I don't need the NookColor attached to my computer, etc.

I guess I need to research more and see if anyone else has already done this. If they have, I apologize. I am just trying to help, haven't researched as much as I should have, am loving this little thing and may be a bit over zealous with things. I just got it and am having lots of fun and am posting this because I want to help others who may be trying to do the same things I am.

I am not sure what everyone else has done but, here is what I did.

I downloaded from the following thread:

I extracted it into my Android SDK Tools folder. I then ran the following commands to make my /system folder writable:

adb shell
mount -o remount,rw /dev/block/mmcblk0p5 /system

I then ran the following to push the files over:

adb push dropbear /system/bin/dropbear
adb push dropbearkey /system/bin/dropbearkey

After that, I got back on the device and ran the following:

mkdir /system/etc/dropbear
chmod 755 /system/bin/dropbear
chmod 755 /system/bin/dropbearkey
dropbearkey -t rsa -f /system/etc/dropbear/dropbear_rsa_host_key
dropbearkey -t dss -f /system/etc/dropbear/dropbear_dss_host_key

To start the server, I ran following command:
dropbear -A -N root -U 0 -G 0 -C test

You can now connect via wifi to your NookColor as root. The "-C test" in the above command is the password used for login. I used "test" for the password to test.

The SSH server will not restart when you reboot the NookColor but, I will update this when I figure that out.

If you want to shutdown the SSH server, just run `killall dropbear` or reboot the NookColor.

Anyway, it is very late so, I will probably look at all of this tomorrow, shake my head and realize that I did things really poorly tonight. Again, I apologize if this has all been done before.

Here is where I found out most of this information:
The Following User Says Thank You to LordDavon For This Useful Post: [ View ] Gift LordDavon Ad-Free
31st December 2010, 03:46 PM |#36  
Flag Orlando, FL
Thanks Meter: 2
does anyone knows how to make the Wallpaper Set & Save to read anything BUT the SD Card?
31st December 2010, 08:14 PM |#37  
OP Senior Member
Thanks Meter: 107
Originally Posted by bassrebel

does anyone knows how to make the Wallpaper Set & Save to read anything BUT the SD Card?

It won't - you're going to need an sd to make it work.
31st December 2010, 08:37 PM |#38  
Thanks Meter: 10
Originally Posted by wvcachi

1. How do I keep wifi from turning off when the screen goes to sleep?

- download Spare Parts from the market and set wifi sleep policy to never.

If you are trying to stop the Nook Color from rebooting due to wifi issues, you can also do the steps from

Originally Posted by jadambpharm

Download Setting Profiles Lite from the market. Under the Profiles tab, create a new one and have everything unchecked and un-starred except WiFi (gold star), which means it will Turn OFF WiFi.

Under the Rules tab, create a new one with Conditions: Screen off and Actions: Activate (whatever you named that profile you just created). I don't think priority matters, but I put it on 'Highest'

This will turn WiFi off whenever the Nook's screen goes off - I think this worked for me since it does this independent of the Nook's handling of WiFi. Sure you're losing WiFi when the screen is off, but at least it wont continually reboot - which means WiFi would be off most of the time anyway and you'd get no email, etc notifications that way either

Thanks to RoboRay for pointing me towards Setting Profiles!

Originally Posted by wvcachi

8. How do I set my wallpaper so that the resolution looks good?

- I used a market app called Wallpaper Set & Save. It's easy, and resolution looks great. I think it cuts off the image a little bit, but not much. I think this method will suffice for many people, but if you want it to be sized perfectly, do the following (credit to swapdotavi for the instructions):

[Get an image that is at least 1200x1024, crop it (without scaling) to 1200x1024. If you're using Photoshop, copy the entire image, then create a new file sized 1200x1024. Then paste the image and use the arrow to drag it around to whatever looks best to you. Save the file as a .png, transfer to your nook, and use Wallpaper Set & Save to choose the new file.]

. . . Since we share the same resolution with the Galaxy Tab, the wallpapers that came with it look phenomenal (in my opinion) on the NookColor. Follow this link to pick them up:

The Nook Color's onboard wallpaper setting application will work perfectly if you rotate the device to landscape BEFORE getting to the screen were you drag the box around the part of the image that you want.
The Following User Says Thank You to silivrenion For This Useful Post: [ View ] Gift silivrenion Ad-Free
1st January 2011, 09:23 AM |#39  
Thanks Meter: 20
Thanks for this thread! Super helpful!

I saw someone asked this earlier but didn't see a reply.

Is there anyway to get a book from the library onto my homescreen when using an alternative launcher (zeam, launcher pro, adw...)?

1st January 2011, 12:54 PM |#40  
Senior Member
Thanks Meter: 29
Add books to HOME screen
I cannot take credit for this so please "thank" the proper person(s):
1st January 2011, 07:58 PM |#41  
Senior Member
Thanks Meter: 26
Just going through my build.prop and in Additional Build Properties theres a line that says

We only have Wifi... so would saying false possibly save battery life?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes