Remove All Ads from XDA

[FIX] for Nand USB Init Failed

15 posts
Thanks Meter: 33
By ntatschner, Junior Member on 1st January 2011, 03:48 PM
Post Reply Email Thread
Hello Guys/Girls,

As I was struggling with this I though I would share the info to help people get NAND Android installed.

Firstly if you are getting the below message you are most likely missing a couple of file's in the same directory called EnterBootloader and rapitool (which I have included in this post)

"Error Description: USB init failed
Info: .\RSPL\RSPL.cpp (723)"

Simply place those file in the same Directory as the DAF.exe file and vola it should now start the flashing from the DAF.exe file.

I hope this helps.

If you are running XP Go to control panel and then active sync while connected in MAGLDR while it states Wait USB...USB and un-check Allow USB then right click the DAF.exe and run as Admin, that should allow you to install.

Attached Files
File Type: zip Missing - [Click for QR Code] (92.2 KB, 20845 views)
The Following 31 Users Say Thank You to ntatschner For This Useful Post: [ View ] Gift ntatschner Ad-Free
1st January 2011, 04:07 PM |#2  
Thanks Meter: 2
Many thanks. I will check now.
1st January 2011, 04:09 PM |#3  
Senior Member
Thanks Meter: 64
Oh yeah I understand. That seems to be a bug of the DAF installer. These files normaly get removed after the RUU has run. And they also do in the DAF installer.
1st January 2011, 04:19 PM |#4  
Senior Member
Flag kudus
Thanks Meter: 101
still not working
1st January 2011, 04:21 PM |#5  
vensterbank's Avatar
Senior Member
Flag Baarn
Thanks Meter: 49
Donate to Me
this aint working for me, its like my pc aint fiding my phone. or the bug fix doesnt help.
however i can use diskdrive mode and htcsync works. so i dont get it.

im just trying to get the new kernel on my stock desire nand.
plz help,
The Following User Says Thank You to vensterbank For This Useful Post: [ View ] Gift vensterbank Ad-Free
1st January 2011, 04:51 PM |#6  
Senior Member
Flag London
Thanks Meter: 53
I was getting the same error. I took these three steps, and all is now working - im not sure if all three 3 steps contributed to success, or any one of them - but taking these measures definately worked for me (im running Windows XP by the way)
The phone should be connected to the PC at all times during these steps.

1) Install MAGLDR using admin rights. This was done by right clicking the Magldr.exe and selecting 'run as', then clicking 2nd option, signing in as a user with admin rights.

2) Open ACTIVESYNC, 'File', then 'Connection Settings' - UNCHECK 'Allow USB connections' Reboot phone

3) Right clicking 'DAF.EXE' file and running with admin rights (like it was done in Step 1 above). Click Next, next untill its searching for USB connection

4) On phone, select option 4.

hopefully, it should all now work

Hope this helps.
The Following 2 Users Say Thank You to nbhadusia For This Useful Post: [ View ] Gift nbhadusia Ad-Free
1st January 2011, 05:07 PM |#7  
Junior Member
Thanks Meter: 0
try your method....
but still error msg come out..

[Error happen
Read below for more information

Error Description: send partition data failed
Info: .\RSPL\RSPL.cpp (802)

Error Description:
Info: .\RSPL\RSPL.cpp (545)

it only process till half way..
using windows xp..
1st January 2011, 05:32 PM |#8  
Senior Member
Thanks Meter: 18
Run as administrator!

Sent from my HTC HD2 using XDA App
1st January 2011, 05:46 PM |#9  
Erkin Ay's Avatar
Senior Member
Flag Trichy
Thanks Meter: 73
Please note that. You must have HSPL 2.08 and Radio Rom on your device
1st January 2011, 05:48 PM |#10  
Flag Freiburg
Thanks Meter: 8
Donate to Me
Same Error for me.

After Right Klick and Start as Admin it works prompt.

Windows 7 X64

Give it a try.

1st January 2011, 06:18 PM |#11  
Senior Member
Flag Silicon Valley
Thanks Meter: 71
Getting same error here even with the suggested fixes. Ran as administrator, added the missing files and still the same USB init error. I am using the correct HSPL and radio files. Could it be the Windows XP laptop that I am using? Will try my other laptop running Vista and report back.
Post Reply Subscribe to Thread

fix, nand, usb init failed

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes