Remove All Ads from XDA

Zpad Setup Guide (SMB-A1002-3G) - Updated 14/03/2011

127 posts
Thanks Meter: 14
By 2manytoys, Senior Member on 4th January 2011, 01:23 PM
Post Reply Email Thread

** UPDATED 14th March 2011 **

Note 1 - Some software, eg Flash, is not on your ROM (maybe this was installed after manufacture). You need to back up these apps first. I'm not sure of all the apps, as I accidently wiped mine first, thinking they would all be on ROM. Fortunately the only one I did miss was Flash, and this can be added later (see below).

Note 2 - This is NOT my work. It's just the steps I followed to get MY Zpad working the way I wanted it (inc Market and Titanium Backup). People waaay smarter than me worked this out and credit should go to them.

Note 3. This is NOT a ROM, and you don't need to flash a ROM, the Zpad works FAST out of the box (I think Quadrant was 2450 (or 2350) from memory)

Note 4. I setup Wireless and Installed File Expert to access the files I needed from my Windows 7 computer.

1. Install Z4Root Version 1.3.0
This is needed to give you "Admin" Access to your device

1a. Install and Open and follow the steps on screen to Root your Zpad

2. Install Clockworkmod following these instuctions
NOTE: This "formats" your Zpad back to factory settings (your "Admin" access remains)
Original Thread -

2a. Download ClockworkMod v08 (This version has been found to work best...the newer version causes some issues with some ROMs.) There are two versions available; one for installing ClockworkMod from the internal memory, one for installing it from external memory (microSD/microSDHC card). Download from the original thread above. ** EDIT - It's recommended to use the Internal Memory File and remove your MicroSD card during install/setup **

2b. Unzip the file you chose ( OR to the root folder on the storage option of your choice. This is SDCARD on the ZPAD.

2c. Rename the original Recovery Folder, and move the new Recovery folder from the above ZIP to SDCARD (should now be SDCARD\Recovery)

2d. Move to SDCARD

2e. Turn off your device.

2f. Press the power button and the Volume+ button at the same time and release them when the Malata splash screen pops up. You should see "Detect a recovery key pressed" pop up in the upper left corner of the screen.

2g. Watch ClockworkMod install. This will not take long. Your tablet will reboot when installation is complete. Nothing will look different unless you enter ClockworkMod by following the steps below…

Entering ClockworkMod:
If you want to get into ClockworkMod you need to shut down your device, then press the Power and Volume+ button (the same way you did to install ClockworkMod). Thankfully this time it will not automatically restart and wipe everything.

Navigating CWMod:
Vol+ and Vol- are to scroll up and down, the home button selects an option, and the back button backs up.


(I installed Flash at this point, Version seemed the only one that worked for me??)

3. Install Google Apps (including Market)
The file is; You can download it by following the instructions in the thread below.
Original Thread -

Note: Some people have experienced problems with the Android/Google Apps Setup Wizard. I think this is related to Wifi only Zpad's? Thanks to Koaby for figuring out you can delete the setupwizard.apk from the cyanogen mod ( This fixes the problem.

Note 2: If you are having problems removing setupwizard.apk check out this post

You only need these instructions
3a. Copy download to SDCARD
3b. Hold volume + and power to boot into recovery (go to "advanced")
3c. Choose, choose zip from sdcard
3d. Choose the zip to be applied as an update
3e. Let Zpad boot and complete GMail Login Details (I had problems here, but my GMail details were stored... not sure why)

4. Fix the Market (Part 3, step 3)

4a. Open the Market app. Once it loads close it (press the home button).

4b. Go into Settings – Applications – Manage Applications – Google Services Framework – Force Stop – Clear Data

4c. Go into Settings – Applications – Manage Applications – Market – Force Stop – Clear Data

4d. Go back to your home screen and open up the market. You should get an error. If not, redo steps 3 and 4 until you do.

4e. Reboot your device. After it starts back up let it sit for a minute or two to let things in the operating system normalize. Open the Market. Reboot your device.

4f. Open the market again and enjoy. You now have Flash and the Android Market. (Keep in mind, this is not the FULL market, it just makes around 99% of it available. It is unknown which apps are not available. There is a full market fix, but it is MUCH more complicated).

(Edited out the bits not needed)

5a. Now you are going to re-do the original Market Fix. First, make sure Market is running, and browse around in it for a few seconds. If you don't do this, there may be no cache to clear and for some reason the market fix may not work. Then, go to Settings->Applications->Manage Applications->Running and scroll down to Market. Then hit Clear Cache, followed by Force Stop **DO NOT CLEAR DATA FOR MARKET, JUST CACHE**. Then go back, scroll down to Google Services Framework, hit Clear Data, then Force Stop.

5b. Now try starting Market again and you get the famous Market Error. Now shut down the Zpad, then turn it back on. Wait for Wifi to connect to your network before doing anything!

5c. Now restart Market again. ..... Voila! A truly full market!

Applications I use that work on Zpad
Root Explorer - Access to Root Files (not needed for this setup)
Titanuim Backup - to Backup EVERYTHING after I set it up the way I wanted
Astro + Bluetooth Module
File Expert - To access Win7 PC
Spare Parts (version 2.2) - To see battery/cpu use
Pocket Cloud - Access work server
MoreLocale 2 - Set Location to Australia
Button Savior - So I've got buttons on the left side too
Touchdown - Sync with Exchange Server
MSN Talk - In case I gets some mates one day
Dolphin Browser HD, with addons; Google Translate, Tab History and AdBlooker
Launcher Pro - The Zpad interface is not that good
Lookout - Antivirus

I hope this helps, Mal.

Again, all credit to the original posters, I just thought best to share the steps I followed for other Zpad users.

PS: I have the original ROM from my Zpad. Happy to share if anyone can point me to the best place to upload it.
The Following 5 Users Say Thank You to 2manytoys For This Useful Post: [ View ] Gift 2manytoys Ad-Free
4th January 2011, 01:24 PM |#2  
OP Senior Member
Flag Sydney
Thanks Meter: 14
In case I forget anything or need to add more stuff
8th January 2011, 11:17 AM |#3  
Junior Member
Thanks Meter: 0
zpad just wifi no 3g
I,m assuming this works on the zpad without 3g only wifi as well. Could you confirm.
8th January 2011, 08:10 PM |#4  
OP Senior Member
Flag Sydney
Thanks Meter: 14
It should work fine. Just make sure you do a backup before step 3 and you'll always be able to go back to standard.

Once it's all running, set it up the way you like, eg mail, apps etc, then install Titanium Backup an get a backup of your settings and apps.

Now if something ever goes wrong you'll be able to go back to your apps and settings or worst case back to Factory settings.
8th January 2011, 10:07 PM |#5  
Junior Member
Thanks Meter: 0
Thanks but issue
Thanks for your update. I followed your instructions and get to the welcome screen after installing the apps. It states touch the android to begin, which I do it clicks but nothing happens. Any suggestions.
9th January 2011, 03:02 AM |#6  
OP Senior Member
Flag Sydney
Thanks Meter: 14
I think from memory there was a "next" button that appeared on the bottom right, I think? It's just the GApps setup I think and I'm pretty sure you can skip it too. If not, try a reset again through clockwork. That's what I did and it seemed to work the second time??

If you have an SD Card in, try removing that and doing it again too.

Cheers, Mal.
9th January 2011, 07:55 AM |#7  
Junior Member
Thanks Meter: 0
Hello again

Thanks for the ideas. Unfortunately I can't get passed the touch the android button. bottom right is a button to change language, and bottom left is a button for emergency call.
Reloaded it about 10 times now and no luck. If you think of something let me know.
9th January 2011, 09:22 PM |#8  
OP Senior Member
Flag Sydney
Thanks Meter: 14
You did touch the Android Man in the middle right (sorry if you have just thought I'd check).

You could try plugging in a USB mouse, something has gone weird with your touch screen I think???
17th January 2011, 07:08 AM |#9  
Junior Member
Flag Caguas
Thanks Meter: 1
Same Problem Cannot pass the android men!
17th January 2011, 09:29 AM |#10  
OP Senior Member
Flag Sydney
Thanks Meter: 14
Can you talk me through what happened?

You installed clockworkmod, backed up the ROM, then let the system boot. Did everything work at this point?

Then you copied the gapps and rebooted but entering recovery this time. You selected the gapps zip and let it boot. This is where its got to the Android man and you couldn't get past right??
17th January 2011, 02:52 PM |#11  
Junior Member
Flag Caguas
Thanks Meter: 1
Yes, I try to bypass the ANDROID man welcome but nothing seems to work I redo all the steps several times now. I long press the home and acces app killer, even go to setting an try to shutdown all running apps but nothing happen. Mine is the SMB-1002-WIFI model. all help will be appreciated. And thanks
Post Reply Subscribe to Thread

backup smb-a1002-3g, clockwork, google, malata, market, zpad

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes