Remove All Ads from XDA

[Q] I9000T stuck during boot, can't get root

15 posts
Thanks Meter: 1
By hmoffatt, Junior Member on 12th January 2011, 12:58 AM
Post Reply Email Thread
I used z4root's temporary root and enabled RyanZA's OCLF but the phone never booted again (stuck at Galaxy S logo, after my carrier's logo.)

"adb logcat" shows that pretty much everything in /data is missing.

I can't get root to investigate much further. I installed from this thread:

which gave me su and busybox, but su just reports "Permission denied" and logcat shows

E/su ( 3315): stat failed with 20: Not a directory
W/su ( 3315): request rejected (2000->0 /system/bin/sh)

(in recovery mode, the stat fails with 2: No such file or directory instead). "su -s /system/xbin/busybox" fails in the same way.

I have /system/app/Superuser.apk, but given that nothing is really running due to the state of /data I don't think that helps. I can't see what's in /data due to not having root though.

any suggestions?
12th January 2011, 03:07 AM |#2  
OP Junior Member
Thanks Meter: 1
ok I have un****ed the phone. I couldn't get RageAgainstTheCage to run (never got a root shell), but the newer KillingInTheNameOf worked.

In /data I found that the lag fix had renamed data, system, app, app-private, dalvik-cache with .old suffixes. The ext2 volume was there but nothing was mounting it on boot. The directories had been replaced with files just containing the text "stump".

For now I nuked the files, renamed the .old directories back to what they should've been, and the phone is working again. (Still no lagfix though.)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes