FORUMS
Remove All Ads from XDA

CHevron WP7 USB device connections problem FIX!

290 posts
Thanks Meter: 40
 
By ilijan, Senior Member on 16th January 2011, 12:19 AM
Post Reply Email Thread
1. Have Winphone developer tools installed. Download it for yourself
2. Connect Phone via USB
3. Wait till zune starts and sync completes
4. Verify that zune is not in a guest relationship
5. open a command prompt, type netstat -a to confirm that port 443 is not being used
6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
8. While the phone is still on the settings page, run Chevron with admin privileges

Attention: if port 443 is used (see on your list) stop IIS or exit Skype program
The Following 17 Users Say Thank You to ilijan For This Useful Post: [ View ] Gift ilijan Ad-Free
 
 
16th January 2011, 02:26 AM |#2  
Senior Member
Flag Atlanta
Thanks Meter: 6
 
More
Links dead
16th January 2011, 03:07 AM |#3  
Senior Member
Flag Indianapolis
Thanks Meter: 11
 
Donate to Me
More
Quote:
Originally Posted by DJTJ

Links dead

Link has an ellipsis in the middle of it.

Regardless, this "fix" did not work for me.
16th January 2011, 03:38 AM |#4  
Senior Member
Flag Trinidad
Thanks Meter: 23
 
More
Quote:
Originally Posted by ilijan

1. Have Winphone developer tools installed. Download it for yourself
2. Connect Phone via USB
3. Wait till zune starts and sync completes
4. Verify that zune is not in a guest relationship
5. open a command prompt, type netstat -a to confirm that port 443 is not being used
6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
8. While the phone is still on the settings page, run Chevron with admin privileges

Attention: if port 443 is used (see on your list) stop IIS or exit Skype program

eureka!!! it worked!!!!
16th January 2011, 04:23 AM |#5  
Senior Member
Flag Atlanta
Thanks Meter: 6
 
More
Now it just gets the error later
16th January 2011, 05:31 AM |#6  
Senior Member
Flag Austin, Texas
Thanks Meter: 75
 
More
Quote:
Originally Posted by DJTJ

Now it just gets the error later

I mentioned this in the original thread:
Quote:
Originally Posted by DanielNTX

I had the same connection problem as everybody and then out of desperation I set my computer and phone date to the 1/10/11 and tried and it worked!

Quote:
Originally Posted by meletios

Guys.. finally..atleast I had my phone unlocked by chevron..
change the date to a future date(as a post earlier suggested, thanks ) , for me it was 01/Oct/2011...it worked finally..dont know how everything else pans out....will update..

Set the time and date of the phone and computer back to like 1/10/2011 and it should work.

For some reason the spoof'ed developerservices.windowsphone.com address to your local machine rejects the HTTPS 443 request if the date is correct. I think it was a built in kill switch by the original devs of ChevronWP7. Because the program can tell whether if the phone is pin-locked or not and will display a message accordingly meaning it definitely has a connection.
16th January 2011, 10:14 AM |#7  
Member
Thanks Meter: 0
 
More
Setting the date back seems to have no effect here. I changed the date of the computer and the phone to the 1st of january 2011. Reconnected the phone, waited until sync to zune finished and retried. Still the same problem.
16th January 2011, 11:27 AM |#8  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ilijan

1. Have Winphone developer tools installed. Download it for yourself
2. Connect Phone via USB
3. Wait till zune starts and sync completes
4. Verify that zune is not in a guest relationship
5. open a command prompt, type netstat -a to confirm that port 443 is not being used
6. open an admin command prompt, navigate to c:\windows\system32\drivers\etc\ then type notepad hosts and delete any references to windowsphone developer services
7. go to the settings on the phone and turn airplane mode on (so that the phone is forced to use internet via zune)
8. While the phone is still on the settings page, run Chevron with admin privileges

Attention: if port 443 is used (see on your list) stop IIS or exit Skype program

Thanks! Was the developer services in the HOSTS file that fixed for me.
16th January 2011, 11:33 AM |#9  
OP Senior Member
Flag Bratislava
Thanks Meter: 40
 
More
it work properly for me ... if you sync with zune its automatickly broke the chevron unlock... just go step by step and you can unlock your phone withou connection issus usb error...GL & HF
16th January 2011, 12:29 PM |#10  
Member
Thanks Meter: 0
 
More
what helps is just to sync for example one mp3 with zune before,t hen run chevron
16th January 2011, 03:55 PM |#11  
G-ThGraf's Avatar
Senior Member
Flag Paris
Thanks Meter: 24
 
More
doesn't works for me :s :s
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes