Remove All Ads from XDA
Honor View 10

[RECOVERY] [3/30/11] Updated ClockworkMod for ALL ROMs

1,098 posts
Thanks Meter: 3,162
By jt1134, Inactive Recognized Developer on 5th February 2011, 02:06 AM
Post Reply Email Thread
So the current iterations of cwm seem to have trouble working reliably with the newer froyo ROMs, and koush's recovery (although seeming to work correctly) is quite broken. So......

please find below a new recovery package that should work for any ROM for the fascinate, mesmerize, or showcase.

This is a "red" cwm recovery, and it will work with both voodoo and non-voodoo installations. can be flashed via any cwm recovery.

if you are using odin, then use the cwm-recovery-ALL odin (.tar) package.

updated 3/29 - thanks to GizmoDroid for help with fixing fix_permissions script and root permissions typo that screwed up nandroid restores

updated 3/30 - fixed 'umount' typo - actually *fixed* fix_permissions this time - fixed odin/heimdall recovery attachment
Attached Files
File Type: zip - [Click for QR Code] (7.17 MB, 35803 views)
File Type: tar cwm-recovery-ALL.tar - [Click for QR Code] (6.64 MB, 41897 views)
The Following 60 Users Say Thank You to jt1134 For This Useful Post: [ View ] Gift jt1134 Ad-Free
5th February 2011, 02:19 AM |#2  
Thanks Meter: 3
Thanks, I just installed it. I'd rather not have a broken clockwork mod.
5th February 2011, 02:22 AM |#3  
Senior Member
Thanks Meter: 4
thanks, will give this a try!

ok, so I flashed this in the old cwm and it does come up red, but also says CwM Voodoo Lagfix Recovery, is that right?
5th February 2011, 02:38 AM |#4  
Senior Member
Thanks Meter: 12
In what ways is the old cm broken with froyo? I haven't noticed any problems.
5th February 2011, 02:42 AM |#5  
Senior Member
Thanks Meter: 67
Thanks! Good to have a fully working recovery again.
5th February 2011, 02:49 AM |#6  
superchunkwii's Avatar
Senior Member
Flag Arizona
Thanks Meter: 70
Originally Posted by renf

In what ways is the old cm broken with froyo? I haven't noticed any problems.

Yeah, I'd like to 2nd this question. I have DL30 and CW worked for me in setting that up. Granted, I haven't tried anything else after that, but I'd like to know too.
5th February 2011, 03:02 AM |#7  
Senior Member
Thanks Meter: 48
Well I've had weird things happen when flashing stuff (I was using the "") , seemed like data being written where it shouldn't be? Just flashing theme files or own stuff I want to add, and I've had the following stuff happen:
Nuked my radio, had an unknown baseband and calls would never work, fortunately Radio Odin fixed it.
Had some /data apps disappear. Had some /data/data disappear. On reboot had Setup Wizard pop-up, even though I still had my Google account registered.

Hoping this new clockwork is completely safe. I suspected that clockwork was responsible for my weird happenings, so data-wiped and haven't flashed anything, so far fine functioning.
5th February 2011, 03:08 AM |#8  
Senior Member
Thanks Meter: 2
Using this is it easy to flash back to a prior set up, for me it would be back to dj05 w superdark and voodoo5?
Ive been holding off on froyo bc I need wireless tether, preferably unreported tether. But I really want to play around and see what the fuss is about. Ive downloaded every dl30 rom, havent installed one fearing I cant go back easily
Sent from my SCH-I500 using XDA App
5th February 2011, 03:12 AM |#9  
OP Inactive Recognized Developer
Thanks Meter: 3,162
Donate to Me
/data on the fascinate is on /dev/block/mmcblk0p1

koush's recovery mounts /data as mmcblk0p2 (THIS IS OUR /DATA/FOTA. THAT'S BAAADDD)

under most circumstances this does not matter , because recovery.rc mounts data CORRECTLY before cwm gets to it, but there are circumstances where /data can be unmounted and then remounted, in which case cwm is gonna mount mmcblk0p2. If things get written there, at best you've got a **** load of FC's to deal with. At worst, a dead radio.

I've pointed this out to koush before, but was met with a "half-response", and to date it not been addressed (except for the recoveries that I've posted)
The Following 4 Users Say Thank You to jt1134 For This Useful Post: [ View ] Gift jt1134 Ad-Free
5th February 2011, 03:28 AM |#10  
Senior Member
Raleigh, NC
Thanks Meter: 53
installed. When I go to do a backup, it gives the messages below. Backup seems to run fine though


E: missing bitmap progress_empty (code -1)
E: missing bitmap progress_fill (code -1)

5th February 2011, 03:30 AM |#11  
Senior Member
Latrobe, PA
Thanks Meter: 108
Thanks, jt.

Copied to sdcard, booted into recovery, ran the program, keep coming back to green, no red.

ETA: Interesting. If I go to recovery from ROM mgr and try to load from sdcard, it does nothing, but if (while in ROM Mgr) I load from SDcard, it works. Got the blue screen, ran update, red appeared.

I likewise get the error message mentioned previously, but got it at install. Backup seemed to ahve run fine.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes