FORUMS
Remove All Ads from XDA

[GUIDE] X10 Battery Calibration

316 posts
Thanks Meter: 66
 
By ooidort, Senior Member on 6th February 2011, 01:19 PM
Post Reply Email Thread
A while back there was a thread about supposedly calibrating X10's battery by charging it to 100%, turning it off, taking the battery out and inserting the charger chord, and then putting the battery back. This made the battery percentage drop down to 88% and when repeating this procedure a couple of times it would rise back to 100%, thus supposedly calibrating the battery. This worked to some and to others not. Now that we have xRecovery, I thought I'd try this in conjuction with the battery stats wipe option and whaddayaknow, I've got better battery life now. Now I can go through a whole day with heavy usage and still have some battery left for the phone to survive through night with data and syncing on. So I thought I'd share this with you guys to try out and report too.

ROOT IS REQUIRED!

STEPS:
1. Download and install xRecovery from here.
2. Charge your phone to 100%
3. Turn off the phone and boot into recovery
4. In recovery, go to Advanced options --> Wipe Battery Stats --> Yes
5. Take the battery off
6. Insert the charger chord
7. Put the battery back and wait for the phone to boot
8. Once the phone boots up, you will notice that the battery percentage is around 88% instead of 100%
9. Charge the phone back to 100%
10. Repeat 4-5 times, seems to be the sweet spot
11. Enjoy your hopefully better battery life and report!

REMEMBER THAT I'M NOT RESPONSIBLE IF YOUR PHONE BLOWS UP ETC. AFTER THIS!
The Following 30 Users Say Thank You to ooidort For This Useful Post: [ View ] Gift ooidort Ad-Free
6th February 2011, 02:49 PM |#2  
Wolfbreak's Avatar
Inactive Recognized Developer
Thanks Meter: 11,577
 
Donate to Me
More
Do i need to repeat all from 1 to 10 until i get 100? And do i need to do this 1 Time or do i need to do this the next 2-3 Days too?
6th February 2011, 03:14 PM |#3  
OP Senior Member
Thanks Meter: 66
 
More
Quote:
Originally Posted by Wolfbreak

Do i need to repeat all from 1 to 10 until i get 100? And do i need to do this 1 Time or do i need to do this the next 2-3 Days too?

Repeat from step 2 onwards till step 9. I believe you don't have to do it more than two or three times to get the desired effect, that's why I'd like to have you guys to test it out too to confirm.
6th February 2011, 05:35 PM |#4  
Lord Takyon's Avatar
Senior Member
Thanks Meter: 265
 
More
Been through the cycle 5 times, still showing 87% at reboot.

Just for the record, I have the 435 firmware.

Sent from my X10i
6th February 2011, 05:40 PM |#5  
teddymild's Avatar
Senior Member
Thanks Meter: 71
 
More
Did you recharge after reboot?

Quote:
Originally Posted by Lord Takyon

Been through the cycle 5 times, still showing 87% at reboot.

Just for the record, I have the 435 firmware.

Sent from my X10i



Sent from my X10i using XDA App
6th February 2011, 10:21 PM |#6  
Lord Takyon's Avatar
Senior Member
Thanks Meter: 265
 
More
Quote:
Originally Posted by teddymild

Did you recharge after reboot?





Sent from my X10i using XDA App

Yes my friend, followed to the letter.

I have noticed one thing, my battery is behaving a bit strange. I used it earlier and it depleted from 100 to 93%, it then went back in my pocket for an hour or so and when I next used it it said 98% charge.

I ran it down to 83% and then put it back to sleep for 30 minutes, checked it again and it said 94%.
6th February 2011, 11:45 PM |#7  
OP Senior Member
Thanks Meter: 66
 
More
That is certainly strange... Hasn't happened to me yet, and I've been monitoring my battery for nearly a week now.
7th February 2011, 12:05 AM |#8  
Lord Takyon's Avatar
Senior Member
Thanks Meter: 265
 
More
It certainly seems to have more juice in though. Given it a bit of a thrashing this evening and I would usually be down to around 50% our so, it's currently at 75%.

I will monitor for a day or so to see if it is just placebo or not.

Sent from my X10i
7th February 2011, 08:22 AM |#9  
Senior Member
Thanks Meter: 21
 
More
Quote:
Originally Posted by Lord Takyon

Yes my friend, followed to the letter.

I have noticed one thing, my battery is behaving a bit strange. I used it earlier and it depleted from 100 to 93%, it then went back in my pocket for an hour or so and when I next used it it said 98% charge.

I ran it down to 83% and then put it back to sleep for 30 minutes, checked it again and it said 94%.

Same happened to me overnight. Went up 8%!

Further, I've now done this process 6 times meaning my battery is effectively 160% of what it was???!!!

Have we got any hardware experts who can pass a view on whether this a bad thing to do? Overcharging a car battery can be bad for example.
7th February 2011, 08:28 AM |#10  
Senior Member
Las Vegas, NV
Thanks Meter: 164
 
More
i've done it 7 times and still boots at 88% battery.

lets see if it did something in the next day.. =P
7th February 2011, 08:43 AM |#11  
LiveSquare's Avatar
Senior Member
Flag Singapore
Thanks Meter: 343
 
More
I've done this and on the first try, it booted with 88%. I recharged it and on the next boot it came with 100%.

Let's see whether there is any real improvement :)

Thanks anyway for the guide.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes