[DEV] CM7 Developers Thread

1,433 posts
Thanks Meter: 2,780
By dalingrin, Inactive Recognized Developer on 19th February 2011, 11:32 AM
Post Reply Email Thread
Please limit this thread to development comments and questions!
The users thread is for all other posts.
When in doubt, post in the users thread.

After many long nights of banging our heads against keyboard, the CM7 port is finally shaping up.
In addition to nightly releases, we may from time to time be releasing test builds here for your feedback and enjoyment. If you find issues please feel free to post here in this thread. Leave all other feedback for the user thread.
Where to get progress news:

I will tweet progress from time to time.
Twitter: @dalingrin

We are usually in #nookie on freenode.

You can always check the Cyanogen [email protected]
Current Issues

****Should be fixed in nightly 13****

-Standy battery life is not as good as stock
Because of a kernel bug CM7 does not fully sleep. The result
is ~1% battery drain per hour while the screen is off. With normal use I usually go
1 - 2 days between charging.
***fixed in 2.6.32 builds***

-A few apps do not scale to full screen
In order to get Market and Maps to work fully the lcddensity has to be
set to something other than 160 causing a few apps not to scale properly.

-Wifi slow to reconnect at times

-Video playback is slow

-Default rotary lockscreen does not fit screen

-Market partially works

-Bluetooth does not work
****Update**** Bluetooth now works in CM7.
Bluetooth is working seemingly perfect except for the range. Unfortunately, the range is terrible.
Depending on the device you are paried with, the range is between 1-5ft. Any ideas on how to
fix the range issue would be much appreciated.
-Do not use SetCPU profiles
If you enable SetCPU profiles it will become a runaway process eating 100% cpu.
Setting your cpu clock can be done in Cyanogenmod Settings. Under Performance->CPU Settings

-Internal storage partition is not mounted on boot and is not shareable via USB
Download and Install

This is installable ONLY with an ext4 aware Clockwork Mod Recovery.

*** Also it is critical to be aware that installing CM7 will write to the internal emmc of your device. You are advised NOT to try it. But if you choose to do so, understand you do so entirely at your own risk. Read sections 15-17 of the GPL for the gist of this disclaimer. There is no warranty or claim of usefulness or fitness for any particular purpose. No one but you shall accepts responsibility for what may happen if you download or try to use this development software. ***

Download for CM7:


Install instructions:
The Following 99 Users Say Thank You to dalingrin For This Useful Post: [ View ] Gift dalingrin Ad-Free
19th February 2011, 11:32 AM |#2  
OP Inactive Recognized Developer
Thanks Meter: 2,780
Post Reserved.
The Following 4 Users Say Thank You to dalingrin For This Useful Post: [ View ] Gift dalingrin Ad-Free
19th February 2011, 11:35 AM |#3  
fattire's Avatar
Inactive Recognized Developer
Thanks Meter: 6,503
Donate to Me
Developer Tips

(Standard do-at-your-own-risk-and-responsibility disclaimers apply.)

* For those developers building from source:

In $OUT, you'll find a few files:

recovery.img --> rename to uRecRam
kernel --> rename to uRecImg

Now you've got the ext4 clockworkmod for mmc built from source.

* Also, there's also a script in $OUT called:

Assuming this works, it should repack your $OUT/root (mmc ramdisk) into a uRamdisk that can be used with a bootable SDcard. The stuff in /system would go in the /system partition of the SD card (p2).

The result: a bootable CM7 on SD. It may not be wise to distribute as Cyanogenmod for encore is a fast-moving target-- unless you plan to create a new one every day or something.

* If you don't like the buttons at the top for some reason, there's the SoftKeys app as well as Button Savior.

* There is a slightly-themed u-boot.bin in device/bn/encore/prebuilt/boot/. It is simply a recompiled u-boot from BN's source.

Info about emmc geometry

If your emmc is hosed and you want to start COMPLETELY from scratch, understand that the underlying geometry (before any partitions are created) of your emmc must be set up correctly on OMAP machines such as the nook before any partitions are created.

You can read more about that stuff here. If you are booted into an "emergency" SD card and have a totally hosed emmc, you can use fdisk to format /dev/block/mmcblk0 to the correct geometry, and then create the partitions one at a time, with a vfat partition as your /boot partition (p1). Then put mlo, u-boot.bin, uImage, uRamdisk, uRecImg, and uRecRam in /boot (p1) and you should have a bootable system.

Read the link above about SD/MMC formatting for OMAP3. Your nook is an OMAP3621, so you gotta get that geometry right, otherwise it won't boot. Luckily, the instructions on using fdisk are pretty good.

More info:

your emmc: /dev/block/mmcblk0
your sd: /dev/block/mmcblk1

Partition Info

the partitions you should have created are at:

/dev/block/mmcblk0p1 == /boot
/dev/block/mmcblk0p5 == /system

/boot, /rom, and /media are of type "vfat"
/system, /data, and /cache are of type "ext4"

/factory (p3) isn't used by cm7

partition 4 is just there to allow you to create partitions 5-8

Sample instructions for copying files from cm7 on local computer to emmc /boot

You should be able to copy those four files simply by getting the lastest cm7, unzipping it on your computer, then once you boot into your bootable SD card, do:

COMPUTER> adb shell
# mkdir /data/bootmountpoint
# mkdir /data/systemmountpoint
# mount /dev/block/mmcblk0p1 /data/bootmountpoint
# mount /dev/block/mmcblk0p5 /data/systemmountpoint
# exit
COMPUTER> adb push mlo /data/bootmountpoint/
COMPUTER> adb push u-boot.bin /data/bootmountpoint/
COMPUTER> adb push uImage /data/bootmountpoint/
COMPUTER> adb push uRamdisk /data/bootmountoint/
COMPUTER> adb push  my/path/to/sdcard/system /data/systemmountpoint/
The Following 11 Users Say Thank You to fattire For This Useful Post: [ View ] Gift fattire Ad-Free
19th February 2011, 11:36 AM |#4  
thecubed's Avatar
Inactive Recognized Developer
Flag Austin, TX
Thanks Meter: 10,505
Donate to Me
Man, everyone makes better (prettier) release threads than I do.
The Following User Says Thank You to thecubed For This Useful Post: [ View ] Gift thecubed Ad-Free
19th February 2011, 01:17 PM |#5  
Thanks Meter: 17
oups, to delete
19th February 2011, 01:44 PM |#6  
foxdl99's Avatar
Senior Member
North East, MD
Thanks Meter: 7
I can mount SD card find from my PC on Ubuntu.

Some apps don't show up on search, only one worth noting right now is Dolphin browser. I can find all kinds of add-ons, but not the app itself.

The lockscreen defaulted to the slider, but when I rebooted it went back to rotary. I went to settings and changed it back to slider.

Edit: Also to note is when I first launch the market, I get a force close on search function unless I use menu->search first. Will try fix permissions. Edit: fix permissions doesn't work, I must use menu->search the first time.

Edit 2: Beautiful Widgets shows up in market but says it isn't there when I try to install.
19th February 2011, 02:28 PM |#7  
Senior Member
Thanks Meter: 83
I had no trouble mounting SD to my PC (windows 7 64). I don't remember which now, but many apps showed in market, allowed me to install, but when I tried to 'open' from their market page I was told they weren't there - just opening my app drawer showed them and they worked fine. Something in market for that one.
19th February 2011, 02:35 PM |#8  
Senior Member
Thanks Meter: 11
screen on/off notification
is the screen on/off setting working?
19th February 2011, 03:10 PM |#9  
chemical1der's Avatar
Senior Member
Thanks Meter: 18
I've also been able to mount to sd via Ubuntu and OS X.
19th February 2011, 03:22 PM |#10  
cosine83's Avatar
Senior Member
Flag Las Vegas, NV
Thanks Meter: 53
Donate to Me
Is there any way to get/use the recovery without using a burn to SD method?
19th February 2011, 03:25 PM |#11  
lafester's Avatar
Senior Member
Thanks Meter: 655
going to try it out now... thanks dalingrin
i notice the file name is the same as the first test release. hopefully i have the right file.


so yes i did have the correct file. lockscreen fix works and am still able to change it to rotary although it 'appears' to be set on rotary already.
market works... so far i have not found anything missing.
i have not been able to connect to usb. first connect got me a failed driver install and i don't see any usb mounting option in settings. -edit- just tried again and now it works? probably a windows thing.
Originally Posted by dalingrin

Fixes that need testing

-USB storage mounting
We need folks to test mounting your sd card from within CM7 onto your computers.

-Market Access
This build contains a partial fix for Android market filters. I don't expect all apps to be available yet but I'm not sure what is and not available in the current build.

-Default lockscreen
I have submitted a patch upstream to change the default lockscreen from rotary to the traditional slider. This is because the rotary lockscreen does not scale for the nook. This patch required changing some mechanics in CM and needs testing. In particular, it needs to be verified that the initial lockscreen is the traditional slider but can still be changed in Cyanogenmod Settings.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes