Remove All Ads from XDA

Solution to Error 801812C1 during Step 6 of February Update (7004:7008)

22 posts
Thanks Meter: 3
By tejazz, Junior Member on 22nd February 2011, 08:27 PM
Post Reply Email Thread
Note to the moderator(s) - I posted the same thread at the Home -> Windows Phone 7 Development and Hacking -> Windows Phone 7 General sub-forum already. I thought LG Optimus 7 owners might miss this info if I don't post into this forum. If you still think that this post is redundant, please delete it.

Great News! I have stumbled upon a solution for the 801812C1 error!

I have reasons to believe that this works for LG E900 Optimus 7 phones. If you want to try this on your Samsung Omnia 7, please read my note at the end of the post.

Here's what I did (LG E900 Optimus 7 / Windows 7 64bit):

During Step 6 (Rebooting your phone), your Windows OS detects your phone as a new device and starts searching for driver updates online. This can be seen when you click on the little indicator with a spinning green circle in the bottom-right corner of your desktop called the notification area (you might need to click on Show Hidden Icons if it's hidden).

You have to *immediately* click on "Skip Obtaining Device Software Online" or Zune will time-out and show error 801812C1.

Once you've skipped obtaining the drivers online, in about 20 seconds or so, your device will be recognized and you will be promptly taken to the Step 7 of the update.

Note for Samsung Omnia 7 users:

Even if you've gotten past the Step 6 801812C1 error, many users are getting stuck at Step 7 at 100% of 'Backing up your phone' resulting in a few users getting their phones bricked -- you might want to wait till that issue is resolved before trying this fix.

Hope this helps.
The Following User Says Thank You to tejazz For This Useful Post: [ View ] Gift tejazz Ad-Free
11th March 2011, 07:47 AM |#2  
hassler's Avatar
Senior Member
Flag Hanoi
Thanks Meter: 1
Let's see if it works
Mine is HTC Mozart and it's stuck at the very 6th step
hate it!
21st July 2011, 05:51 AM |#3  
Flag Corozal
Thanks Meter: 1
Originally Posted by hassler

Let's see if it works
Mine is HTC Mozart and it's stuck at the very 6th step
hate it!

Have you gotten it fixed ? I am the same problem here... Do you or somebody here knows the fix? what about step 7 where people have reported it gets stuck at 100% and getting their phone bricked?
27th September 2011, 11:05 PM |#4  
Junior Member
Thanks Meter: 0
got the same problem with Dell venue pro and tried everything......

but there is no icon where i can cancel the search for driver :eek: what can I do? Please, I tried everything , and I'm very frustrated now
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes