Remove All Ads from XDA

FRX04 Bundle and FRX05 Update

4,064 posts
Thanks Meter: 416
Post Reply Email Thread
3rd March 2011, 02:29 PM |#11  
Eodun's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 51
Originally Posted by ypsmav

I've updated to FRX5 yesterday, and so far much better/faster than FRX4.
Camera and camcorder works fine.
Battery life for me is similar to FRX04.

The old issues still unsolved (at lest for me) are:
a) Bluetooth not working (for me the most important to use it on daily basis):
- Calls: even if paired with my handsfree, and you pickup the call with it, voice is not going throught the handsfree.
- Music: it goes thorugh the handsfree, but suffering heavy audio shutering.
b) Skype not signing in.
c) Facebook don't sync contacts.


a)BT as always... still no devs onto it AFAIK
b) That's Skype's problem, not XDAndroid. There are other original Android devices that can't login too.
c) Not sure where the problem is, but same as a). Could be google's problem too.
3rd March 2011, 04:34 PM |#12  
Senior Member
Thanks Meter: 2
I updated my blackstone to the FRX05 last night. First, I only replace the system.ext2 file within the existing andboot folder and after booting it up, it was so slow (both booting slowly, and once booted, everything run so slowly).

Then I followed advice from Eodun to backup and deleted the andboot folder, and put back a new andboot folder from the FRX04 plus the new system.ext2 file from the FRX05, and put back the data.img and the calibration file.

Then boot it up, it runs normally now. Everything seems to be back normal, it runs smoothly and may be a bit faster than FRX04, but not really significant faster.
I was glad it runs normally again and could pick up the old data.img, so I did not need to reconfigure everything.

Camera does not work for me. Eodun, it seems you just mentioned few more steps to get it working? Can you give more details on those steps?

I also notice the startup file did not have the rel_path=andboot anymore.
But it seems no problem at all, mine runs fine without it.
3rd March 2011, 09:33 PM |#13  
Eodun's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 51
Well, now you just need to get the lastest kernel from autobuild and cam will work out of the box.

About rel_path, better having it, just in case haret goes mad
The Following 2 Users Say Thank You to Eodun For This Useful Post: [ View ] Gift Eodun Ad-Free
3rd March 2011, 09:59 PM |#14  
Senior Member
Thanks Meter: 2
hmm.. i downloaded the kernel but have not figure out how to expand the tar file and get the kernel file out of it (I don't have linux). Perhaps I should wait until they release a full bundle of FRX05.
3rd March 2011, 10:10 PM |#15  
Eodun's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 51
I use 7zip file manager for windows, it can extract tar files and it's free.

BTW, remember to:

1.- rename zImageblahblah to zImage
2.- Don't extract modules
3.- Put both files in andboot folder (overwrite zImage)
4.- You can safely delete old modules (be careful with which ones you delete! )
3rd March 2011, 10:57 PM |#16  
Senior Member
Thanks Meter: 29
Clean install on formatted SD
Since this turned out to be a rather lengthy post, there's a conclusion at the bottom of it. And if all your interested in is camera performance that's where to go...

FRX04 bundle with FRX05 system.ext2 and 20110228 kernel on a freshly formatted SD.
(and with old startup.txt: OC, waiting for SD fix, initrd_offset, sleepmode 3)

First boot:
Get's to home screen. Started removing widgets, and at the last one (search bar) the phone froze.
Waited for a few minutes, then pulled battery.

Second boot:
Boots fine until lock screen. When unlocking phone it had removed all home screen widgets.
Went to APN settings to remove the defaults loaded from SIM which are wrong, but phone froze as soon as i touched the menu button inside APN properties.
Waited for a few minutes, then pulled battery.

Third boot:
This time without SIM since the problem with the second boot so closely resembled the freeze of the froyo x red first boots issue.
Boots into lock screen. Straight to APN settings. No freeze
On to Wifi settings. Setup and connected in no time at all!
Setup Gmail account. Synchronized without problems.
Went through most other settings without any problems. Happy to see the time-zone issue is now fixed
Read some email. Wifi is working great, just like before. Wanted to play some music but realized there were no mp3's on the sd...
Oh well, time to put in the SIM. Phone shut down 'as designed'.

Fourth boot:
With SIM, also put some apps to install in designated folder (including ZEAM) and some mp3's in a separate folder.
Boots into lock screen. Unlocked and set ZEAM as default launcher. Loads fine. Very responsive and fluid. (i turn all animation OFF)
Played some music: stutters unbearably...
Disabled Wifi, opened an email to connect 3G. Message opens, but (probably) prefetched because there's no 3G icon in the notification bar.
Waited for a few minutes, then pulled battery.
Maybe i hadn't switched on 3G in WinMo before this boot, don't remember or know if it's still needed. Turned it on just in case before the

Fifth boot:
Just to see if audio is ok without Wifi. (i had this with some other kernel, don't remember which one, really should start keeping those logs)
While watching the androids fly through the boot animation it hit me: i never put the dot next to the APN after inserting the SIM again...
Freezes after i pull down notifications...
No waiting this time.
No changes, just a

Sixth boot:
Starting to lose confidence in this endeavour...
Boots fine, unlocks fine. Into settings, and freeze...

Lucky number 7 or tie-breaker?
Removed the OC from startup.txt, even though it's 'only' at 600Mhz and never gave me problems with other builds.
Boots fine, unlocks fine. Into settings to find the default APNs are back alongside the one i put there myself and the dot next to the wrong one.
Put the dot where it should be, deleted first excess APN, deleted second excess APN and freeze...

One more time...
YES! The 3G icon is there.
BUT! Still stuttering the audio.
Check out the camera though before swapping kernels: it loads.
After taking one picture i get an all black viewfinder. Phone's not frozen because it vibrates when pushing the virtual buttons. Back button does nothing, but it let's me turn off the screen and back on again to find the lock screen. Camera not running anymore according to task killer. Try again...
Now it let's me take pictures. AND record video, with sound. The first picture i tried to take is not in the Gallery.

Although it took me 8 boots to finally have this FRX05 system.ext2 running, it runs very well once it does. Praise for implementation of the camera in the last kernel, pics and video with sound, hooray!
But because of the audio, this kernel is not for me.
I'll try once to get it running with the 1255 kernel and otherwise it's back to GBX0A for me.
The Following User Says Thank You to hrk7474 For This Useful Post: [ View ] Gift hrk7474 Ad-Free
3rd March 2011, 11:34 PM |#17  
Eodun's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 51
I always have to let settle down and load everything (just wait 2-3min) after a boot. After that, I have none of the problems you describe, though I don't play music and don't know about the stuttering (sure it's there, as it's a problem with battery meter). Oh, and I don't use 3G...

You must have something around that makes your device behave weirdly.

First thing is OC, I never felt that it made my phone run faster, but to decrease stability.

Also, if you tried many builds, one thing I'd do is to beckup, full format SD with HP format tool and restore.

Thanks for your tests
The Following User Says Thank You to Eodun For This Useful Post: [ View ] Gift Eodun Ad-Free
4th March 2011, 12:53 AM |#18  
Senior Member
Thanks Meter: 29
Thanks for reading all that

I just did the kernel swap to 1255 and the audio stuttering is gone, but of course so is camera functionality. I'll try to put in the libs from viruscrazy's thread to see if it works sometime tomorrow. For now i'll just fully charge the battery and see how long it lasts. I had GBX0A running for over 12 hours without charging with this same kernel.


You must have something around that makes your device behave weirdly.

Well, yes. That would be me

I haven't put back the OC, and like you said, i can't really tell the difference. I'll just leave it standard for now.
I've made backups of working FRX04 and GBX0A builds with everything on them, because i format all the time

I'll keep testing and trying things. Thanks again.
4th March 2011, 08:36 AM |#19  
Eodun's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 51
aaarrghh made a full bundle with FRX05, you can find it here:

For blackstone just remember to keep ts-calibration and startup.txt, also data.img if don't want to lose everything.
The Following User Says Thank You to Eodun For This Useful Post: [ View ] Gift Eodun Ad-Free
4th March 2011, 04:46 PM |#20  
Lothaen's Avatar
OP Senior Member
Thanks Meter: 416
I had issues with the calibration using the FRX04 full bundle and adding on the FRX05 system.ext2

kept coming up wit the calibration question then as soon as i pressed the first one it went back to a screen full of text so i had no idea where to press...

trying the frx05 bundle now...

edit: same issue - will go back to frx03 and hopefully it will work on there and i won't delete it this time and copy that to frx05!

tried the GBX release too which did the same calibration issue

edit2: calibration for my blackstone:


just in case it helps in the future
4th March 2011, 05:17 PM |#21  
Senior Member
Thanks Meter: 29
Originally Posted by Lothaen

will go back to frx03 and hopefully it will work on there and i won't delete it this time

If i'm not to late and you haven't wiped yet, there's ts-calibration files on XDA for download at different places.

But here's one, anyway
Attached Files
File Type: txt ts-calibration.txt - [Click for QR Code] (40 Bytes, 298 views)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes