[GUIDE] *Rooting the Xoom for Dummies*

575 posts
Thanks Meter: 208
By js042507, Senior Member on 5th March 2011, 10:25 PM
Post Reply Email Thread
***Xoom Rooting Guide for N00bs***

Hello Xoom Dev community! Sorry. I know you're thinking, "Man! Not another Xoom root guide?!". Lol. But I wanted to make this, so, here ya go...

-This will erase everything on your xoom. Its like flashing flashing back to stock because of the unlocking process. So BACK everything up before continuing via USB, or your preferred backup app-

**Also, this Tutorial is for the 3G version ONLY. The Wifi model is different and uses an incompatible boot.img. Once again, ONLY FOR 3G MODEL**

Ok. So, rooting the Xoom isn’t really that “hard” of a task. I’m a n00b as well, so I did have a little difficulty doing it. Only because this method requires you to use adb, the command prompt, etc…

Well, I wanted to make a guide that should be ‘n00b-proof’. LOL. It’s really super simple.

**Bofore you get started, make sure the USB Debugging option is enabled in the Settings. Go to Settings --> Applications --> Development --> USB Debugging**

Alright, you’re going to need some tools to get it done. First of all, download the Xoom USB drivers. Either get them from -->, which requires a free membership; or get them from the Motorola/Support site -->, and download the ‘motohelper’ program. I prefer the drivers from the dev site because they’re just stand-alone drivers. Motohelper is an actual app that “keeps your drivers up-to-date”. Both will have the same version of drivers, i.e. 4.9.0.

Now that we have the drivers installed plug in your Xoom to make sure all drivers/services were detected/installed properly. If you’re good, next we will need the Android SDK, if not already installed. To properly install it though, you must download the Java JDK from -->, and click the “Download JDK” button. Choose your OS, and install.

**NOTE** If you’re running Vista/7 x64, Android SDK will not detect the REQUIRED Java kit installation. Yes, JDK has been properly installed, but the Registry doesn’t read the installation right. So, to get around this issue, either go here -->, for a tutorial that gets it detected by modifying the Registry. Or, do what I did, and just download the .zip installer of Android SDK. I’m writing this guide based on the ‘zip type’ of installation, but I’m sure the directories are identical besides having SDK installed in your Program Files folder.

Whew! Now, either extract the SDK to a directory of choice, or point your mouse to the Program Files\Android SDK\ directory. There will be some folders like platforms, platform-tools, tools, etc…

Anyways, to root the Xoom you will be running a command prompt from one of these folders. NOTE, in the newest release of Android SDK, they have moved the adb files to the ‘platform-tools’ folder, rather than all in the ‘tools’ folder. What I did, was copied everything from inside the ‘platform-tools’ folder, to the ‘tools’ folder. But do not replace any files! Just copy. It will put the required files, like adb.exe, inside one location. Sorry if I’m confusing anybody. LOL! Just copy the files from ‘platform-tools’ --> ‘tools’. Without replacing anything.

**NOTE** When I first installed SDK, I ran the emulator.exe from within the ‘tools’ directory. This updated everything, but I’m not sure if it matters for this tutorial?

Ok. The “hard” part is over. We should be all setup, and ready to type some commands! What you’ll need to do now is, open up a command prompt i.e. cmd. And do a cd --> to whatever path the ‘tools’ folder is in. For example, mine is in a Xoom folder from my documents. So the command would be “cd C:\Users\%name%\Documents\Xoom\android-sdk_r10-windows\android-sdk-windows\tools”. Without quotes of course.

You should now be pointed at the ‘tools’ folder from cmd, and next we can start the commands!

- Xoom drivers installed, xoom is plugged in, & detected properly. To make sure, open Device Manager to see if the “ADB Interface” is there. **Sorry, I’m not sure ADB is in Device Manager before, or after rooting** Can’t remember! As long as you don’t have any ‘device is not properly installed’ pop-ups, you should be good!

- Android SDK is configured right, and cmd is pointed at the correct location.

-USB Debugging option is checked. Check above for instructions

***This is obviously, from Koush’s site, so give him some kudos please ***
***I will bold all commands, and try to put in ‘n00b’ terms***

Type the following commands in CMD… after you have moved the “XOOM root” files.

1. Download the XOOM root zip.
2. Unzip the package, and
3. put the 3 files inside the same ‘tools’ folder we’re running cmd from!
4. adb reboot bootloader (skip the next 3 steps if you have already unlocked your Xoom via fastboot, which is another guide on XDA that just lets you unlock the Xoom. It’s not rooting.)
5. fastboot oem unlock
-You have to accept the terms by pressing the vol - down key, and then select 'accept' by pressing the vol + up key.
6. -wait for the Xoom to reboot completely.
**You may have to re-enable USB Debugging mode again for the next command**
7. adb reboot bootloader
8. fastboot flash boot rootboot.img
9. fastboot reboot
10. -wait for the Xoom to reboot completely.
11. adb remount
12. adb push su /system/bin/
13. adb shell --> You will now be mounted within adb shell…
14. ln –s /system/bin/su /system/xbin/su
15. chmod 4755 /system/bin/su
16. exit --> This gets you out of adb shell…
17. adb push Superuser.apk /system/app/

That is all! Now, unplug the Xoom and reboot it.

To verify your root is working properly, download an app such as, Cachemate, or any other that requires Superuser access. Open up Superuser to see if that apps’ rights were saved successfully.

Yay! Root access! But honestly, this tutorial will be outdated and inefficient, once the source code is out and then we’ll have a oneclickroot method. Which is way better! Until then, I hope anybody who is a little confused about the process benefits from this guide.

Happy moddin’!
The Following 15 Users Say Thank You to js042507 For This Useful Post: [ View ] Gift js042507 Ad-Free
6th March 2011, 06:13 AM |#2  
Senior Member
Flag Queens, NY
Thanks Meter: 59
good guide.
7th March 2011, 06:21 PM |#3  
Senior Member
Thanks Meter: 16
Thanks, I like this guide and made rooting my xoom super easy.

One other important initial step is to make sure USB debugging is enabled:

Settings>>Applications>>Development>>USB debugging
7th March 2011, 07:35 PM |#4  
js042507's Avatar
OP Senior Member
Thanks Meter: 208
Hey, thank you guys for your kudos. I appreciate the feedback.

@jtseidner, Man you are a genius! That is a very important step that I left out! You couldn't root the Xoom without that option. I'll add it to the tutorial.
7th March 2011, 11:16 PM |#5  
Senior Member
Thanks Meter: 7
14. ln –s /system/bin/su /system/xbin/su

Its saying In: not found.. help
8th March 2011, 12:15 AM |#6  
js042507's Avatar
OP Senior Member
Thanks Meter: 208
Hey. The command is all lower case so it would be "LN" not "IN". Just type it in all lower case. The rest of your command is ok. Simple syntax error, that's all. :) Let me know if it works and if you have any other concerns.

Sent from the most 'Epic' phone in the world! ...Using XDA Premium app :)
8th March 2011, 03:29 PM |#7  
Senior Member
Thanks Meter: 6
ok i got to step fastboot oem unlock #5 and the screen shows choices. i accidentally chose device unlock operation aborted, the down arrow. now it wont go off this text screen. how can i reboot this xoom?
8th March 2011, 03:30 PM |#8  
Senior Member
Thanks Meter: 6
disregard, i pressed the volume UP and power, tablet is rebooting now.
13th March 2011, 11:57 PM |#9  
Senior Member
Thanks Meter: 17
Hey worked great for me only problem is that it wiped my xoom...probably said that somewhere in the instructions and i just missed it. Anyway Thanks.
14th March 2011, 04:40 AM |#10  
js042507's Avatar
OP Senior Member
Thanks Meter: 208
Yeah sorry. I should put that on the tutorial. But im pretty sure any method of rooting the xoom will wipe it. Only because you have to unlock the device. Until we receive clockwork, this is the only way. Im glad you were successful with my guide though!

Sent from the most 'Epic' phone in the world! ...Using XDA Premium app :)
15th March 2011, 03:23 PM |#11  
Junior Member
Thanks Meter: 0
Screen Stuck At Starting FastBoot Protocol Dont Know How Long This Screen Stays Up Or Have I Done Something Wrong I Downloded FastBoot Already And Put It In My Sdk Folder Can Someone Pleas Help Me
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes