Remove All Ads from XDA

VERY very long shot...

886 posts
Thanks Meter: 151
By Sage, Senior Member on 8th March 2011, 04:40 AM
Post Reply Email Thread
Hi all,

Love my HTC Desire so much i bought a Witstech A81E Android 2.2 Tablet. Which is pretty buggy to say the least though on the whole works well.

The one thing that is driving me crazy is a number of apps dont install with the logcat error:

"packagename.apk requires unavailable shared library"

Now from what i have read apparently this device does not come with Google Maps API so my question is how do i add it?

Can it be done? Do i need to modify a ROM to do it? can i push it via adb or apk?

A little help would be greatly appreciated.
8th March 2011, 05:39 AM |#2  
Senior Member
Flag Boynton Beach, FL
Thanks Meter: 30
It would need to have google apps installed to be able to access the libraries. Best bet is to find out if it has been rooted yet and try to install the proprietary applications they can't ship the device with.
8th March 2011, 09:47 PM |#3  
appreciate the help mate. i've rooted the device though where can i find google maps api?

the unit already has google maps 5.0 installed but apparently doesnt have the API's.

Any idea what im looking for? will it be an APK or just some files i need to put in a system folder?

i think im over my head
8th March 2011, 10:33 PM |#4  
additionally i have searched for any related data on my desire and have found the following:




/data/dalvik-cache/ es.dex

could it be as easy as copying this over to my tablet?

Ill try it out tonight.
9th March 2011, 01:49 AM |#5  
Senior Member
Flag Boynton Beach, FL
Thanks Meter: 30
If the application is installed correctly it should work because the api is stored in the data. Is the application on the tablet installed to the /system/ or /data/ partition. It might be looking for the data in /system/
9th March 2011, 08:39 AM |#6  
not sure what you mean about where the application resides? you mean the app i am trying to install? The app i am trying to install is Tasker.

i have been doing some googling and saw someone else have the same problem and he managed to fix it:


When trying to install some apps, I would see this error message in logcat:

requires unavailable shared library

I had the Google Maps app installed and working, but that didn’t fix the issue. It turns out, I had to add two other files and restart the phone. I found those files in the google zip from Cyanogenmod. It took a little fiddling, but I was able to use these instructions to remount /system in write mode. First step was to take the following two files from the google apps zip ( and put them onto my sd card.


Then to load them onto the phone, I opened the terminal emulator and ran:

mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
cp /mnt/sdcard/ /system/etc/permissions/
cp /mnt/sdcard/ /system/framework/

Then after I rebooted the phone, I was able to install apps that depend on Google Maps. I can now check bus and train times, and do all kinds of other cool stuff with maps!

i simply used root explorer to copy it across though still not working. surely someone smarter than me can tell me what i am doing wrong.

is copying with root explorer essentially the same as above?
10th March 2011, 10:01 PM |#7  
damn i could have sworn someone here would have been switched on enough to help me on this

oh well back to random googling for me.
11th March 2011, 02:17 AM |#8  
Pneuma1985's Avatar
Recognized Themer
Flag Around
Thanks Meter: 1,063
Donate to Me
Well did you try using terminal emulator? And do what he did? B/c that looks like a remount to system to me easy as pie just do what he did you can find the files with root explorer or do it on your pc doesnt really matter. You can Not achieve what he did just using root explorer you need terminal emulator!
11th March 2011, 06:05 AM |#9  
Senior Member
Thanks Meter: 36
Originally Posted by Sage

damn i could have sworn someone here would have been switched on enough to help me on this

oh well back to random googling for me.

I don't know how much it will help (or if its 100 percent true) but I was just told recently that moving a file via root explorer is the same as pushing it via adb.

sent from gv1.5 on g2
11th March 2011, 07:08 AM |#10  
youdug's Avatar
Senior Member
Thanks Meter: 2,379

Sent from Enrique Iglesias.
14th March 2011, 12:29 AM |#11  
now i am confused. can i use root explorer or not? i used root explorer and then reset the correct permissions on the files though its still not working.

I take it i can get a terminal emulator that runs on the device itself yeah?

Ill try that next.

If that fails i am going to try my first attempt at cooking a ROM

Appreciate all the help!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes