FORUMS
Remove All Ads from XDA

[TOOL/E15] [UPDATE 07/01/2013] Flashtool version 0.9.10.0 - Windows / Linux / Mac

1,065 posts
Thanks Meter: 2,751
 
Post Reply Email Thread
Hello

Flashtool can be downloaded on the Flashtool Homepage (on Installation tab)

As Flashtool was originally developped for X10, you can find a lot of information on the Original X10 Flashtool thread

Major update for 0.6.8.0 : Ability to now install CWM from Flashtool on locked bootloader for LT15/LT18.
Fastboot now works fine under linux

Major new feature :
- Fastboot toolbox for 2011 line devices.
- BL Unlock for X10 Mini/PRo and X8

Please post device related issues here in this thread
The Following 57 Users Say Thank You to Androxyde For This Useful Post: [ View ]
 
 
9th March 2011, 05:02 PM |#2  
XperianPro's Avatar
Senior Member
Flag Mars
Thanks Meter: 878
 
Donate to Me
More
But there need to be special edit for x8
jit,xrecovery and other stuff for x10 will now work on x8
The Following 2 Users Say Thank You to XperianPro For This Useful Post: [ View ] Gift XperianPro Ad-Free
9th March 2011, 05:06 PM |#3  
Asdoos's Avatar
Senior Member
Flag Stuttgart
Thanks Meter: 50
 
Donate to Me
More
Changelog:

0.2.8:

[New] The device is autodetected by the flashtool at plug / unplug
[New] If you install xRecovery from flashtool, you can reboot into recovery from flashtool too (Advanced menu)
[New] You can now backup all /system/app content (Advanced menu)
[New] You can translate all parts of the Graphical Interface (look in x10flasher_lib/langs for samples)
[Upd] Firmware screen selection offers the ability to change the folder source containing ftf files.
[Upd] Clean task now has a notion of profile that can be imported/exported for sharing
[Upd] Customize is now APK Installer. This screen has the ability to choose the folder where apk files are
[Upd] Optimize should work for any device (X10, X10mini/pro, X8)
[Upd] xRecovery should work for any device (X10, X10mini/pro, X8)
[Bug] Flashing should not anymore hang if flash goes wrong. An error should be thrown and flash aborted


Watch this
The Following 2 Users Say Thank You to Asdoos For This Useful Post: [ View ] Gift Asdoos Ad-Free
9th March 2011, 06:11 PM |#4  
cruizz's Avatar
Senior Member
Flag undefined
Thanks Meter: 20
 
More
hmmm...i hope it works, cuz i ever try use the optimize/xrecovery and it isn't work also stuck on boot...but if only for flashing it's work smoothly. i'm sure bin4ry will fixed it

regards,,,
9th March 2011, 06:17 PM |#5  
OP Recognized Developer
Flag Paris
Thanks Meter: 2,751
 
Donate to Me
More
Quote:
Originally Posted by cruizz

hmmm...i hope it works, cuz i ever try use the optimize and it isn't work

regards,,,

I hope too, I don't have any X8 so I can't test it ;)
9th March 2011, 06:54 PM |#6  
Member
Flag Somewhere in Malaysia
Thanks Meter: 10
 
More
so... if we want to use flashtool, how and where to get the firmware?
9th March 2011, 07:09 PM |#7  
Senior Member
Flag Oslo
Thanks Meter: 17
 
More
Thumbs up
I've tried it on latest SEMC rom. My phone was already rooted though and I had xrecovery installed. After you check for root you can optimize (will put on jit) and I also installed the new xrecovery.

works for x8

Edit: Install script don't work for xRecovery. It picks the right files, but the script fails.
Code:
09/054/2011 23:54:55 - INFO  - <- This level is successfully initialized
09/055/2011 23:55:02 - INFO  - Connected device : E15
09/055/2011 23:55:02 - INFO  - Installed version of busybox : BusyBox v1.15.3 (2010-02-06 17:13:19 CET) multi-call binary
09/055/2011 23:55:14 - DEBUG - <- This level is successfully initialized
09/055/2011 23:55:18 - DEBUG - Pushing .\custom\root\sysrun to /data/local/tmp/sysrun
09/055/2011 23:55:18 - DEBUG - Running .\x10flasher_lib\adb push .\custom\root\sysrun /data/local/tmp/sysrun
09/055/2011 23:55:18 - DEBUG - stderr :7 KB/s (101 bytes in 0.014s)
09/055/2011 23:55:18 - DEBUG - Pushing .\custom\root\checkperms to /data/local/tmp/runscript
09/055/2011 23:55:18 - DEBUG - Running .\x10flasher_lib\adb push .\custom\root\checkperms /data/local/tmp/runscript
09/055/2011 23:55:18 - DEBUG - stderr :0 KB/s (11 bytes in 0.011s)
09/055/2011 23:55:18 - WARN  - Please check your Phone and 'ALLOW' Superuseraccess!
09/055/2011 23:55:18 - DEBUG - Running .\x10flasher_lib\adb shell su -c 'sh /data/local/tmp/sysrun'
09/055/2011 23:55:19 - DEBUG - stdout :uid=0(root) gid=0(root)
09/055/2011 23:55:19 - INFO  - Root Access Allowed
09/055/2011 23:55:25 - INFO  - Installing xRecovery to device...
09/055/2011 23:55:25 - INFO  - Remounting system read-write
09/055/2011 23:55:25 - DEBUG - Pushing .\custom\root\sysrun to /data/local/tmp/sysrun
09/055/2011 23:55:25 - DEBUG - Running .\x10flasher_lib\adb push .\custom\root\sysrun /data/local/tmp/sysrun
09/055/2011 23:55:25 - DEBUG - stderr :10 KB/s (101 bytes in 0.009s)
09/055/2011 23:55:25 - DEBUG - Pushing .\custom\root\remount to /data/local/tmp/runscript
09/055/2011 23:55:25 - DEBUG - Running .\x10flasher_lib\adb push .\custom\root\remount /data/local/tmp/runscript
09/055/2011 23:55:25 - DEBUG - stderr :15 KB/s (156 bytes in 0.010s)
09/055/2011 23:55:25 - DEBUG - Running remount  as root thru sysrun
09/055/2011 23:55:25 - DEBUG - Running .\x10flasher_lib\adb shell su -c 'sh /data/local/tmp/sysrun'
09/055/2011 23:55:26 - INFO  - Pushing .\custom\xRecovery\xrecoveryE15.tar.gz to /data/local/tmp/xrecovery.tar.gz
09/055/2011 23:55:26 - DEBUG - Running .\x10flasher_lib\adb push .\custom\xRecovery\xrecoveryE15.tar.gz /data/local/tmp/xrecovery.tar.gz
09/055/2011 23:55:26 - DEBUG - stderr :1611 KB/s (1270848 bytes in 0.770s)
09/055/2011 23:55:27 - INFO  - Pushing .\custom\xRecovery\chargemonnew to /data/local/tmp/chargemon
09/055/2011 23:55:27 - DEBUG - Running .\x10flasher_lib\adb push .\custom\xRecovery\chargemonnew /data/local/tmp/chargemon
09/055/2011 23:55:27 - DEBUG - stderr :120 KB/s (741 bytes in 0.006s)
09/055/2011 23:55:27 - INFO  - Pushing .\custom\xRecovery\chargerE15 to /data/local/tmp/charger
09/055/2011 23:55:27 - DEBUG - Running .\x10flasher_lib\adb push .\custom\xRecovery\chargerE15 /data/local/tmp/charger
09/055/2011 23:55:27 - DEBUG - stderr :350 KB/s (14364 bytes in 0.040s)
09/055/2011 23:55:27 - INFO  - Pushing .\custom\xRecovery\sh to /data/local/tmp/sh
09/055/2011 23:55:27 - DEBUG - Running .\x10flasher_lib\adb push .\custom\xRecovery\sh /data/local/tmp/sh
09/055/2011 23:55:27 - DEBUG - stderr :1012 KB/s (735308 bytes in 0.709s)
09/055/2011 23:55:27 - DEBUG - Pushing .\custom\root\sysrun to /data/local/tmp/sysrun
09/055/2011 23:55:27 - DEBUG - Running .\x10flasher_lib\adb push .\custom\root\sysrun /data/local/tmp/sysrun
09/055/2011 23:55:28 - DEBUG - stderr :14 KB/s (101 bytes in 0.007s)
09/055/2011 23:55:28 - DEBUG - Pushing .\custom\root\installrecovery to /data/local/tmp/runscript
09/055/2011 23:55:28 - DEBUG - Running .\x10flasher_lib\adb push .\custom\root\installrecovery /data/local/tmp/runscript
09/055/2011 23:55:28 - DEBUG - stderr :56 KB/s (583 bytes in 0.010s)
09/055/2011 23:55:28 - INFO  - Running installrecovery  as root thru sysrun
09/055/2011 23:55:28 - DEBUG - Running .\x10flasher_lib\adb shell su -c 'sh /data/local/tmp/sysrun'
09/055/2011 23:55:29 - DEBUG - stdout :rm failed for -f, Read-only file system
09/055/2011 23:55:29 - DEBUG - stdout :rm failed for -f, Read-only file system
09/055/2011 23:55:29 - DEBUG - stdout :rm failed for -f, Read-only file system
09/055/2011 23:55:29 - DEBUG - stdout :rm failed for -f, Read-only file system
09/055/2011 23:55:29 - DEBUG - stdout :rm failed for -f, Read-only file system
09/055/2011 23:55:29 - INFO  - xRecovery successfully installed
hmm - 2nd time i ran the script it installed. it's the removal of the temp files that fails.

I'm happy anyways
9th March 2011, 07:12 PM |#8  
airyz's Avatar
Junior Member
Thanks Meter: 0
 
More
Wink
work on any devices?
wow, that good news
thanks..
9th March 2011, 07:49 PM |#9  
cruizz's Avatar
Senior Member
Flag undefined
Thanks Meter: 20
 
More
Quote:
Originally Posted by oisteink

I've tried it on latest SEMC rom. My phone was already rooted though and I had xrecovery installed. After you check for root you can optimize (will put on jit) and I also installed the new xrecovery.

works for x8


glad to hear that...ready to download

@airyz :semarange endi gan?
11th March 2011, 10:32 AM |#10  
Senior Member
Thanks Meter: 12
 
More
menuju TKP gan... ama ijin sedotnya.. :P
19th March 2011, 02:22 PM |#11  
Senior Member
Flag London
Thanks Meter: 15
 
More
what does iptimize do? Does it autoinstall jit v2 for x8? does it work? Thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes