Remove All Ads from XDA

[ROM] [MIUI] MIUI 1.3.11 Porting effort to the D2 (not working yet)

299 posts
Thanks Meter: 109
By casacristo, Senior Member on 15th March 2011, 03:38 PM
Post Reply Email Thread

I do not have access to a Droid2 right now so please do a NAND backup BEFORE and then try to flash my MIUI D2 ROM[/URL]

Make sure you have a .sbf file to restore the phone to factory state if this rom does not work as intended,
remember I DO NOT own a droid2 (and with the lack of donations it doesn´t look like I will be able to afford one anytime soon)
so unfortunately I can not test whether the rom works correctly, partially or not at all.


make sure you have root and clockworks recovery installed
Warning!!!! Make sure you are on 2.3.320 or 2.3.340!!!
-boot into recovery via clockworks bootstrap
-select "wipe data/factory reset"
-select "Yes -- delete all data"
-go back "powerbutton"
-select "install zip from sdcard"
-select "choose zip from sdcard"
-find and select


If the rom does not work to perfection (or at all) and you want to help with the porting effort please carry out the following steps:

1) Install the latest alpha (in this thread)
2) (optional if you want to produce a debug log but can not do so)
Before rebooting apply the following patch to enable debugging

3) From a terminal enter these commands:
adb shell stop
adb shell setprop log.redirect-stdio true
adb shell start
and in a separate terminal
 adb -d logcat
Now reboot the phone so we get some logs (hopefully)

4) Repeat the process of point 3) with
 db -s ? bugreport
5) check the contents of /sdcard/clockworkmod/ for .log files

Get me the resulting output logs... (under /sdcard/clockworkmod/ )


If you encounter errors please be as specific as you can in the error report
The Following User Says Thank You to casacristo For This Useful Post: [ View ] Gift casacristo Ad-Free
15th March 2011, 05:18 PM |#2  
Senior Member
Flag Pittsburgh
Thanks Meter: 489
Downloading now. Will put in my .02 when I get it up and running.
15th March 2011, 05:38 PM |#3  
Senior Member
Flag Pittsburgh
Thanks Meter: 489
As promising as this looks. After downloading twice and copying over twice I can't install it. I get E:Error in /sdcard/ (Status 6) Installation aborted.

Any ideas?
15th March 2011, 06:30 PM |#4  
Thornfulless Rose's Avatar
Senior Member
Thanks Meter: 1
Originally Posted by miketoasty

I get E:Error in /sdcard/ (Status 6) Installation aborted.

Same here.
15th March 2011, 07:15 PM |#5  
phrozen87's Avatar
Flag Kentucky
Thanks Meter: 14
Would love to give this a try also if the file gets fixed. There has been a lot of hype around MIUI and I'd like to see if it works any good!
15th March 2011, 07:47 PM |#6  
Seanydizzley's Avatar
Senior Member
Flag IN
Thanks Meter: 14
This really made my day. I can't wait to see what comes of this. Looks really promising.
15th March 2011, 08:42 PM |#7  
OP Senior Member
Thanks Meter: 109
Donate to Me
I think the bug is with the buidscript
I will try to fix it... stay tuned
15th March 2011, 08:50 PM |#8  
OP Senior Member
Thanks Meter: 109
Donate to Me
Open the .zip from the first posting and rename

to update-script

and the content with:

show_progress 0.500000 0
delete_recursive SYSTEM:
format SYSTEM:
format CACHE:
copy_dir PACKAGE:sdcard SDCARD:
copy_dir PACKAGE:system SYSTEM:
copy_dir PACKAGE:data DATA:

## droid2 froyo MIUI permissions ##
set_perm_recursive 0 0 0755 0644 SYSTEM:
set_perm_recursive 0 2000 0755 0755 SYSTEM:bin
set_perm 0 3003 02750 SYSTEM:bin/netcfg
set_perm 0 3004 02755 SYSTEM:bin/ping
set_perm 0 1001 04770 SYSTEM:bin/pppd-ril
set_perm 0 2000 06750 SYSTEM:bin/run-as
set_perm 0 0 06755 SYSTEM:xbin/su
set_perm_recursive 1002 1002 0755 0440 SYSTEM:etc/bluetooth
set_perm 0 0 0755 SYSTEM:etc/bluetooth
set_perm 1000 1000 0640 SYSTEM:/etc/bluetooth/auto_pairing.conf
set_perm 3002 3002 0444 SYSTEM:/etc/bluetooth/blacklist.conf
set_perm 1002 1002 0440 SYSTEM:etc/dbus.conf
set_perm 1014 2000 0550 SYSTEM:etc/dhcpcd/dhcpcd-run-hooks
set_perm 0 0 06755 SYSTEM:etc/
set_perm 0 2000 0550 SYSTEM:etc/
set_perm_recursive 0 0 0755 0555 SYSTEM:etc/ppp
set_perm_recursive 0 2000 0755 0755 SYSTEM:xbin
set_perm 0 0 06755 SYSTEM:bin/busybox
set_perm 0 0 06755 SYSTEM:bin/busybox2
set_perm 0 0 06755 SYSTEM:bin/sysinit

set_perm 0 0 06755 SYSTEM:etc/init.d/00banner
set_perm 0 0 06755 SYSTEM:etc/init.d/01sysctl
set_perm 0 0 06755 SYSTEM:etc/init.d/02firstboot
set_perm 0 0 06755 SYSTEM:etc/init.d/05modules
set_perm 0 0 06755 SYSTEM:etc/init.d/06defaulttheme
set_perm 0 0 06755 SYSTEM:etc/init.d/99complete

set_perm 0 0 06755 SYSTEM:xbin/zipalign
set_perm 0 0 06755 SYSTEM:xbin/zipalign_apks

show_progress 0.2 10

Then I am not sure if you need to sign the resulting .zip or not (try without and see what happens, if it works, or a different error)
Make sure you edit the update-script file within linux or using something like ultraedit or notepadplus

(remember guys I am working blind here as I am not likely to have a droid2 for a couple of months, I need people able to flash the different alphas and report on errors)
15th March 2011, 09:59 PM |#9  
Senior Member
Flag Pittsburgh
Thanks Meter: 489
Tried and got same error before and after signing.
15th March 2011, 10:38 PM |#10  
OP Senior Member
Thanks Meter: 109
Donate to Me
yes, the scrip has to be named update-script not updater-script

So try with the correct name and the content in my previous posting

Originally Posted by miketoasty

Tried and got same error before and after signing.

16th March 2011, 12:04 AM |#11  
Senior Member
Flag Phoenix
Thanks Meter: 14
Hyped about this ^.^
Post Reply Subscribe to Thread

droid2, miui, rom

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes