FORUMS
Remove All Ads from XDA

easy way to fix Samsung pay on non Samsung devices

276 posts
Thanks Meter: 30
 
Post Reply Email Thread
enable magisk hide on those apps in screenshot. Use xmlpak magisk mod if you don't see Samsung in play store after activating it on your watch
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190325-121257.jpg
Views:	634
Size:	156.1 KB
ID:	4730900   Click image for larger version

Name:	Screenshot_20190325-121337.png
Views:	640
Size:	221.0 KB
ID:	4730901  
 
 
25th March 2019, 08:48 PM |#2  
thaunknownartist's Avatar
Senior Member
Flag New York
Thanks Meter: 330
 
Donate to Me
More
Please edit title to state that is requires a rooted phone, a simple "[ROOT]" would be fine. Don't want to have a misleading title.
The Following User Says Thank You to thaunknownartist For This Useful Post: [ View ] Gift thaunknownartist Ad-Free
25th March 2019, 11:29 PM |#3  
Member
Thanks Meter: 12
 
More
I'm running a rooted note 9 and latest magisk, yet I don't see any of those apps in magisk hide? Not sure why
16th May 2019, 03:44 PM |#4  
ca_guri01's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 47
 
More
I have a Samsung galaxy watch 42mm and Nokia 7 Plus, i live in India, since i got the watch there is no option of Samsung pay in Galaxy wear app. I manually installed latest Samsung pay plugin ( https://www.apkmirror.com/apk/samsun...-5906-release/ ) , and changed the region to Australia and after that when i paired the watch again with galaxy wear app Samsung pay is showing in it, and i then followed the instructions in the app to set it up.

I followed the below instructions samsung pay works on my nokia 7 plus.

You do NOT need root.
But this is how you do it.


1. So first, download SDBstarterKidv1 from the following link please:
https://forum.xda-developers.com/sho...&postcount=330


WARNING: This will reset your watch, so make sure you back it up so you can restore it later.



2. Next make sure your watch is set up as follows:
- Debugging Mode turned ON
- Connect watch to WiFi and get its IP address (To find the IP address on Galaxy Watch: Settings > Connections > Wifi > Wifi Networks > [your network] > Scroll down to IP address)


3. Next, from SDBstarterKidv1 double click on 'install.bat' (it will not install, it just flashes a window, but this step is required)
4. From the subfolder data\tools double click on 'sdb.exe' (it will not install, it just flashes a window, but this step is required too)

After noting IP address of the Galaxy Watch, Launch ‘Ansicon.exe’ from sdb_2.2.60_windows-64\data\tools (this thing will open a command prompt window, and all the action is done here)

5. Type: sdb connect [IP of Galaxy Watch]

6. Look at Galaxy Watch, it will prompt you to accept a message
7. If you try the sdb connect [IP address] again, it will say "already connected". This means we are connected and good to continue.

8. Type: sdb shell and Enter

9. Copy Paste: launch_app csc-manager.csc-pre-configuration and Enter



So this lets you change the region of the watch. Now for me I changed mine to Austrailia. The code for Austrailia is XSA

Once the watch is reset, pair it back up with your phone.



10. Once pared with your phone you will need to:
- Turn on developer mode again
- Turn on debugging mode
- Turn off the watch and turn it back on again.
- You may need to wait a few minutes.



11. Once you have done this, you can open the Samsung Galaxy Wearable app and go to settings. When you scroll down you should see samsung pay.
If you dont see pay, hold down the back button (Top right button) on the watch till samsung pay opens up and follow the instuctions to set it up. But initially the Samsung pay app is not recognising my compatible Indian Debit and Credit card and not allowing me to add, i thought this might be that i had changed the region to Australia, but i tried again after an hour and then to my surprise i am able to add all my 4 cards to Samsung pay app , and it is working also, i tried a payment at NFC enabled terminal and payment works flawlessly


Enjoy your new watch with Samsung Pay enabled.
The Following User Says Thank You to ca_guri01 For This Useful Post: [ View ] Gift ca_guri01 Ad-Free
19th May 2019, 09:52 AM |#5  
Senior Member
Flag Mumbai
Thanks Meter: 91
 
More
Delete
19th May 2019, 09:57 AM |#6  
ca_guri01's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 47
 
More
Quote:
Originally Posted by Dbj.Dhaval

Delete

Sorry, My mistake, instead of APK mirror link, i entered xda link, now edited the original post, please check.
11th June 2019, 06:40 AM |#7  
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by ca_guri01

Sorry, My mistake, instead of APK mirror link, i entered xda link, now edited the original post, please check.

I followed your steps, but chose SEK as region (thinking it was Sweden). However, now it's impossible to connect to the watch again with sdb. When trying to connect, I sometimes get responses like ¥¸ºeÇþx or other strange characters

EDIT: After the reset when I changed the region, the watch was also showing cyrillic characters for the instructions. However, as soon as I connected my phone, the watch changed to english.
EDIT2: I installed Tizen Studio to get the most recent version of SDB. And after a reboot of the watch, it looks like I'm getting closer:

Code:
PS C:\tizen-studio\tools> .\sdb connect 192.168.0.199
connecting to 192.168.0.199:26101 ...
device unauthorized. Please approve on your device.
PS C:\tizen-studio\tools> .\sdb connect 192.168.0.199
192.168.0.199:26101 is already connected
PS C:\tizen-studio\tools> ./sdb shell
device unauthorized. Please check the confirmation dialog on your device.
device unauthorized. Please check the confirmation dialog on your device.
device unauthorized. Please check the confirmation dialog on your device.
EDIT 3:
I followed instructions here: https://stackoverflow.com/questions/...e-unauthorized
To delete the key, and after restarting the watch again and running sdb kill-server, I was able to connect again and get the request to confirm my computer.
Damn Samsung, why is this **** so buggy?
11th June 2019, 01:48 PM |#8  
ca_guri01's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 47
 
More
Quote:
Originally Posted by Inrego

I followed your steps, but chose SEK as region (thinking it was Sweden). However, now it's impossible to connect to the watch again with sdb. When trying to connect, I sometimes get responses like ¥¸ºeÇþx or other strange characters

EDIT: After the reset when I changed the region, the watch was also showing cyrillic characters for the instructions. However, as soon as I connected my phone, the watch changed to english.
EDIT2: I installed Tizen Studio to get the most recent version of SDB. And after a reboot of the watch, it looks like I'm getting closer:

Code:
PS C:\tizen-studio\tools> .\sdb connect 192.168.0.199
connecting to 192.168.0.199:26101 ...
device unauthorized. Please approve on your device.
PS C:\tizen-studio\tools> .\sdb connect 192.168.0.199
192.168.0.199:26101 is already connected
PS C:\tizen-studio\tools> ./sdb shell
device unauthorized. Please check the confirmation dialog on your device.
device unauthorized. Please check the confirmation dialog on your device.
device unauthorized. Please check the confirmation dialog on your device.
EDIT 3:
I followed instructions here: https://stackoverflow.com/questions/...e-unauthorized
To delete the key, and after restarting the watch again and running sdb kill-server, I was able to connect again and get the request to confirm my computer.
Damn Samsung, why is this **** so buggy?

Yeah deleteing the key is the work around, glad you get the answer

Sent from my Nokia 7 plus using XDA-Developers Legacy app
11th June 2019, 03:07 PM |#9  
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by ca_guri01

Yeah deleteing the key is the work around, glad you get the answer

Sent from my Nokia 7 plus using XDA-Developers Legacy app

Thing is, the .tizen folder didn't exist when just installing the tools from this post. Only after I installed tizen studio

Sent from my VOG-L29 using Tapatalk
11th June 2019, 03:09 PM |#10  
ca_guri01's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 47
 
More
Quote:
Originally Posted by Inrego

Thing is, the .tizen folder didn't exist when just installing the tools from this post. Only after I installed tizen studio

Sent from my VOG-L29 using Tapatalk

Strange, i don't have tizen studio, never installed, and still i have .tizen folder, make sure hidden items are shown in windows option

Sent from my Nokia 7 plus using XDA-Developers Legacy app
11th June 2019, 03:44 PM |#11  
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by ca_guri01

Strange, i don't have tizen studio, never installed, and still i have .tizen folder, make sure hidden items are shown in windows option

Sent from my Nokia 7 plus using XDA-Developers Legacy app

It is enabled. And it did show after installing Tizen Studio.
EDIT: I even ran the tools on another pc, and here's the user folder:
screenshot
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes